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1 Signal Generator Overview

In the following sections, this chapter describes the models, options, and features available for Agilent PSG
signal generators. The modes of operation, front panel user interface, as well as front and rear panel
connectors are also described.

“Signal Generator Models and Features’ on page 2
“Options’ on page 5

“Firmware Upgrades’ on page 5

“Modes of Operation” on page 7

“Front Panel” on page 9

“Front Panel Display” on page 17

“Rear Panel” on page 22

NOTE For more information about the PSG, such as data sheets, configuration guides, application

notes, frequently asked questions, technical support, software and more, visit the Agilent
PSG web page at http://www.agilent.com/find/psg.
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Signal Generator Models and Features

Table 1-1 lists the available PSG signal generator models and frequency-range options.

Table 1-1 PSG Signal Generator Models
Model Frequency Range Options
E8257D PSG analog signal generator 250 kHz to 20 GHz (Option 520)

250 kHz to 40 GHz (Option 540)
250 kHz to 50 GHz (Option 550)

250 kHz to 67 GHz? (Option 567)

E8267D PSG vector signal generator 250 kHz to 20 GHz (Option 520)

250 kHz to 31.8 GHz (Option 532)
250 kHz to 44 GHz (Option 544)

a. functional, but unspecified, above 67 GHz to 70 GHz

E8257D PSG Analog Signal Generator Features
The E8257D PSG includes the following standard features:

CW output from 250 kHz to the highest operating frequency, depending on the option
frequency resolution to 0.001 Hz

list and step sweep of frequency and amplitude, with multiple trigger sources

user flatness correction

external diode detector leveling

automatic leveling control (ALC) on and off modes; power calibration in ALC-off modeis available,
even without power search

10 MHz reference oscillator with external output
RS-232, GPIB, and 10Base-T LAN |/O interfaces

a source module interface that is compatible with Agilent 83550 Series millimeter-wave source modules
for frequency extension up to 110 GHz and Oleson Microwave Labs (OML) AG-Series millimeter-wave
modules for frequency extensions up to 325 GHz

The E8257D PSG also offers the following optional features:

Option 007—anal og ramp sweep

Chapter 1
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Option UNR—enhanced phase noise performance

Option UNT—AM, FM, phase modulation, and L F output

* open-loop or closed-loop AM

e dc-synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency

e external modulation inputs for AM, FM, and ®M

e simultaneous modul ation configurations (except: FM with ®M or Linear AM with Exponential AM)

e dual function generators that include the following:

— 50-ohm low-frequency output, 0 to 3 Vp, available through the LF output

— selectable waveforms: sine, dual-sine, swept-sine, triangle, positive ramp, negative ramp, square,
uniform noise, Gaussian noise, and dc

— adjustable frequency modulation rates

— selectable triggering in list and step sweep modes: free run (auto), trigger key (single), bus
(remote), and external

Option UNU—pulse modulation

e internal pulse generator
e external modulation inputs

« sdlectable pulse modes: internal square, internal free-run, internal triggered, internal doublet, internal
gated, and external pulse; internal triggered, internal doublet, and internal gated require an
external trigger source

e adjustable pulse rate

e adjustable pulse period

e adjustable pulse width (150 ns minimum)

e adjustable pulse delay

« selectable external pulsetriggering: positive or negative

Option UNW—narrow pulse modulation

e generate narrow pulses (20 ns minimum) across the operational frequency band of the PSG
¢ includes all the same functionality as Option UNU

Option 1EA—high output power

Option 1E1—step attenuator
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Option 1IED—Type-N female RF output connector

Option 1EH—improved harmonics below 2 GHz

Option IEM—moves all front panel connectorsto the rear panel
E8267D PSG Vector Signal Generator Features

The E8267D PSG provides the same standard functionality of the E8257D PSG, and adds the following
standard features:

e internal I/Q modulator

e externa analog I/Q inputs

» single-ended and differential analog 1/Q outputs
» high output power (optional for the E8257D)

e step attenuator (optional for the E8257D)

The E8267D PSG offers the same optional functionality of the E8257D PSG, and adds the following
optional features:

Option 601—internal baseband generator with 8 megasamples of memory
Option 602—internal baseband generator with 64 megasamples of memory
Option 003—PSG digital output connectivity with N5102A

Option 004—PSG digital input connectivity with N5102A

Option 005—6 GB internal hard drive

Option 015—wideband external 1/Q inputs

4 Chapter 1
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Options

PSG signal generators have hardware, firmware, software, and documentation options. The Data Sheet
shipped with your signal generator provides an overview of available options. For more information, visit
the Agilent PSG web page at http://www.agilent.conm/find/psg, where you can select the desired PSG model
and then click View price list. The price list provides you with a current list of available options for the
selected model.

Firmware Upgrades

You can upgrade the firmware in your signal generator whenever new firmwareisreleased. New firmware
releases, which can be downloaded from the Agilent website, may contain signal generator features and
functionality not available in previous firmware releases.

To inquire about the availability of new signal generator firmware, visit the Agilent Firmware Upgrade
Assistant web page at http: //mwww.agilent.conVfind/upgradeassistant, or call the number listed at
http: /imww.agilent.com/find/assist.

To Upgrade Firmware

The following procedure shows you how to download new firmware to your PSG using aL AN connection
and aPC. For information on equipment requirements and alternate methods of downloading firmware, such
as GPIB, refer to the PSG/ESG Firnmware Upgrade Guide, which can be accessed at

http: //mww.agilent.com/find/upgradeassistant.

1. NotetheIP address of your signal generator. To view the IP address on the PSG, press Utility >
GPIB/RS-232 LAN > LAN Setup.

2. Usean internet browser to visit http://mww.agilent.com/find/upgradeassistant.

3. Scroll down to “Documents and Downloads” and click E82x7D PSG, NEW Firmware C.xx.xx. This opens
another web page where you must make the same selection.

4. Scroll down to “Documents and Downloads” and click E82x7D PSG, NEW Firmware C.XX.XX.
In the File Download window, select Run this program from its current location and click OK.

6. Inthe Security Warning window, click Yes and follow the on-screen instructions. The firmware files
download to the PC. When you click Finish, the browser displays the NEW Firmware page.

7. Inthe browser, click the Back button to return to the Firmware Upgrade Assistant page.
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8. Inthe“Documents and Downloads’ table, click PSG/ESG Upgrade Assistant x.xx, and download the
Upgrade Assistant.

9. At the desktop shortcut prompt, click Yes.

10. Oncethe utility downloads, close the browser and double-click the PSG/ESG Upgrade Assistant icon on the
desktop.

11. In the Upgrade Assistant, set the connection type you wish to use to download the firmware, and the
parameters for the type of connection selected. For LAN, enter the instrument’s | P address, which you
recorded in step 1.

NOTE If the PSG’s dynamic host configuration protocol (DHCP) is enabled, the network assigns
the instrument an IP address at power on. Because of this, when DHCP is enabled the IP
address may be different each time you turn on the instrument. DHCP does not affect the
hostname.

12. Click Browse, and double-click the firmware revision to upgrade your signal generator.
13. In the Upgrade Assistant, click Next.

14. Once connection to the instrument is verified, click Next and follow the on-screen prompts.

NOTE Once the download starts, it cannot be aborted.
NOTE When the User Attention message appears, you must first cycle the instrument’s power,
then click OK.

When the upgrade compl etes, the Upgrade Assistant displays a summary.
15. Click OK and close the Upgrade Assistant.
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Modes of Operation

Depending on the model and installed options, the PSG signal generator provides up to four basic modes of
operation: continuous wave (CW), swept signal, analog modulation, and digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to asingle
frequency and power level. Both the E8257D and E8267D can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over arange of frequencies and/or power levels. Both the E8257D
and E8267D provide list and step sweep functionality. Option 007 adds analog ramp sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog modulation
types available depend on the installed options.

Option UNT provides AM, FM, and ®M modulations. Some of these modulations can be used together.
Options UNU and UNW provide standard and narrow pulse modul ation capability, respectively.

Digital Modulation

In this mode, the signal generator modulates a CW signal with either areal-time 1/Q signal or arbitrary 1/Q
waveform. 1/Q modulation is only available on the E8267D. An internal baseband generator
(Option 601/602) adds the following digital modulation formats:

e Custom Arb Waveform Generator mode can produce a single-modulated carrier or multiple-modul ated
carriers. Each modul ated carrier waveform must be cal culated and generated before it can be output; this
signal generation occurs on theinternal baseband generator. Once awaveform has been created, it can be
stored and recalled, which enables repeatable playback of test signals. To learn more, refer to “ Custom
Arb Waveform Generator” on page 161.

» Custom Real Time I/Q Baseband mode produces a single carrier, but it can be modulated with rea -time
datathat allows real-time control over all of the parameters that affect the signal. The single-carrier
signal that is produced can be modified by applying various data patterns, filters, symbol rates,
modulation types, and burst shapes. To learn more, refer to “ Custom Real Time I/Q Baseband” on
page 189.
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Signal Generator Overview
Modes of Operation

» Two Tone mode produces two separate continuous wave signals (or tones). The frequency spacing
between the two signals the amplitudes are adjustable. To learn more, refer to “ Two-Tone Waveform
Generator” on page 223.

» Multitone mode produces up to 64 continuous wave signals (or tones). Like Two Tone mode, the
frequency spacing between the signals and the amplitudes are adjustable. To learn more, refer to
“Multitone Waveform Generator” on page 213.

« Dual ARB modeis used to control the playback sequence of waveform segments that have been written
into the ARB memory located on the internal baseband generator. These waveforms can be generated by
the internal baseband generator using the Custom Arb Waveform Generator mode, or downloaded
through a remote interface into the ARB memory. To learn more, refer to “Using the Dual ARB
Waveform Player” on page 91.
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Front Panel

Signal Generator Overview

Front Panel

This section describes each item on the PSG front panel. Figure 1-1 shows an E8267D front panel, which
includes all items available on the E8257D as well.

Figure 1-1

Front Panel Diagram (E8267D PSG Vector Signal Generator)

0

Wﬁ?ﬁ@ [

HHEEE
O0000

9 6

0o0a

O
O
O
O

0000

-O7

G

““D O

=

N

[ /]9

/

] ]

&

o

[} E8267D only
(O— E8257D and E8267D

1. Display

2. Softkeys
3. Knob

4. Amplitude
5. Fregquency
6. Save

7. Recall

8. Trigger

9. MENUS

10. Help

11. EXT 1 INPUT
12. EXT 2INPUT
13. LFOUTPUT

14. Mod On/Off

15. ALCINPUT

16. RF On/Off

17. Numeric Keypad
18. RF OUTPUT

19. SYNC OUT 28
20. VIDEO OUT 29
21. Incr Set 30
22. GATE/ PULSE/ TRIGGER INPUT 3L
23. Arrow Keys 32
24. Hold 33
25. Return 34
26. Contrast Decrease 35
27. Contrast Increase 36

37

° 44 L0 ddlby

¢ @Jé@éég b

. Local
. Preset
. Line Power LED

LINE

. Standby LED

. SYMBOL SYNC
. DATA CLOCK

. DATA

. Q Input

. | Input

Chapter 1

({e]



Signal Generator Overview
Front Panel

1. Display

The LCD screen provides information on the current function. Information can include status indicators,
frequency and amplitude settings, and error messages. Softkeys labels are located on the right-hand side of
the display. For more detail on the front panel display, see “Front Panel Display” on page 17.

2. Softkeys
Softkeys activate the displayed function to the left of each key.

3. Knob

Usethe knob to increase or decrease anumeric value, change a highlighted digit or character, or step through
lists or select itemsin arow.

4. Amplitude

Pressing this hardkey makes amplitude the active function. You can change the output amplitude or use the
menus to configure amplitude attributes such as power search, user flatness, and leveling mode.

5. Frequency

Pressing this hardkey makes frequency the active function. You can change the output frequency or use the
menus to configure frequency attributes such as frequency multiplier, offset, and reference.

6. Save

Pressing this hardkey accesses amenu of choicesthat enable you to save datain the instrument state register.
The instrument state register is a section of memory divided into 10 sequences (numbered 0 through 9), each
containing 100 registers (numbered 00 through 99). It is used to store and recall frequency, amplitude, and
modul ation settings.

The Save hardkey provides a quick alternative to reconfiguring the signal generator through the front panel
or SCPI commands when switching between different signal configurations. Once an instrument state has
been saved, all of the frequency, amplitude, and modul ation settings can be recalled with the Recall hardkey.
For more information on saving and recalling instrument states, refer to “ Using the Instrument State
Registers’ on page 61.

7. Recall

Restores an instrument state saved in amemory register. To recall an instrument state, press Recall and enter
the desired sequence number and register number. To save a state, use the Save hardkey. For more
information on saving and recalling instrument states, refer to “Using the Instrument State Registers’ on

page 61.
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Signal Generator Overview
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8. Trigger

Initiates an immediate trigger event for afunction such as alist, step, or ramp sweep (Option 007 only).
Before this hardkey can be used to initiate a trigger event, the trigger mode must be set to Trigger Key. For
example: press the Sweep/List hardkey, then one of the following sequences of softkeys:

e More (1 of 2) > Sweep Trigger > Trigger Key
e More (1 of 2) > Point Trigger > Trigger Key

9. MENUS
These keys open softkey menus for configuring various functions. For descriptions, see the Key Reference.
Table 1-2 Hardkeys in Front Panel MENUS Group
E8257D PSG Analog E8267D PSG Vector

AM Mode FM/®M

Sweep/List Mux Utility

FM/®M AM 17Q

Utility Sweep/List Pulse

Pulse Mode Setup LF Out

LF Out Aux Fctn
NOTE Some menus are optional. Refer to “Options’ on page 5 for more information.
10. Help

Pressing this hardkey accesses a short description of any hardkey or softkey and, in most cases, alisting of
related remote-operation SCPI commands. There are two help modes available on the signal generator:
single and continuous. The single mode is the factory preset condition. Toggle between single and
continuous mode by pressing Utility > Instrument Info/Help Mode > Help Mode Single Cont.

» Insingle mode, help text is provided for the next key you press without activating the key’s function.
Any key pressed afterward exits the help mode and its function is activated.

» Incontinuous mode, help text is provided for each subsequent key press until you press the Help hardkey
again or change to single mode. In addition, each key is active, meaning that the key function is executed
(except for the Preset key).
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Signal Generator Overview
Front Panel

11. EXT 1 INPUT

This female BNC input connector (functional only with Options UNT, UNU, or UNW) acceptsa+1V,
signal for AM, FM, and ®M. For these modulations, +1 V , produces the indicated deviation or depth. When
ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by more

than 3 percent, the HI/L O display annunciators light. The input impedance is selectable as either 50 or 600
ohms; the damage levelsare 5 Vs and 10 V,. On signal generators with Option 1EM, this connector is

relocated to the rear panel.

12. EXT 2 INPUT

This female BNC input connector (functional only with Options UNT, UNU, or UNW) acceptsa+1V,
signa for AM, FM, and ®M. With AM, FM, or ®M, +1 V|, produces the indicated deviation or depth. When
ac-coupled inputs are selected for AM, FM, or ®M and the peak input voltage differs from 1V, by more
than 3 percent, the HI/L O annunciatorslight on the display. Theinput impedanceis sel ectable as either 50 or
600 ohms and damage levels are 5 Vs and 10 V,. On signal generators with Option 1EM, thisinput is
relocated to the rear panel.

13. LF OUTPUT

This female BNC output connector (functional only with Option UNT) outputs modulation signals
generated by the low frequency (LF) source function generator. This output is capable of driving
3V, (nominal) into a50-ohm load. On signal generators with Option 1EM, this output is relocated to the rear

panel.

14. Mod On/0ff

This hardkey (E8257D with Options UNT, UNU, or UNW and E8267D only) enables or disables al active
modulation formats (AM, FM, ®M, Pulse, or 1/Q) applied to the output carrier signal available through the
RF Output connector. This hardkey does not set up or activate an AM, FM, ®M, Pulse, or I/Q format; each
modulation format must still be set up and activated (for example, AM > AM 0On) or nothing is applied to the
output carrier signal when the Mod On/0ff hardkey is enabled. The MOD QN GFF annunciator indicates
whether active modulation formats have been enabled or disabled with the Mod On/0ff hardkey.

15. ALC INPUT

Thisfemale BNC input connector is used for negative external detector leveling. This connector accepts an
input of —0.2 mV to —0.5 V. The nominal input impedance is 120 kohms and the damage level is+15V. On
signal generators with Option 1EM, thisinput isrelocated to the rear panel.
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16. RF On/Off

Pressing this hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector.
Although you can set up and enabl e various frequency, power, and modulation states, the RF and microwave
output signal is not present at the RF OUTPUT until RF On/0ff is set to On. The RF On/0ff annunciator is
always visible in the display to indicate whether the RF is turned on or off.

17. Numeric Keypad

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace hardkey
( ). The backspace hardkey enables you to backspace or alternate between a positive and a negative

value. When specifying a negative numeric value, the negative sign must be entered prior to entering the
numeric value.

18. RF OUTPUT

This connector outputs RF and microwave signals. The nominal output impedance is 50 ohms. The
reverse-power damage levels are 0 Vdc, 0.5 watts nominal. On signal generators with Option 1EM, this
output is relocated on the rear panel. The connector type varies according to frequency option.

19. SYNC OUT

Thisfemale BNC output connector (functional only with Options UNU or UNW) outputs a synchronizing
TTL-compatible pulse signal that is nominally 50 ns wide during internal and triggered pulse modulation.
The nominal source impedance is 50 ohms. On signal generators with Option 1EM, this output is rel ocated
to the rear panel.

20. VIDEO OUT

This female BNC output connector (functional only with Options UNU or UNW) outputsa TTL-level
compatible pulse signal that follows the output envelope in all pulse modes. The nominal source impedance
is 50 ohms. On signal generators with Option 1EM, this output is relocated to the rear panel.

21. Incr Set

This hardkey enables you to set the increment value of the current active function. The increment value of
the current active function appears in the active entry area of the display. Use the numeric keypad, arrow
hardkeys, or the knob to adjust the increment value.
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22. GATE/ PULSE/ TRIGGER INPUT

Thisfemale BNC input connector (functional only with Options UNU or UNW) accepts an externally
supplied pulse signal for use as a pulse or trigger input. With pulse modulation, +1V isonand 0V is off
(trigger threshold of 0.5 V with a hysteresis of 10 percent; so 0.6 V would be on and 0.4 VV would be off).
The damage levels are +5 Vg and 10 V.. The nominal input impedance is 50 ohms. On signal generators

with Option 1EM, thisinput is rel ocated to the rear panel.

23. Arrow Keys

These up and down arrow hardkeys are used to increase or decrease a numeric value, step through displayed
lists, or to select itemsin arow of adisplayed list. Individual digits or characters may be highlighted using
the left and right arrow hardkeys. Once an individual digit or character is highlighted, its value can be
changed using the up and down arrow hardkeys.

24. Hold

Pressing this hardkey blanks the softkey label area and text areas on the display. Softkeys, arrow hardkeys,
the knob, the numeric keypad, and the Incr Set hardkey have no effect once this hardkey is pressed.

25. Return

Pressing this hardkey returns you to the softkey menu you were at previoudly. It enables you to step back
through the menus until you reach the first menu you selected.

26. Contrast Decrease

Pressing this hardkey causes the display background to darken.

27. Contrast Increase

Pressing this hardkey causes the display background to lighten.

28. Local

Pressing this hardkey deactivates remote operation and returns the signal generator to front-panel control.

29. Preset

Pressing this hardkey sets the signal generator to a known state (factory or user-defined).

30. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.
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31. LINE

In the on position, this switch activates full power to the signal generator; in standby, it deactivates all signal
generator functions. In standby, the signal generator remains connected to the line power and power is
supplied to some internal circuits.

32. Standby LED

Thisyellow LED indicates when the signal generator power switch is set to the standby condition.

33. SYMBOL SYNC

Thisfemale BNC input connector (E8267D only) is CMOS-compatible and accepts an externally supplied
symbol sync signal for use with the internal baseband generator (Option 601/602). The expected input isa
3.3V CMOS hit clock signal (whichisaso TTL compatible). SYMBOL SYNC might occur once per
symbol or be a single one-bit-wide pulse that is used to synchronize the first bit of the first symbol. The
maximum clock rateis 50 MHz. The damagelevelsare > +5.5 V and < —0.5V. The nominal input impedance
is not definable. SYMBOL SYNC can be used in two modes:

*  When used as a symbol sync in conjunction with a data clock, the signal must be high during the first
data bit of the symbol. The signal must be valid during the falling edge of the data clock signal and may
be a single pulse or continuous.

*  When the SYMBOL SYNC itself is used as the (symbol) clock, the CMOS falling edge is used to clock
the DATA signal.

On signal generators with Option 1EM, thisinput is relocated to the rear panel.

34. DATA CLOCK

Thisfemale BNC input connector (E8267D only) is CMOS compatible and accepts an externally supplied
data-clock input signal to synchronize serial data for use with the internal baseband generator (Option
601/602). The expected input isa 3.3 V CMOS hit clock signal (whichisaso TTL compatible) where the
rising edge is aligned with the beginning data bit. The falling edge is used to clock the DATA and SYMBOL
SYNC signals. The maximum clock rate is 50 MHz. The damage levelsare > +5.5V and < -0.5V. The
nominal input impedanceis not definable. On signal generators with Option 1EM, thisinput is relocated to
the rear panel.
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35. DATA

This female BNC input connector (E8267D with Option 601/602 only) is CMOS compatible and accepts an
externally supplied serial datainput for digital modulation applications. The expected input isa 3.3V
CMOS signal (whichisalso TTL compatible) wherea CMOS high = adata 1 and aCMOS low = adata 0.
The maximum input data rate is 50 Mb/s. The data must be valid on the falling edges of the data clock
(normal mode) or the on the falling edges of the symbol sync (symbol mode). The damage levels are

> +5.5 and < —0.5V. The nominal input impedance is not definable. On signal generators with Option 1EM,
thisinput isrelocated to the rear panel.

36. Q Input

Thisfemale BNC input connector (E8267D only) accepts the quadrature-phase (Q) component an externally
supplied, analog, 1/Q modulation. The in-phase (1) component is supplied through the | INPUT. The signal

level is [, > =0.5Vmsfor acalibrated output level. The nominal input impedanceis 50 or 600 ohms.
The damage level is 1V ynsand 10 V ey To activate signals applied to the | and Q input connectors, press

Mux > 1/Q Source 1 or 1/Q Source 2 and then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with
Option 1EM, these inputs are relocated to the rear panel.

37. 1 Input

Thisfemale BNC input connector (E8267D only) accepts the in-phase (I) component an externally supplied,
analog, 1/Q modulation. The quadrature-phase (Q) component is supplied through the Q INPUT. The signal

level is /7. > =0.5Vmsfor acalibrated output level. The nominal input impedanceis 50 or 600 ohms.
The damage level is 1V ynsand 10 V ey To activate signals applied to the | and Q input connectors, press

Mux > 1/Q Source 1 or 1/Q Source 2 and then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with
Option 1EM, these inputs are relocated to the rear panel.
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Front Panel Display

Figure 1-2 shows the various regions of the PSG display. This section describes each region.

Figure 1-2 Front Panel Display Diagram
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1. Active Entry Area

The current active function is shown in thisarea. For example, if frequency isthe active function, the current
frequency setting will be displayed here. If the current active function has an increment val ue associated
with it, that value is also displayed.

2. Frequency Area

The current frequency setting is shown in this portion of the display. Indicators are also displayed in thisarea
when the frequency offset or multiplier is used, the frequency reference mode is turned on, or a source
moduleis enabled.

3. Annunciators

The display annunciators show the status of some of the signal generator functions and indicate any error
conditions. An annunciator position may be used by more than one function. This does not create a problem,
because only one function that shares an annunciator position can be active at atime.

oM Thisannunciator (Option UNT only) appears when phase modulation ison. If frequency
modulation is on, the FMannunciator replaces ®M

ALC OFF This annunciator appears when the ALC circuit is disabled. A second annunciator,
UNLEVEL, appearsin the same position if the ALC is enabled and cannot maintain the
output level.

AM This annunciator (Option UNT only) appears when amplitude modulation is on.

ARMED This annunciator appears when a sweep has been initiated and the signal generator is

waiting for the sweep trigger event.

ATTEN HOLD This annunciator (Option 1E1 or E8267D only) appears when the attenuator hold
function is on. When thisfunction is on, the attenuator is held at its current setting.

DI G BUS This annunciator (Options 003 or 004 only) appears when the Digital Busis active, and
the internal oven reference oscillator is not cold (OVEN QOOLD appears in this same
location).

ENVLP This annunciator appearsif a burst condition exists, such as when marker 2 is set to

enable RF blanking in the Dual ARB format.

ERR This annunciator appears when an error message is in the error queue. This annunciator
does not turn off until you either view all the error messages or cleared the error queue.
To access error messages, press Utility > Error Info.

EXT This annunciator appears when external leveling ison.

EXT1 LOH This annunciator (Options UNT, UNU, or UNW only) appears as either EXT1 LOor
EXT1 H, when the ac-coupled signal to the EXT 1 INPUT is<0.97 V, or >1.03 V.
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This annunciator (Options UNT, UNU, or UNW only) isdisplayed as either EXT2 LO
or EXT2 H . Thisannunciator appears when the ac-coupled signal to the EXT 2 INPUT
is<0.97 Vpor >1.03 V.

This annunciator appears when an external frequency referenceis applied.

This annunciator (Option UNT only) appears when frequency modulation isturned on.
If phase modulation is turned on, the ®Mannunciator will replace FM

This annunciator (E8267D only) appears when 1/Q modulation is turned on.

This annunciator appears when the signal generator isin listener mode and is receiving
information or commands over the RS-232, GPIB, or VXI-11 LAN interface.

This annunciator (E8257D with Options UNT, UNU, or UNW and E8267D only)
indicates whether active modulation formats have been enabled or disabled. Pressing
the Mod On/0ff hardkey enables or disables all active modulation formats (AM, FM,
@M, Pulse, or 1/Q) that are applied to the output carrier signal available through the RF
Output connector. The Mod On/0ff hardkey does not set up or activate an AM, FM, ®M,
Pulse, or 1/Q format; each individual modulation format must still be set up and
activated (for example, AM > AM 0On) or nothing will be applied to the output carrier
signal when the Mod On/0ff hardkey is enabled.

Thisannunciator (Option UNR only) appears when the temperature of the internal oven
reference oscillator has dropped below an acceptable level. When this annunciator ison,
frequency accuracy is degraded. This condition should occur for several minutes after
the signal generator isfirst connected to line power.

This annunciator (Options UNU or UNW only) appears when pulse modulation is on.

This annunciator appears when the signal generator is remotely controlled over the
GPIB, RS-232, or VX1-11/Sockets LAN interface (TELNET operation does not activate
the R annunciator). When the R annunciator is on, the front panel keys are disabled,
except for the Local key and the line power switch. For information on remote
operation, refer to the Programming Guide.

Thisannunciator indicates when the RF and microwave signal ispresent (RF QN) at the
RF OUTPUT, or if the RF and microwave signa is not present (RF OFF) at the RF
OUTPUT. Either condition of this annunciator is always visible in the display.

This annunciator appears when the signal generator has generated a service reguest
(SRQ) over the RS-232, GPIB, or VXI-11 LAN interface.

Chapter 1
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SWEEP This annunciator appears when the signal generator isin list, step, or ramp sweep mode
(ramp sweep is available with Option 007 only). List mode is when the signal generator
can jump from point to point in alist (hop list); the list is traversed in ascending or
descending order. Thelist can be afrequency list, a power level list, or both. Step mode
iswhen a start, stop, and step value (frequency or power level) are defined and the
signal generator produces signals that start at the start value and increment by the step
value until it reaches the stop value. Ramp sweep mode (Option 007 only) iswhen a
start and stop value (frequency or power level) are defined and the signal generator
produces signals that start at the start value and produce a continuous output until it
reaches the stop value.

T Thisannunciator appears when the signal generator isin talker mode and istransmitting
information over the GPIB, RS-232, or VXI-11 LAN interface.

UNLEVEL This annunciator appears when the signal generator is unable to maintain the correct
output level. The UNLEVEL annunciator is not necessarily an indication of instrument
failure. Unleveled conditions can occur during normal operation. A second annunciator,
ALC OFF, will appear in the same position when the ALC circuit is disabled.

UNLOCK This annunciator appears when any of the phase |ocked |oops are unable to maintain
phase lock. You can determine which loop is unlocked by examining the error

messages.
4. Digital Modulation Annunciators

All digital modulation annunciators (E8267D with Option 601/602 only) appear in thislocation. These
annunciators appear only when the modulation is active, and only one digital modulation can be active at
any given time.

ARB Dual Arbitrary Waveform Generator M TONE  Multitone Waveform Generator
CQUSTOM  Custom Real Time I/Q Baseband T-TONE Two-Tone Waveform Generator
Dl GMD  Custom Arb Waveform Generator

5. Amplitude Area

The current output power level setting is shown in this portion of the display. Indicators are also displayed in
this area when amplitude offset is used, amplitude reference mode is turned on, external leveling mode is
enabled, a source module is enabled, and when user flatnessis enabled.
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6. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the most
recent message remains displayed. Reported error messages with details can be viewed by pressing Utility >
Error Info.

7. Text Area
This text area of the display:

» showssignal generator status information, such as the modulation status, sweep lists, and file catalogs

» displaysthetables

» enablesyou to perform functions such as managing information, entering information, and displaying or
deleting files

8. Softkey Label Area

The labelsin this area define the function of the softkeys located immediately to the right of the label. The
softkey label may change depending upon the function selected.
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Rear Panel

This section describes each item on the PSG rear panel. Figure 1-3 shows a standard E8267D rear panel.
Figure 1-4 on page 23 shows an E8267D rear panel with Option 1EM. Option 1EM moves all front panel
connectorsto the real panel. Both rear panel figures include al items available on the E8257D as well.

Figure 1-3 Standard Rear Panel Diagram

11121]13]14]]|5 6|7 81(9] [10][11] [12]|13] |14| (15

E8257D and E8267D

oo S84 455000 \

1. EVENT1 10. 1 OUT 19. 10 MHz IN

2.EVENT 2 11. Q OUT 20. AUXILIARY INTERFACE
3. PATTERN TRIG IN 12. I-bar OUT 21. 10 MHz OUT

4. BURST GATE IN 13. Q-bar OUT 22.LAN

5. BASEBAND GEN REF IN 14. COH CARRIER 23. STOP SWEEP IN/OUT

6. DIGITAL BUS 15. SOURCE MODULE INTERFACE 24. Z-AX1S BLANK/MKRS

7. AUXILIARY 1/0 16. AC Power Receptacle 25. SWEEP OUT

8. WIDEBAND | INPUT 17. GPIB 26. TRIGGER OUT

9. WIDEBAND Q INPUT 18. 10 MHz EFC 27. TRIGGER IN

28. SOURCE SETTLED

22 Chapter 1



Figure 1-4

Option 1EM Rear Panel Diagram
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1.EVENT 1

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602);
on signal generators without Option 601/602, this female BNC connector is non-functional .

In real-time mode, the EVENT 1 connector outputs a pattern or frame synchronization pulse for triggering
or gating external equipment. It may be set to start at the beginning of a pattern, frame, or timeslot and is
adjustable to within + one timeslot with one bit resolution.

In arbitrary waveform mode, the EVENT 1 connector outputs atiming signal generated by Marker 1. A
marker (3.3 V CMOS high for both positive and negative polarity) is output on the EVENT 1 connector
whenever aMarker 1 isturned on in the waveform.

The reverse damage levels for this connector are > +8 V and < -4 V. The nominal output impedance is not
defined.

2. EVENT 2

Thisfemale BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602);
on signal generators without Option 601/602, this female BNC connector is non-functional.

In real-time mode, the EVENT 2 connector outputs a data enable signal for gating external equipment. This
is applicable when external datais clocked into internally generated timeslots. Datais enabled when the
signal islow.

In arbitrary waveform mode, the EVENT 2 connector outputs atiming signal generated by Marker 2. A
marker (3.3 V CMOS high for both positive and negative polarity) is output on the EVENT 2 connector
whenever aMarker 2 isturned on in the waveform.

The reverse damage levels for this connector are > +8 V and < —4 V. The nominal output impedance is not
definable.

3. PATTERN TRIG IN

Thisfemale BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602);
on signal generators without Option 601/602, this female BNC connector is non-functional. This connector
acceptsasignal that triggers an internal pattern or frame generator to start a single-pattern output. Minimum
pulse width is 100 ns. Damage levelsare > +5.5 V and < —0.5 V. The nominal input impedance is not
definable.
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4. BURST GATE IN

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602).
On signal generators without Option 601/602, this connector is hon-functional. This connector accepts a
3-volt CMOS input signal for gating burst power. Burst gating is used when you are externally supplying
data and clock information.

Theinput signal must be synchronized with the external datainput that will be output during the burst. The
burst power envelope and modulated data are internally delayed and re-synchronized. The input signal must
be CMOS high for normal burst RF power or CW RF output power and CMOS low for RF off. Damage
levelsare > +5.5V and < —-0.5 V. The nominal input impedance is not definable.

5. BASEBAND GEN REF IN

This female BNC connector (E8267D only) is used with an internal baseband generator (Option 601/602);
on signal generators without Option 601/602, this female BNC connector is non-functional. This connector
accepts a0to +20 dBm sine wave or TTL square wave signal from an external timebase reference. This
external timebase reference clock is used by the internal baseband generator for both component and
receiver test applications (only the internal baseband generator can be locked to this external reference; the
RF frequency remains locked to the 10 MHz reference).

This connector accepts rates from 250 kHz through 100 MHz; the nominal input impedance is 50 ohms at
13 MHz, ac-coupled. Theinternal clock for the arbitrary waveform generator islocked to this signal when
external referenceis selected in the ARB setup. The minimum pulse width must be > 10 ns. The damage
levelsare>+8V and < -8 V.

6. DIGITAL BUS

Thisisaproprietary bus used for Agilent Baseband Studio products, which require an E8267D with
Options 003/004 and 601/602. This connector is not operational for general-purpose customer use. Signals
are present only when a Baseband Studio option isinstalled (for details, refer to

http: /imww.agilent.com/find/basebandstudio). The DI G BUS annunciator appears on the display when the
Digital Busisactive (and the internal oven reference oscillator is not cold—OVEN OCOLD appearsin this
same location).
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7. AUXILIARY 170

This female 37-pin connector

(E8267D only) is active only on instruments with an internal baseband

generator (Option 601/602); on signal generators without Option 601/602, this connector is non-functional.
This connector provides access to the inputs and outputs described in the following figure.

Figure 1-5 Auxiliary 1/0 Connector (Female 37-Pin)

View looking into
rear panel connector
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PARALLEL DATA 7* —
GND —
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GND —

GND —

GND —

OPEN—]
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*Future capability
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EVENT 3: Used with an internal baseband generator. In arbitrary waveform mode,
this pin outputs a timing signal generated by Marker 3. A marker (3.3 V CMOS
high for both positive and negative polarity) is output on this pin when a Marker 3 is
turned on in the waveform. Reverse damage levels: > +8 V and < -4 V.

EVENT 4: Used with an internal baseband generator. In arbitrary
waveform mode, this pin outputs a timing signal generated by
Marker 4. A marker (3.3V CMOS high for both positive and
negative polarity) is output on this pin when a Marker 4 is turned
on in the waveform. Reverse damage levels: > +8 V and < -4 V.

F—EVENT 3 PATT TRIG IN 2: Accepts a signal that triggers an
— EVENT 4 / internal pattern or frame generator to start single
pattern output. Minimum pulse width: 100 ns.

—PATTTRIGIN 2

Damage levels: > +5.5V and < -0.5 V.
—ALT PWR IN \
[— PARALLEL DATA1® ALT PWR IN: Used with an internal baseband
—GND generator. This pin accepts a CMOS signal for
—GND synchronization of external data and alternate power
—GND signal timing. Damage levels are > +8 V and < -4 V.
— GND
— GND
— PARALLEL DATA 8*
— PARALLEL DATA CLK*

| DATAOUT/ DATA OUT: Used with an internal baseband generator.
This pin outputs data (CMOS) from the internal data

— DATACLK oUT generator or the externally supplied signal at data input.
— SYM SYNC OUT
—OPEN DATA CLK OUT: Used with an internal baseband

—GND generator. This pin relays a CMOS bit clock signal for
— GND synchronizing serial data.
— OPEN

SYM SYNC OUT: Used with an internal baseband
generator. This pin outputs the CMOS symbol clock for
symbol synchronization, one data clock period wide.
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8. WIDEBAND I INPUT

This female BNC connector (E8267D only) is used with wideband external 1/Q inputs (Option 015). It
accepts wideband AM and allows direct high—bandwidth analog inputs to the I/Q modulator in the

3.2-44 GHz range (frequency limit is dependant on the option). Thisinput is not calibrated. The
recommended power level at the input is0 dBm with a+/— 1 volt maximum amplitude. On signal generators
without Option 015, this connector is non-functional. The nominal impedance for this connector is 50 ohms.

The signal generator uses lowside mixing in the 20-28.5 GHz fregquency range (Options 532 and 544),
which reverses the phase relationship for | and Q signals. For internally generated 1/Q signals the signal
generator’s firmware compensates for this. However, for wideband externa 1/Q inputs (Option 015) there is
no compensation and the | and Q inputs at the rear panel must be swapped to maintain the correct phase
relationships in this frequency band. Refer to the A37 Upconverter section in the PSG User’s Guide and
Option 015 data sheet for more information.

9. WIDEBAND Q INPUT

Thisfemale BNC connector (E8267D only) is used with wideband external 1/Q inputs (Option 015); on
signal generators without Option 015, this female BNC connector is non—functional. The female BNC
connector allows direct high—bandwidth analog inputs to the 1/Q modulator in the 3.2 to 44 GHz frequency
range (frequency limit is dependant on the option). Thisinput is not calibrated. The recommended power
level at theinput is 0 dBm with a+/— 1 volt maximum amplitude. The nominal impedance for this connector
is 50 ohms. Refer to the above description for the wideband | input for more information.

10. 1 OUT

Thisfemale BNC connector (E8267D only) can be used with an internal baseband generator (Option
601/602) to output the anal og, in-phase component of I/Q modulation; on signal generators without Option
601/602, this female BNC connector can be used to output the in-phase component of an external 1/Q
modulation that has been fed into the | input connector. The nominal output impedance of thel OUT
connector is 50 ohms, dc-coupled.

11.Q OUT

This female BNC connector (E8267D only) can be used with an internal baseband generator (Option
601/602) to output the anal og, quadrature-phase component of 1/Q modulation; on signal generators without
Option 601/602, this female BNC connector can be used to output the quadrature-phase component of an
external 1/Q modulation that has been fed into the Q input connector. The nominal output impedance of the
Q OUT connector is 50 ohms, dc-coupled.

12. I-bar OUT

Thisfemale BNC connector (E8267D only) can be used with an internal baseband generator (Option
601/602) to output the complement of the anal og, in-phase component of 1/Q modulation; on signal
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generators without Option 601/602, thisfemale BNC connector can be used to output the complement of the
in-phase component of an external 1/Q modulation that has been fed into the | input connector.

I-bar OUT isused in conjunction with | OUT to provide a balanced baseband stimulus. Balanced signals are
signals present in two separate conductors that are symmetrical relative to ground and are opposite in
polarity (180 degrees out of phase). The nominal output impedance of the I-bar OUT connector is 50 ohms,
dc-coupled.

13. Q-bar OUT

This female BNC connector (E8267D only) can be used with an internal baseband generator (Option
601/602) to output the complement of the analog, quadrature-phase component of 1/Q modulation; on signal
generators without Option 601/602, this female BNC connector can be used to output the complement of the
guadrature-phase component of an external 1/Q modulation that has been fed into the Q input connector.

Q-bar OUT isused in conjunction with Q OUT to provide a balanced baseband stimulus. Balanced signals
are signals present in two separate conductors that are symmetrical relative to ground and are oppositein
polarity (180 degrees out of phase). The nominal output impedance of the Q-bar OUT connector is 50 ohms,
dc-coupled.

14. COH CARRIER

Thisfemale SMA connector (E8267D with Option UNT only) outputs an RF signal that is phase coherent
with the signal generator carrier. The coherent carrier connector outputs RF that is not modulated with AM,
pulse, or 1/Q modulation, but is modulated with FM or ®M (when FM or ®M are on).

The output power is nominally 0 dBm. The output frequency range is from 249.99900001 MHz to 3.2 GHz;
this output is not useful for output frequencies > 3.2 GHz. If the RF output frequency is below
249.99900001 MHz, the coherent carrier output signal will have the following frequency:

Frequency of coherent carrier = (1E9 - Frequency of RF output) in Hz.

Damage levels are 20 Vdc and 13 dBm reverse RF power. The nominal output impedance of this connector
is 50 ohms.

15. SOURCE MODULE INTERFACE

Thisinterface is used to connect to compatible Agilent Technol ogies 83550 Series mm-wave source
modules.

16. AC Power Receptacle

The ac line voltage is connected here. The power cord receptacl e accepts a three-pronged power cable that is
shipped with the signal generator.
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17. GPIB

This GPIB interface allows listen and talk capability with compatible |EEE 488.2 devices.

18. 10 MHz EFC

Thisfemale BNC input connector accepts an external dc voltage, ranging from -5V to +5'V, for electronic
frequency control (EFC) of theinternal 10 MHz reference oscillator. This voltage inversely tunesthe
oscillator about its center frequency approximately —0.0025 ppm/V. The nominal input impedance is greater
than 1 Mohms. When not in use, this connector should be shorted using the supplied shorting cap to assure a
stable operating frequency. This connector is available only with Option UNR.

19. 10 MHz IN

This female BNC connector accepts an external timebase reference input signal level of > -3 dBm. The
reference must be 1, 2, 2.5, 5, or 10 MHz, within £1 ppm. The signal generator detects when avalid
reference signal is present at this connector and automatically switches from internal to external reference
operation.

For Option UNR, this BNC connector accepts asignal with anominal input level of 5+5 dBm. The external
frequency reference must be 10 MHz, within £1 ppm.

The nominal input impedance is 50 ohms with a damage level of = 10 dBm.
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20. AUXILIARY INTERFACE

This 9-pin D-subminiature femal e connector is an RS-232 serial port that can be used for serial
communication and Master/Slave source synchronization.

Table 1-3 Auxiliary Interface Connector
Pin Number Signal Description Signal Name

1 No Connection
2 Receive Data RECV
3 Transmit Data XMIT
4 +5V
5 Ground, OV
6 No Connection
7 Request to Send RTS
8 Clear to Send CTS
9 No Connection

Figure 1-6

S5e¢ 4o 3e

9¢ 8¢ 78 6e

21. 10 MHz OUT

This female BNC connector outputs a nominal signal level of > +4 dBm and has an output impedance of

2e 1o View looking into
rear panel connector

50 ohms. The accuracy is determined by the timebase used.

22. LAN

ThisLAN interface alows ethernet local area network communication through a10Base-T LAN cable. The
yellow LED on the interface illuminates when data transmission (transfer/receive) is present. The green

LED illuminates when thereis a delay in data transmission or no data transmission is present.
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23. STOP SWEEP IN/OUT

Thisfemale BNC connector (Option 007 only) provides an open-collector, TTL-compatible input/output
signal that is used during ramp sweep operation. It provides low-level (nominally 0 V) output during sweep
retrace and band-cross intervals. It provides high-level (nominally +5 V) output during the forward portion
of sweep. Sweep stops when this input/output connector is grounded externally. When operating as an input,
the nominal impedance for this connector is less than 10 ohms. When operating as an output, the nominal
impedance is approximately 4.2 kohms.

24. Z-AXIS BLANK/MKRS

Thisfemale BNC connector (Option 007 only) suppliesa+5 V (nominal) level during retrace and
band-switch intervals of astep, list, or ramp sweep. During ramp sweep, this female BNC connector
suppliesa—5 V (nominal) level when the RF frequency is at a marker frequency and intensity marker mode
ison. Thissignal is derived from an operational amplifier output so the load impedance should be greater
than or equal to 5 kohms. This connection is most commonly used to interface with an Agilent 8757D scalar
network analyzer.

25. SWEEP OUT

This female BNC connector outputs a voltage proportional to the RF power or frequency sweep ranging
from OV at the start of sweep and goesto +10 V (nominal) at the end of sweep, regardless of sweep width.

The nominal output impedanceis less than 1 ohm and can drive a 2-kohm load.

When connected to an Agilent Technologies 8757D network analyzer, it generates a sel ectable number of
equally spaced 1 ms 10 V pulses (nominal) across a ramp (analog) sweep. The number of pulses can be set
from 101 to 1601 by remote control through the 8757D.

26. TRIGGER OUT

Thisfemale BNC connector, in step/list sweep mode, outputsa TTL signal that is high at the start of adwell
seguence or when waiting for a point trigger in manual sweep mode. The signal is low when the dwell is
over or when a point trigger isreceived. In ramp sweep mode, the output provides 1601 equally spaced 1 s
pulses (hominal) across aramp sweep. When using LF Out, the output provides a 2 ps pulse at the start of
LF sweep. The nominal impedance for this connector isless than 10 ohms.

27. TRIGGER IN

This female BNC connector accepts a 3.3V CMOS signal, which is used for point-to-point triggering in
manual sweep mode, or in an low-frequency (LF output) or analog (AM, FM, and ®M) externa sweep
trigger setup. Triggering can occur on either the positive or negative edge of the signal start. The damage
level is< -4V or =2 +10 V. The nominal input impedance for this connector is approximately 4.2 kohms.
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28. SOURCE SETTLED

This female BNC connector provides a 3-volt CMOS output trigger, indicating when the signal generator
has settled to a new frequency or power level. A high indicates that the source has not settled. A low
indicates that the source has settled. The nominal output impedance for this connector is less than 10 ohms.

29. RF OUT

On standard instruments, this connector resides on the front panel.

“18. RFOUTPUT” on page 13.

30. EXT 1 Input

On standard instruments, this connector resides on the front panel.

“11. EXT 1 INPUT” on page 12.

31. EXT 2 Input

On standard instruments, this connector resides on the front panel.

“12. EXT 2INPUT” on page 12.

32. LF OUT

On standard instruments, this connector resides on the front panel.

“13. LFOUTPUT” on page 12.

33. PULSE SYNC OUT

On standard instruments, this connector resides on the front panel.

“19. SYNC OUT” on page 13.

34. PULSE VIDEO OUT

On standard instruments, this connector resides on the front panel.

“20. VIDEO OUT” on page 13.

35. PULSE/TRIG GATE INPUT

On standard instruments, this connector resides on the front panel.

“22. GATE/ PULSE/ TRIGGER INPUT” on page 14.

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see
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36. ALC INPUT

On standard instruments, this connector resides on the front panel.

“15. ALCINPUT” on page 12.

37. DATA

On standard instruments, this connector resides on the front panel.

“35. DATA” on page 16.

38. DATA CLOCK

On standard instruments, this connector resides on the front panel.

“34. DATA CLOCK” on page 15.

39. SYMBOL SYNC

On standard instruments, this connector resides on the front panel.

“33. SYMBOL SYNC” on page 15.

40. | Input

On standard instruments, this connector resides on the front panel.

“37. 1 Input” on page 16.

41. Q Input

On standard instruments, this connector resides on the front panel.

“36. Q Input” on page 16.

Signal Generator Overview
Rear Panel

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see

For a description of this connector, see
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2 Basic Operation

In the following sections, this chapter describes operations common to all Agilent PSG signal generators:

“Using Table Editors’” on page 36

“Configuring a Continuous Wave RF Output” on page 38
“Configuring a Swept RF Output” on page 41

“Using Ramp Sweep (Option 007)” on page 46
“Extending the Frequency Range” on page 56

“Turning On a Modulation Format” on page 57
“Applying aModulation Format to the RF Output” on page 58
“Using Data Storage Functions” on page 59

“Using the Instrument State Registers’ on page 61
“Using Security Functions’ on page 64

“Enabling Options” on page 71

“Using the Web Server” on page 73
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Using Table Editors

Table editors simplify configuration tasks, such as creating alist sweep. This section provides information to
familiarize you with basic table editor functionality using the List Mode Values table editor as an example.

Press Preset > Sweep/List > Configure List Sweep.

The signal generator displays the List Mode Values table editor, as shown below.

Figure 2-1
Active Function Area Cursor
\
FREDUENCY AMPLITY )
Edit It
20.000 000 000 000 &+ | -135.00 dn .
’7 ﬂ Insert Row
Oelete Rou
List Mode Values
Frequency / Pouer Duell
] 1 = HH= -20.00 dem 100 ms Goto RowqK
2
Inzert Item
5
6 .
7 . 00000000
8 530, 00000000 belete Item
9 575. 00000000
LI 10 587, 50000000 Hare
7 (1 of 2)
Table Name Table Items Table Softkeys
Active Function Area displays the active table item whileits value is edited
Cursor an inverse video identifier used to highlight specific table itemsfor
selection and editing
Table Softkeys select table items, preset table values, and modify table structures
Table Items values arranged in numbered rows and titled columns (The columns

are also known as data fields. For example, the column below the
Frequency titleis known as the Frequency datafield).
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Table Editor Softkeys

The following table editor softkeys are used to load, navigate, modify, and store table item values.

Edit Item

Insert Row
Delete Row

Goto Row

Insert Item
Delete Item

Page Up and
Page Down

More (1 of 2)
Load/Store

displays the selected item in the active function area of the display where theitem’s
value can be modified

inserts an identical row of table items above the currently selected row
deletes the currently selected row

opens amenu of softkeys (Enter, Goto Top Row, Goto Middle Row, Goto Bottom Row, Page Up,
and Page Down) used to quickly navigate through the table items

inserts an identical item in a new row below the currently selected item

deletes the item from the bottom row of the currently selected column

displays table items that occupy rows outside the limits of the ten-row table display area
accesses Load/Store and its associated softkeys

opens amenu of softkeys (Load From Selected File, Store To File, Delete File, Goto Row, Page
Up, and Page Down) used to load table items from afile in the memory catalog, or to
store the current table items as afile in the memory catalog

Modifying Table Items in the Data Fields

1. If not aready displayed, open the List Mode Values table editor (shown in Figure 2-1 on page 36):
Press Preset > Sweep/List > Configure List Sweep

2. Usethe arrow keys or the knob to move the table cursor over the desired item.

In Figure 2-1, the first item in the Frequency datafield is selected.

3. PressEdit Item.

The selected item is displayed in the active function area of the display.

4. Usethe knob, arrow keys, or the numeric keypad to modify the value.

Press Enter.

The modified item is now displayed in the table.

Chapter 2
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Configuring the RF Output

This section provides information on how to create continuous wave and swept RF (on page 41) outputs. It
also has information on using a mm-Wave source module to extend the signal generator’s frequency range
(see page 56).

Configuring a Continuous Wave RF Output

These procedures demonstrate how to set the following parameters:

* RF output frequency

» frequency reference and frequency offset (on page 39)
* RF output amplitude (on page 40)

» amplitude reference and amplitude offset (page 40)

Setting the RF Output Frequency
Set the RF output frequency to 700 MHz, and increment or decrement the output frequency in 1 MHz steps.

1. Returnthe signal generator to the factory-defined state: Press Preset.

NOTE You can change the preset condition of the signal generator to a user-defined state. For these
examples, however, use the factory-defined preset state (set the Preset Normal User softkey
in the Utility menu to Normal).

2. Observe the FREQUENCY area of the display (in the upper left-hand corner).
The value displayed is the maximum specified frequency of the signal generator.
3. PressRF On/0ff.

The RF On/0ff hardkey must be pressed before the RF signal is available at the

RF OUTPUT connector. The display annunciator changes from R CGFF to RF ON. The maximum
specified frequency should be output at the RF OUTPUT connector (at the signal generator’s minimum
power level).

4. PressFrequency > 700 > MHz.

The 700 MHz RF frequency should be displayed in the FREQUENCY area of the display and also in the
active entry area.

5. PressFrequency > Incr Set > 1 > MHz.

This changes the frequency increment valueto 1 MHz.
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Press the up arrow key.

Each press of the up arrow key increases the frequency by the increment value last set with the Incr Set
hardkey. The increment valueis displayed in the active entry area.

The down arrow decreases the frequency by the increment value set in the previous step. Practice
stepping the frequency up and down in 1 MHz increments.

You can also adjust the RF output frequency using the knob. Aslong as frequency isthe active function
(the frequency is displayed in the active entry ared), the knob will increase and decrease the RF output
frequency.

Use the knob to adjust the frequency back to 700 MHz.

Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency to which all other frequency
settings are relative. When the frequency reference is set, the display will read 0. 00 Hz (the frequency
output of the signal generator’s hardware minus the reference frequency). Although the display changes, the
actual frequency output is 700 MHz (from step 8 above). Any subsequent frequency changes are shown as
increments or decrements to the O Hz reference.

The Frequency Reference Set function is not an active function. Once it is set, any change to the frequency
setting appears as a frequency reading on the signal generator’s front-panel display. For example,

1
2.

Preset the signal generator: Press Preset.

Set the frequency reference to 700 MHz:
Press. Frequency > 700 > MHz > More (1 of 3) > Freq Ref Set.

This activates the frequency reference mode, sets the output frequency (700 MHz) as the reference
value, and toggles the Freq Ref softkey On. The FREQUENCY areadisplays 0. 000 Hz. Thisreading isthe
frequency output of the signal generator’s hardware (700 MHz) minus the reference value (700 MHz).
The signal generator’s true output frequency is 700 MHz. If the Freq Ref softkey istoggled to Off, the
front-panel will indicate the actual frequency: 700 MHz. The REF indicator appears on the front-panel
display and the Freq Ref Off On softkey togglesto On.

Turn on the RF output: Press RF On/0ff.

The display annunciator changes from RF OFF to RF ON. The RF frequency at the RF OUTPUT
connector is 700 MHz.

Set the frequency increment value to 1 MHz: Press Frequency > Incr Set > 1 > MHz.
Increment the output frequency by 1 MHz: Press the up arrow key.

The FREQUENCY area display changes to show 1.000 000 000 MHz, which is the frequency output by
the hardware (700 MHz + 1 MHz) minus the reference frequency (700 MHz). The frequency at the RF
OUTPUT changesto 701 MHz.
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Enter a1 MHz offset: Press More (1 of 3) > Freq Offset > 1 > MHz.

The FREQUENCY areadisplays2. 000 000 00 MHz, which isthe frequency output by the hardware
(701 MHz) minus the reference frequency (700 MHz) plus the offset (1 MHZz). The OFFS indicator
activates. The frequency at the RF OUTPUT connector isstill 701 MHz.

Setting the RF Qutput Amplitude

1

Preset the signal generator: Press Preset.

The AMPLI TUDE area of the display shows the minimum power level of the signal generator. Thisisthe
normal preset RF output amplitude.

Turn on the RF output: Press RF On/Off.
The display annunciator changesto RF ONL At the RF OUTPUT connector, the RF signal isoutput at the
minimum power level.

Change the amplitude to —20 dBm: Press Amplitude > —20 > dBm.

The new output power displaysin the AMPLI TUDE area of the display and in the active entry area. Until
you press adifferent front panel function key, amplitude remains the active function. You can also
change the amplitude using the up and down arrow keys or the knob.

Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to which all other amplitude
parameters are relative. The amplitude initially shown on the display is 0 dB (the power output by the
hardware minus the reference power). Although the display changes, the output power does not change. Any
subsequent power changes are shown as incremental or decremental to 0 dB.

1. PressPreset.
2. Set the amplitude to —20 dBm: Press Amplitude > -20 > dBm.
3. Activate the amplitude reference mode and set the current output power (—20 dBm) as the reference
value: Press More (1 of 2) > Ampl Ref Set.
The AMPLI TUDE areadisplays 0. 00 dB, which isthe power output by the hardware (—20 dBm) minus
the reference value (—20 dBm). The REF indicator activates and the Ampl Ref Off On softkey toggles On.
4. Turn the RF output on: Press RF On/Off.
The display annunciator changesto RF O\ The power at the RF OUTPUT connector is—20 dBm.
5. Change the amplitude increment value to 10 dB: Press Incr Set > 10 > dB.
6. Usethe up arrow key to increase the output power by 10 dB.
The AMPLI TUDE areadisplays 10. 00 dB, which is the power output by the hardware
(-20 dBm plus 10 dBm) minus the reference power (—20 dBm). The power at the RF OUTPUT
connector changesto —10 dBm.
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7. Enter a10 dB offset: Press Ampl Offset > 10 > dB.

The AMPLI TUDE areadisplays 20. 00 dB, which isthe power output by the hardware (=10 dBm) minus
the reference power (—20 dBm) plus the offset (10 dB). The OFFS indicator activates. The power at the
RF OUTPUT connector is still =10 dBm.

Configuring a Swept RF Output
A PSG signal generator has up to three sweep types: step sweep, list sweep, and ramp sweep (Option 007).

The signal generator indicates the sweep advance in a progress bar on the front-panel display. If the sweep
time is greater than one second, the progress bar sweep advances according to the frequency span of each
segment. For each segment in the span, the progress bar displays the full segment and then the sweep is
taken. With sweep times less than one second, the progress bar is drawn, the sweep taken, and the progress
bar is then blanked.

NOTE List sweep data cannot be saved within an instrument state, but can be saved to the memory
catalog. For instructions on saving list sweep data, see “ Storing Files to the Memory
Catalog” on page 60.

During swept RF output, the FREQUENCY and AMPLI TUDE areas of the signal generator’s
display are deactivated, depending on what is being swept.

Step sweep (see page 42) and ramp sweep (see page 43) provide a linear progression through the
start-to-stop frequency and/or amplitude values, while list sweep enables you to create alist of arbitrary
frequency, amplitude, and dwell time values and sweep the RF output based on that list.

The list sweep example uses the points created in the step sweep example asthe basis for anew list sweep.

Ramp sweep (see page 46) is faster than step or list sweep, and is designed to work with an 8757D scalar
network analyzer.

The signal generator provides a softkey, Sweep Retrace Off On, that lets you configure single sweep behavior.
When sweep retrace is on, the signal generator will retrace the sweep to the first point of the sweep. If the
sweep retrace is off, the sweep will stop and remain on the last point in the sweep.

Activating Scalar Pulse in Sweep Configurations

If your sweep setup uses a scalar network analyzer and a DC detector, the PSG must modul ate the swept
signal with a 27 kHz square wave, also referred to as a scalar pulse. This pulse modulation is necessary for
the DC detector to properly detect the swept signal. If the PSG is controlled by an 8757D through a GPIB
connection, the scalar pulse automatically turns on when DC detection is selected on the 8757D. When using
any other scalar analyzer, you can manually turn on the scalar pulse using either one of the following
key-press sequences:
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Press Sweep/List > Sweep Type > Scalar Pulse Off On to On
or

Press Pulse > Pulse Source > Scalar > Pulse Off On to On

Using Step Sweep

Step sweep provides alinear progression through the start-to-stop frequency and/or amplitude values. You
can toggle the direction of the sweep, up or down. When the Sweep Direction Down Up softkey is set to Up,
values are swept from the start amplitude/frequency to the stop amplitude/frequency. When set to Down,
values are swept from the stop amplitude/frequency to the start amplitude/frequency.

When a step sweep is activated, the signal generator sweeps the RF output based on the values entered for
RF output start and stop frequencies and amplitudes, a number of equally spaced points (steps) to dwell
upon, and the amount of dwell time at each point; dwell time is the minimum period of time after the settling
time that the signal generator will remain at its current state. The frequency, amplitude, or frequency and
amplitude of the RF output will sweep from the start amplitude/frequency to the stop amplitude/frequency,
dwelling at equally spaced intervals defined by the # Points softkey value.

To Configure a Single Step Sweep
In this procedure, you create a step sweep with nine, equally-spaced points, and the following parameters:

» frequency range from 500 MHz to 600 MHz
e amplitude from =20 dBmto 0 dBm
e dwell time 500 ms at each point

1. PressPreset.

2. Press Sweep/List.
This opens a menu of sweep softkeys.

3. Press Sweep Repeat Single Cont.
This toggles the sweep repeat from continuous to single.

4. Press Configure Step Sweep.

5. PressFreq Start > 500 > MHz.
This changes the start frequency of the step sweep to 500 MHz.

6. PressFreq Stop > 600 > MHz.
This changes the stop frequency of the step sweep to 600 MHz.

7. Press Ampl Start > -20 > dBm.
This changes the amplitude level for the start of the step sweep.

8. Press Ampl Stop > 0 > dBm.
This changes the amplitude level for the end of the step sweep.
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9. Press# Points > 9 > Enter.
This sets the number of sweep pointsto nine.

10. Press Step Dwell > 500 > msec.
This sets the dwell time at each point to 500 milliseconds.

11. Press Return > Sweep > Freq & Ampl.

This sets the step sweep to sweep both frequency and amplitude data. Selecting this softkey returns you
to the previous menu and turns on the sweep function.

12. Press RF On/Off.
The display annunciator changes from RF OFF to RF ON.

13. Press Single Sweep.

A single sweep of the frequencies and amplitudes configured in the step sweep is executed and available
at the RF OUTPUT connector. On the display, the SWEEP annunciator appears for the duration of the
sweep and a progress bar shows the progression of the sweep. The Single Sweep softkey can aso be used
to abort a sweep in progress. To see the frequencies sweep again, press Single Sweep to trigger the

Sweep.

To Configure a Continuous Step Sweep
Press Sweep Repeat Single Cont.

Thistoggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes
configured in the step sweep are now available at the RF OUTPUT connector. The SWEEP annunciator
appears on the display, indicating that the signal generator is sweeping and progression of the sweep is
shown by a progress bar.

Using List Sweep

List sweep enables you to create alist of arbitrary frequency, amplitude, and dwell time values and sweep
the RF output based on the entriesin the List Mode Values table.

Unlike a step sweep that contains linear ascending/descending frequency and amplitude values, spaced at
equal intervals throughout the sweep, list sweep frequencies and amplitudes can be entered at unequal
intervals, nonlinear ascending/descending, or random order.

For convenience, the List Mode Values table can be copied from a previously configured step sweep. Each
step sweep point’s associated frequency, amplitude and dwell time values are entered into arow in the List
Mode Values table, as the following exampleillustrates.

To Configure a Single List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the sweep information by editing
severa pointsin the List Mode Values table. For information on using tables, see “Using Table Editors’ on

page 36.
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Press Sweep Repeat Single Cont.

This toggles the sweep repeat from continuous to single. The SWEEP annunciator is turned off. The
sweep will not occur until it istriggered.

Press Sweep Type List Step.
Thistoggles the sweep type from step to list.
Press Configure List Sweep.

This opens another menu displaying softkeys that you will use to create the sweep points. The display
shows the current list data. (When no list has been previoudly created, the default list contains one point
set to the signal generator’s maximum freguency, minimum amplitude, and a dwell time of 2 ms.)

Press More (1 of 2) > Load List From Step Sweep > Confirm Load From Step Data.

The points you defined in the step sweep are automatically loaded into the list.

To Edit List Sweep Points

1. PressReturn > Sweep > Off.
Turning the sweep off allows you to edit the list sweep points without generating errors. If sweep
remains on during editing, errors occur whenever one or two point parameters (frequency, power, and
dwell) are undefined.

2. Press Configure List Sweep.
This returns you to the sweep list table.

3. Usethearrow keysto highlight the dwell timein row 1.

4. PressEdit Item.
The dwell time for point 1 becomes the active function.

5. Press 100 > msec.
This enters 100 ms as the new dwell time value for row 1. Note that the next item in the table (in this
case, the frequency value for point 2) becomes highlighted after you press the terminator softkey.

6. Using the arrow keys, highlight the frequency valuein row 4.

7. PressEdit Item > 545 > MHz.
This changes the frequency value in row 4 to 545 MHz.

8. Highlight any column in the point 7 row and press Insert Row.
This adds a new point between points 7 and 8. A copy of the point 7 row is placed between points 7 and
8, creating a new point 8, and renumbering the successive points.

9. Highlight the frequency item for point 8, then press Insert Item.
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Pressing Insert Item shifts frequency values down one row, beginning at point 8. Note that the original
frequency values for both points 8 and 9 shift down one row, creating an entry for point 10 that contains
only afrequency value (the power and dwell time items do not shift down).

The frequency for point 8 is still active.
10. Press 590 > MHz.
11. Press Insert Item > -2.5 > dBm.

Thisinserts anew power value at point 8 and shifts down the original power values for points 8 and 9 by
one row.

12. Highlight the dwell time for point 9, then press Insert Item.
A duplicate of the highlighted dwell timeisinserted for point 9, shifting the existing value down to
complete the entry for point 10.

To Configure a Single List Sweep

1. PressReturn > Sweep > Freq & Ampl

Thisturnsthe sweep on again. No errors should occur if all parametersfor every point have been defined
in the previous editing process.

2. PressSingle Sweep.

The signal generator will single sweep the pointsin your list. The SWEEP annunciator activates during
the sweep.

3. Press More (1 of 2) > Sweep Trigger > Trigger Key.

This sets the sweep trigger to occur when you press the Trigger hardkey.
4. Press More (2 of 2) > Single Sweep.

This arms the sweep. The ARMED annunciator is activated.
5. Pressthe Trigger hardkey.

The signal generator will single sweep the points in your list and the SWEEP annunciator will be
activated during the sweep.
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To Configure a Continuous List Sweep
Press Sweep Repeat Single Cont.

Thistoggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes
configured in the list sweep are now available at the RF OUTPUT connector. The SWEEP annunciator
appears on the display, indicating that the signal generator is sweeping and progression of the sweep is
shown by a progress bar.

Using Ramp Sweep (Option 007)

Ramp sweep provides alinear progression through the start-to-stop frequency and/or amplitude values.
Ramp sweep is much faster than step or list sweep, and is designed to work with an 8757D scalar network
analyzer. This section describes the ramp sweep capabilities available in PSG signal generators with Option
007. You will learn how to use basic ramp sweep, and how to configure aramp sweep for a master/slave
setup (see page 54).

Refer to the Programming Guide for an example program that uses pass-thru commands in aramp sweep
system (pass-thru commands enable you to temporarily interrupt ramp sweep system interaction so that you
can send operating instructions to the PSG).

Using Basic Ramp Sweep Functions

This procedure demonstrates the following tasks (each task builds on the previous task):

» “Configuring a Frequency Sweep” on page 47

» “Using Markers’ on page 49

e “Adjusting Sweep Time” on page 51

» “Using Alternate Sweep” on page 52

» “Configuring an Amplitude Sweep” on page 53
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Configuring a Frequency Sweep
1. Set up the equipment as shown in Figure 2-2.
NOTE The PSG signal generator is not compatible with the GPIB system interface of an 8757A,

8757C, or 8757E. For these older scalar network analyzers, do not connect the GPIB cable
in Figure 2-2. This method provides only a subset of 8757D functionality. See the PSG
Data Sheet for details. Use the 8757A/C/E documentation instead of this procedure.

Figure 2-2 Equipment Setup
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2. Turn on both the 8757D and the PSG.
3. Onthe 8757D, press System > More > Sweep Mode and verify that the SYSINTF softkey is set to ON.

This ensures that the system interface mode is activated on the 8757D. The system interface mode
enables the instruments to work as a system.

4. Press Utility > GPIB/RS-232 LAN to view the PSG’s GPIB address under the GPIB Address softkey. If you
want to change it, press GPIB Address and change the value.

5. Onthe8757D, press LOCAL > SWEEPER and check the GPIB address. If it does not match that of the PSG,
change the value.
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6. Preset either instrument.

Presetting one of the instruments should automatically preset the other aswell. If both instruments do
not preset, check the GPIB connection, GPIB addresses, and ensure the 8757D is set to system interface
mode (SYSINTF set to ON).

The PSG automatically activates a2 GHz to maximum frequency ramp sweep with a constant amplitude
of 0 dBm. Notice that the RF ON, SWEEP, and PULSE annunciators appear on the PSG display. The
PUL SE annunciator appears because the 8757D is operating in AC mode.

The PSG also switches its remote language setting to 8757D System, allowing the PSG to talk to the
8757D during ramp sweep operations. You can confirm this by pressing Utility > GPIB/RS-232 LAN and
observing the selection under the Remote Language softkey.

NOTE During swept RF output, the FREQUENCY and/or AMPLI TUDE areas of the signal
generator’s display are deactivated, depending on what is being swept. In this case, since
frequency is being swept, nothing appears in the FREQUENCY area of the display.

7. PressFrequency > Freq CW.
The current continuous wave frequency setting now controls the RF output and ramp sweep is turned off.
8. PressFreq Start.

The ramp sweep settings once again control the RF output and the CW mode is turned off. Pressing any
one of the softkeys Freq Start, Freq Stop, Freq Center, or Freq Span activates aramp sweep with the current
settings.

NOTE In afrequency ramp sweep, the start frequency must be lower than the stop frequency.

9. Adjust the settings for Freq Center and Freq Span so that the frequency response of the device under test
(DUT) is clearly seen on the 8757D display.

Notice how adjusting these settings al so changes the settings for the Freq Start and Freq Stop softkeys. You
may need to rescal e the response on the 8757D for a more accurate eval uation of the amplitude. Figure
2-3 on page 49 shows an exampl e of a bandpass filter response.
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Figure 2-3 Bandpass Filter Response on 8757D
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Using Markers

1. Press Markers.

This opens atable editor and associated marker control softkeys. You can use up to 10 different markers,
labeled 0 through 9.

2. Press Marker Freq and select a frequency value within the range of your sweep.

In the table editor, notice how the state for marker 0 automatically turns on. The marker also appears on
the 8757D display.

3. Usethearrow keysto move the cursor in the table editor to marker 1 and select afrequency value within
the range of your sweep, but different from marker O.

Notice that marker 1 is activated and is the currently selected marker, indicated by the marker arrow
pointing down. Asyou switch between markers, using the arrow keys, you will notice that the selected
marker’s arrow points down, while all others point up.

Notice also that the frequency and amplitude data for the currently selected marker is displayed on the
8757D.
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4. Move the cursor back to marker 0 and press Delta Ref Set > Marker Delta Off On to On.

In the table editor, notice that the frequency values for each marker are now relative to marker 0. Ref
appearsin the far right column (also labeled Ref ) to indicate which marker is the reference. Refer to

Figure 2-4.

Figure 2-4
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Move the cursor back to marker 1 and press Marker Freq. Turn the front panel knob while observing
marker 1 on the 8757D.

On the 8757D, natice that the displayed amplitude and frequency values for marker 1 arerelative to
marker 0 as the marker moves along the trace. Refer to Figure 2-5.
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Figure 2-5 Delta Markers on 8757D
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6. PressTurn Off Markers.
All active markers turn off. Refer to the Key Reference for information on other marker softkey
functions.

Adjusting Sweep Time

1. Press Sweep/List.

This opens a menu of sweep control softkeys and displays a status screen summarizing all the current
sweep settings.

2. Press Configure Ramp/Step Sweep.
Since ramp is the current sweep type, softkeysin this menu specifically control ramp sweep settings.

When step is the selected sweep type, the softkeys control step sweep settings. Notice that the Freq Start
and Freq Stop softkeys appear in this menu in addition to the Frequency hardkey menu.
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Press Sweep Time to Manual > 5 > sec.

In auto mode, the sweep time automatically setsto the fastest alowable value. In manual mode, you can
select any sweep time slower than the fastest allowable. The fastest allowable sweep time is dependent
on the number of trace points and channels being used on the 8757D and the frequency span.

Press Sweep Time to Auto.

The sweep time returns to its fastest allowabl e setting.

NOTE When using an 8757 network analyzer in manual sweep mode, you must activate the signal

generator’s Manual Freq softkey before using the front panel knob to control the sweep.
Press Sweep/List > More (2 of 3) > Manual Freq

Using Alter nate Sweep

1

Press the Save hardkey.

This opens the table editor and softkey menu for saving instrument states. Notice that the Select Reg
softkey is active. (For more information on saving instrument states refer to “Using the Instrument State
Registers’ on page 61.)

Turn the front panel knob until you find an available register and press SAVE. Remember this saved
register number. If no registers are available, you can write over an in-use register, by pressing Re-SAVE.

NOTE When you are using the PSG in a system with an 8757 network analyzer, you are limited to

using registers 1 through 9 in sequence O for saving and recalling states.

3.

Press Sweep/List > Configure Ramp/Step Sweep and enter new start and stop frequency valuesfor the ramp
sweep.

Press Alternate Sweep Register and turn the front panel knob to select the register number of the
previously saved sweep state.

Press Alternate Sweep Off On to On.

The signal generator alternates between the original saved sweep and the current sweep. You may need
to adjust 8757D settingsto effectively view both sweeps, such as setting channel 2 to measure sensor A.
Refer to Figure 2-6.
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Figure 2-6 Alternating Sweeps on 8757D
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Configuring an Amplitude Sweep

1

Press Return > Sweep > Off.

Thisturns off both the current sweep and the alternate sweep from the previous task. The current CW
settings now control the RF output.

Press Configure Ramp/Step Sweep.
Using the Ampl Start and Ampl Stop softkeys, set an amplitude range to be swept.
Press Return > Sweep > Ampl.

The new amplitude ramp sweep settings control the RF output and the CW mode is turned off.
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Configuring a Ramp Sweep for a Master/Slave Setup

This procedure shows you how to configure two PSGs and an 8757D to work in a master/slave setup. The
master/slave control setup must use two instruments from the same signal generator family such as two
PSG’s, or two 83640B’s, or two 83751B's.

NOTE The master/slave setup applies to ramp sweep only, not step sweep or list sweep. To use this

setup, you must have two sources from the same signal generator family such astwo PSG's,
or two 83640B’s, or two 83751B’s.

Set up the equipment as shown in Figure 2-7. Use a 9-pin, D-subminiature, male RS-232 cable with the
pin configuration shown in Figure 2-8 on page 55 to connect the auxiliary interfaces of the two PSGs.
You can also order the cable (part number 8120-8806) from Agilent Technologies.

By connecting the master PSG’s 10 MHz reference standard to the slave PSG’s 10 MHz reference input,
the master’s timebase supplies the frequency reference for both PSGs.

Set up the dlave PSG’s frequency and power settings.

By setting up the slave first, you avoid synchronization problems.

Set up the master PSG’s frequency, power, and sweep time settings.

The two PSGs can have different frequency and power settings for ramp sweep.

Set the slave PSG'’s sweep time to match that of the master.

Sweep times must be the same for both PSGs.

Set the slave PSG to continuous triggering.

The slave must be set to continuous triggering, but the master can be set to any triggering mode.
On the dlave PSG, press Sweep/List > Sweep Type > Ramp Sweep Control > Slave.

This sets the PSG to operate in slave mode.

On the master PSG, press Sweep/List > Sweep Type > Ramp Sweep Control > Master. This sets the PSG to
operate in master mode.
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Figure 2-7 Master/Slave Equipment Setup
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Extending the Frequency Range

You can extend the signal generator frequency range using an Agilent 83550 series millimeter-wave source
module or other manufacturer’s mm-source module. Refer to “Millimeter-Wave Source Modules’ on
page 270 for information on using the signal generator with a millimeter-wave source module.
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Modulating a Signal

This section describes how to turn on a modulation format, and how to apply it to the RF output.

Turning On a Modulation Format
A modulation format can be turned on prior to or after setting the signal parameters.

1. Accessthe first menu within the modulation format.
This menu displays a softkey that associates the format’s name with off and on. For example, AM >
AM Off On. For some formats, the off/on key may appear in additional menus other than the first one.

2. Pressthe modulation format off/on key until On highlights.
Figure 2-9 shows the portion of the AM modulation format’s first menu that displays the state of the
modulation format, as well as the active modulation format annunciator.

The modulation format generates, but the carrier signal is not modulated until you apply it to the RF
output (see page 58).

Depending on the modulation format, the signal generator may require afew seconds to build the signal.
Within the digital formats (E8267D PSG with Option 601/602 only), you may see a BaseBand

Reconf i guri ng status bar appear on the display. Once the signal is generated, an annunciator showing the
name of the format appears on the display, indicating that the modulation format is active. For digital
formats (E8267D PSG with Option 601/602 only), the | / Qannunciator appearsin addition to the name of
the modulation format.

Figure 2-9 Example of AM Modulation Format Off and On
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Applying a Modulation Format to the RF Output

The carrier signal is modulated when the Mod On/0ff key is set to On, and an individual modulation format is
active.

When the Mod On/0ff key is set to Off, the MCD GFF annunciator appears on the display.When the key is set
to On, the MCD ONannunciator shows in the display, whether or not there is an active modul ation format.
The annunciators ssimply indicate whether the carrier signal will be modulated when a modulation format is
turned on.

To Turn RF Output Modulation On
Press the Mod On/0ff key until the MOD ON annunciator appears in the display.
The carrier signal should be modulated with all active modulation formats. Thisis the factory default.

To Turn RF Output Modulation Off
Press the Mod On/0ff key until the MOD OFF annunciator appearsin the display.

The carrier signal is no longer modulated or capable of being modul ated when amodulation format is active.

Figure 2-10 Carrier Signal Modulation Status
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Using Data Storage Functions

This section explains how to use the two forms of signal generator data storage: the memory catalog and the
instrument state register.

Using the Memory Catalog

The Memory Catalog isthe signal generator’s interface for viewing, storing, and saving files; it can be
accessed through the signal generator’s front panel or a remote controller. (For information on performing
these tasks remotely, see the Programming Guide.)

Table 2-1 Memory Catalog File Types and Associated Data
Binary binary data
State instrument state data (controlling instrument operating

parameters, such as frequency, amplitude, and mode)

LIST sweep data from the List Mode Values table including
frequency, amplitude, and dwell time

User Flatness user flatness calibration correction pair data (user-defined
frequency and corresponding amplitude correction values)

FIR Finite Impulse Response (FIR) filter coefficients

ARB Catalog Types (E8267D PSG with Option 601/602 only) user created files -
Waveform Catalog Types. WFM 1 (waveform file),

NVARB Catalog Types:

NVWFM (non-volatile, ARB waveform file),

NVMKR (non-volatile, ARB waveform marker file),

Seq (ARB sequencefile),

MTONE (ARB multitonefile),

DMOD (ARB digital modulation file),

MDMOD (ARB multicarrier digital modulation file)

Modulation Catalog Types (E8267D PSG with Option 601/602 only) associated datafor 1/Q
and FSK (frequency shift keying) modulation files

Shape burst shape of apulse

Bit Bit
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Storing Files to the Memory Catalog

To store afile to the memory catal og, first create afile. For this example, use the default list sweep table.

1
2.

Press Preset.

Press Sweep/List > Configure List Sweep > More (1 of 2) > Load/Store.
This opensthe “Catalog of List Files’.

Press Store to File.

This displays a menu of alphabetical softkeysfor naming thefile. St ore to: isdisplayedinthe active
function area.

Enter the filename LI ST1 using the alphabetical softkeys and the numeric keypad (for the numbers 0 to
9).

Press Enter.

Thefile should be displayed in the “ Catalog of List Files’, showing the file name, file type, file size, and
the date and time the file was modified.

Viewing Stored Files in the Memory Catalog

1

Press Utility > Memory Catalog > Catalog Type.

All filesin the memory catalog are listed in alphabetical order, regardless of which catalog type you
select. Fileinformation appears on the display and includes the file name, filetype, file size, and the date
and time the file was modified.

Press List.

The “Catalog of List Files” is displayed.

Press Catalog Type > State.

The “ Catalog of State Files” is displayed.

Press Catalog Type > All.

The “Catalog of All Files’ is displayed. For acomplete list of file types, refer to Table 2-1 on page 59.
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Using the Instrument State Registers

Theinstrument state register is a section of memory divided into 10 sequences (numbered 0 through 9) with
each sequence consisting of 100 registers (numbered 00 through 99). Instrument state sequences and
registers are used to store and recall instrument settings and provide a quick way to reconfigure the signal
generator when switching between different instrument and signal configurations. The signal generator with
Option 005 (internal hard drive) has approximately 4 GB available for storing instrument state files and
other user data. Without Option 005, the signal generator has 20 MB available for data and instrument state
storage. Instrument state files can vary in length depending on the signal generator’s configuration.

File data, such as modulation formats, arb setups, and table entries, are not stored with the save function.
Only setups such as frequency, attenuation, power and other user-defined settings that do not survive a
power cycle or instrument reset can be saved to a sequence and register. Any datafile, such as an arb format
file, associated with the instrument state will only be referenced by its file name. Once an instrument state
has been saved, recalling that state will setup the generator with the saved settings and |oad the associated
file data.

For more information on storing file data such as modulation formats, arb setups, and table entries refer to
“Storing Filesto the Memory Catalog” on page 60. Refer to the PSG Programming Guide and the PSG Key
Reference for more information on the save and recall function.

NOTE A referenceto afileis saved along with the instrument state. However, no datais saved with
the save function. You must store file data, using store commands, in a different memory
location.

Saving an Instrument State
1. Preset the signal generator, then turn on amplitude modulation (the AMannunciator will turn on):

a. PressFrequency > 800 > MHz.
b. Press Amplitude > 0 > dBm.
c. PressAM > AM Off On.

2. Press Save > Select Seq.

The sequence number becomes the active function. The signal generator displaysthe last sequence used.
Using the arrow keys, set the sequence to 1.

3. Press Select Reg.

The register number in sequence 1 becomes the active function. The signal generator displays either the
last register used accompanied by thetext: (i n use), or (if no registersare in use) register 00
accompanied by thetext: (avai | abl e) . Usethe arrow keysto select register 01.

4. Press Save Seq[1] Reg[01].
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This saves thisinstrument state in sequence 1, register 01 of the instrument state register.
Press Add Comment to Seq[1] Reg[01].

This enables you to add a descriptive comment to sequence 1 register 01.

Using the al phanumeric softkeys or the knob, enter a comment and press Enter.

Press Edit Comment In Seq[1] Reg[01].

If you wish, you can now change the descriptive comment for sequence 1 register O1.

After making changes to an instrument state, you can save it back to a specific register by highlighting that
register and pressing Re-SAVE Seq[n] Reg[nn].

Recalling an Instrument State

Using this procedure, you will learn how to recall instrument settings saved to an instrument state register.

1
2.

Press Preset.

Press the Recall hardkey.

Notice that the Select Seq softkey shows sequence 1. (This isthe last sequence that you used.)
Press RECALL Reg.

The register to be recalled in sequence 1 becomes the active function. Press the up arrow key once to
select register 1. Your stored instrument state settings should have been recalled.

Deleting Registers and Sequences

These procedures describe how to delete registers and sequences saved to an instrument state register.

Deleting a Specific Register within a Sequence

1
2.

Press Preset.

Press the Recall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

Press Select Seq and enter the sequence number containing the register you want to delete.

Press Select Reg and enter the register number you want to del ete.

Notice that the Delete Seq[n] Reg[nn] should be loaded with the sequence and register you want to delete.
Press Delete Seq[n] Reg[nn].

This deletes the chosen register.
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Deleting All Registers within a Sequence

1. PressPreset.
2. PresstheRecall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.

Press Select Seq and enter the sequence number containing the registers you want to delete.
4. PressDelete all Regs in Seq[n].

This deletes all registers in the selected sequence.

Deleting All Sequences

CAUTION Be sure you want to delete the contents of all registers and all sequencesin the instrument
State register.

1. PressPreset.
2. PresstheRecall or Save hardkey.

Notice that the Select Seq softkey shows the last sequence that you used.
3. Press Delete All Sequences.

This deletes all of the sequences saved in the instrument state register.

8757 Network Analyzer Save and Recall Functions

The 8757 network analyzer family can save and recall signal generator instrument states although
communication between the instruments is limited.

A clear register command from the 8757 will cause the signal generator to replace aregister’s contents with
default values. Default values can be cleared from the signal generator by using the Delete All softkey menu
or by using the corresponding SCPI (Standard Commands for Programmable Instruments) command.

The signal generator does not communicate directly with the 8757 network analyzer. If the 8757 saves an
instrument state to asignal generator register and the user deletes that register, the 8757 will not recognize
the deletion. An attempt, by the 8757, to recall a deleted state will cause the PSG to generate the error mes-

sage: +700 “ State Save Recall Error...”.
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Using Security Functions

This section describes how to use the PSG’s security functions to protect and remove classified proprietary
information stored or displayed in the instrument. All security functions described in this section also have
an equivalent SCPI command for remote operation. (Refer to the “ System Commands” chapter of the SCPI
Command Reference for more information.)

Understanding PSG Memory Types

The PSG comprises several memory types, each used for storing a specific type of data. Before removing
sensitive data, it isimportant to understand how each memory type is used in the PSG. The following tables
describe each memory type used in the base instrument, optional baseband generator, and optional hard disk.

Table 2-2 Base Instrument Memory

o &
o .2 .2
Memory £8|go
Type and a §. £ % Purpose/Contents | Data Input Method | Location in PSG and Remarks
Size 2382
SE|ag5
S2|8s
Main Yes No firmware operating | operating system CPU board
Memory memory (not user)
(SDRAM)
64 MB
Main Yes Yes factory calibration/ | firmware upgrades | CPU board (same chip as firmware
Memory configuration data | and user-saved data | memory, but managed separately)
(Flash) user file system, User datais not stored in this memory if
20MB which includes hard disk (Option 005) isinstalled.
Tlatnes_s Cal.' bration, Because this 32-MB memory chip
Q calibration, A .
instrument states, contains 20 MB of user data (described
waveforms here) qnd 12 M.B of fi rmware memory, a
(including header full-chip eraseis not desirable. User data
aress are selectively and completely
and marker data), "
modulation sanltl zed Whgn you perform the Erase and
definitions, and Sanitize function.
sweep lists
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Table 2-2 Base Instrument Memory
s | &
28| 2
Memory £8 1|3 kS
Type and a § -% % Purpose/Contents | Data Input Method | Location in PSG and Remarks
Size 25 |2
£E | g8
=2 |82
Firmware |No Yes main firmware factory installed or | CPU board (same chip as main flash
Memory image firmware upgrade | memory, but managed separately)
(Flash) . . :
During normal operation, this memory
12MB cannot be overwritten. It isonly
overwritten during the firmware
installation or upgrade process.
Because this 32-MB memory chip
contains 20 MB of user dataand 12 MB of
firmware memory (described here), a
full-chip erase isnot desirable. User data
areas are selectively and completely
sanitized when you perform the Erase and
Sanitize function.
Battery Yes Yes user-editabledata | firmware operations | CPU board
Ezﬁ:g:y (tabl'e editors) The battery can be remqved to clear the
(SRAM) last instrument state memory, but must be reinstalled for the
and last instrument instrument to operate.
512 kB state backup
user-stored
instrument states
Bootrom No Yes CPU bootup factory programmed | CPU board
Memory program and During normal operation, this memory
(Flash) firmware X )
|oader/updater cannot be overyvntten or erased. This
128 kB read-only datais programmed at the
factory.
Calibration | No Yes factory calibration/ |factory or service motherboard
Backup configuration data | only
Memory backup
(Flash) no user data
512 KB
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Table 2-2 Base Instrument Memory
o &
5 S
o .2
Memory £E8 |z
Type and a § -% % Purpose/Contents | Data Input Method | Location in PSG and Remarks
Size 25 |2
SE | &
EE|ZSQ
=2 |82
Boards No Yes factory calibration | factory or service all RF boards, baseband generator, and
Memory and information only motherboard
(Flash) files, code images,
512 Bytes and self-test limits
no user data
Micro- Yes No CPU dataand memory ismanaged | CPU board
processor instruction cache by CPU, not user
Cache
(SRAM)
3kB
Table 2-3 Baseband Generator Memory (Options 601 and 602)
o E
o .2 %
Memory £8|ge
Type and a § -% g Purpose/Contents |Data Input Method |Remarks
Size 25 |2
E£E o5
=2 |8%2
Waveform | Yes No waveforms normal user User datais completely sanitized when you
Memory (including header operation perform the Erase and Sanitize function.
(SDRAM) and marker data) and
40-320 MB PRAM
BBG No Yes firmwareimagefor |firmware upgrade
Firmware baseband generator
Memory
(Flash)
32MB
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Table 2-3 Baseband Generator Memory (Options 601 and 602)
<
& E=
25| S
Memory £E8|ge
Type and a §. £ % Purpose/Contents  |Data Input Method |Remarks
Size 25 |2
EE|obB
=2 |82
Coprocessor | Yes No operating memory of | During normal This memory is used during normal
Memory baseband operation, some user |baseband generator operation. It is not
(SRAM) coprocessor CPU information, such as |directly accessible by the user.
payload data, can
32MB remain in the
memory.
Buffer No No support buffer normal user This memory is used during normal
Memory memory for ARB operation baseband generator operation. It is not
(SRAM) and real-time directly accessible by the user.
5x512kB gpplications
Table 2-4 Hard Disk Memory (Option 005)
~
& E=
o5 | S
Memory £E8|ge
Type and a §. £ £ |Purpose/Contents | Data Input Method | Remarks
Size 25 |2
£E a5
=2 |82
Media Yes Yes user files, including | user-saved data The magnetic residue requires several
Storage flatnesscalibrations, rewrite cycles or drive removal and
(Built-in IQ calibration, destruction.
Hard Disk) \l/cztvrgfr:rernntsstat%, The hard disk is an option and is therefore
6 GB or . . not installed in some instruments. If itis
(including header . .
10GB and marker data) installed, these files are stored on the hard
(4GB . ' disk instead of in flash memory.
ussblein modulation
both ) definitions, and User datais completely sanitized when
sweep lists you perform the Erase and Sanitize function.
Buffer No No buffer (cache) normal operation
Memory memory through hard disk
(DRAM)
512 kB
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Removing Sensitive Data from PSG Memory

When moving the PSG from a secure devel opment environment, you can remove any classified proprietary
information stored in theinstrument. This section describes several security functions you can use to remove
sensitive data from your instrument.

Erase All

This function removes all user files, user flatness calibrations, user I/Q calibrations, and resets all table
editors with original factory values, ensuring that user data and configurations are not accessible or
viewable. Theinstrument appearsasif itisinitsoriginal factory state, however, the memory is not sanitized.
This actionisrelatively quick, taking less than one minute.

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase All > Confirm Erase.

NOTE This function is different than pressing Utility > Memory Catalog > More (1 of 2) >
Delete All Files, which deletes all user files, but does not reset the table editors.

Erase and Overwrite All

This function performs the same actions as Erase All and then clears and overwrites the various memory
types in accordance with Department of Defense (DoD) standards, as described bel ow.

SRAM - All addressable locations are overwritten with random characters.

CPU Flash — All addressable locations are overwritten with random characters and then the flash blocks
are erased. This accomplishes the same purpose of a chip erase, however, only the areas that are no
longer in use are erased and the factory calibration files are left intact.

DRAM - All addressable |ocations are overwritten with random characters.

Hard Disk — All addressable locations are overwritten with a single character. (This isinsufficient for
top secret data, according to DoD standards. For top secret data, the hard drive must be removed and
destroyed.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Overwrite All >
Confirm Overwrite.
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Erase and Sanitize All

This function performs the same actions as Erase and Overwrite All and then adds more overwriting actions.
After executing this function, you must manually perform some additional steps for the sanitization to
comply with Department of Defense (DoD) standards. These actions and steps are described below.

SRAM - After applying this function, the instrument must remain in the secure arealong enough to
ensure that the random overwriting resides in memory for aperiod longer than the classified data resided
in memory. Alternatively, the SRAM battery can be removed then manually reinserted, however, this
requires opening the instrument.

DRAM - All addressable locations are overwritten with asingle character. You must then power off the
instrument to purge the memory contents.

Hard Disk — All addressable |ocations are overwritten with a single character and then a random
character. (Thisisinsufficient for top secret data, according to DoD standards. For top secret data, the
hard drive must be removed and destroyed.)

To carry out this function, press Utility > Memory Catalog > More (1 of 2) > Security > Erase and Sanitize All >
Confirm Sanitize.

Using the Secure Mode

The secure mode automatically applies the selected Security Level action the next time the instrument’s power
iscycled.

To set the level of the secure mode, press Utility > Memory Catalog > More (1 of 2) > Security > Security Level
and choose from the following selections:

None — equivalent to a factory preset, no user information islost
Erase — equivalent to Erase All

Overwrite — equivalent to Erase and Overwrite All

Sanitize — equivalent to Erase and Sanitize All

To activate the secure mode, press Utility > Memory Catalog > More (1 of 2) > Security > Enter Secure Mode >
Confirm. The Enter Secure Mode softkey changes to Secure Mode Activated.

CAUTION Once you select a security level action and activate secure mode by pressing Confirm, you
cannot deactivate or decrease the security level. The erasure actions for that security level
execute at the next power cycle. You can only increase the security level once the secure
mode is activated. For example, you can change Erase to Overwrite, but not the reverse.

NOTE After the power cycle, the security level selection remains the same, but the secure modeis
not activated.
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If Your Instrument is Not Functioning

If the instrument is not functioning and you cannot use the security functions, the storage media must be
physically removed from the instrument. This requires removal of the hard disk and processor board, which
should then be rendered unusable and discarded. The instrument can then be sent to arepair facility for new
parts, repair, and calibration. Refer to the service guide for disassembly procedures.

Using the Secure Display

This function prevents unauthorized personnel from reading the instrument display and tampering with the
current configuration through the front panel. The display is blanked, except for the message*** SECURE
DI SPLAY ACTI VATED *** and the front panel keys are disabled. Once this function is activated, the
power must be cycled to re-enable the display and front panel keys.

To apply thisfunction, press Utility > Display > More (1 of 2) > Activate Secure Display > Confirm Secure Display

Figure 2-11 PSG Screen with Secure Display Activated

(]
(]
(]
*** SECURE DISPLAY ACTIVATED *** :[:]
-]
(]
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Enabling Options

You can retrofit your signal generator after purchase to add new capabilities. Some new optional features are
implemented in hardware that you must install. Some options are implemented in software, but require the
presence of optional hardware in the instrument. This example shows you how to enable software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each software option.

1. Access the Software Options menu:
Utility > Instrument Adjustments > Instrument Options > Software Options.
The following is an example of the signal generator display, which lists any enabled software options,
and any software options that can be enabled:

FREQUEMCY AMPLITUDE ~ Modify
20.000 000 000 000 &z | =135.00 cen icense Ked
EXT REF HOD
OH
Softuare Option Selection Host I0 = el77FFFF
Option License Keu Description
WL O07 FEUEZFA1721L v RANP SLEEF
015 00000000000A -+ LIDEBAKND IO
1EA < HIGH OUTPUT FOLER
Lz20 < RADAR SIMULATION PERSOMALITY
L21 + NOISE POMER RATIO PERSOMALITY
Proceed Llith
Reconf iguration

2. Verify that the host ID shown on the display matches the host ID on the license key certificate. The host
ID isaunique number for every instrument. If the host ID on the license key certificate does not match
your instrument, the license key cannot enabl e the software option.

3. Verify that any required hardware is installed. Because some software options are linked to specific
hardware options, before the software option can be enabled, the appropriate hardware option must be
installed. For example, Option 420 (radar simulation modulation format) requires that Option 601/602
(internal baseband generator) be installed. If the software option that you intend to install islisted in a
grey font, the required hardware may not be installed (look for an X in the “ Selected” column of the
appropriate hardware option in the Hardware Options menu).
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4. Enable the software option:
a. Highlight the desired option.
b. Press Modify License Key, and enter the 12-character license key (from the license key certificate).

c. Verify that you want to reconfigure the signal generator with the new option:
Proceed With Reconfiguration > Confirm Change

The instrument enables the option and reboots.
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Using the Web Server

You can communicate with the signal generator using the Web Server. This service uses TCP/IP
(Transmission Control Protocol/Internet Protocol) to communicate with the signal generator over the
internet.

The Web Server uses a client/server model where the client is the web browser on your PC or workstation
and the server isthe signal generator. When you enable the Web Server, you can access aweb page that
resides on the signal generator.

The Web-Enabled PSG web page, shown in Figure 2-12, provides general information on your signal
generator and a means to control the instrument by using a remote front-panel interface or using SCPI
(Standard Communication for Programmable Instruments) commands. The web page also has links to
Agilent’s products, support, manuals, and website.

NOTE The Web Server serviceis compatible with the latest version of the Microsoft© Internet
Explorer web browser.

The Signal Generator Web Control menu button on the Web-Enabled PSG web page will access a second
web page. Thisweb page, shown in Figure 2-13, provides a virtual instrument interface that can be used to
control the signal generator. You can use the mouse to click on the signal generator’s front panel hardkeys,
softkeys and number pad. There is also atext box that can be used to send SCPI commands to the
instrument.

Activating the Web Server

Perform the following steps to access the Web Server.

Turn on the Web Server by pressing Utility > GPIB/RS-232 LAN > LAN Services Setup > Web Server On.
Press the Proceed With Reconfiguration softkey.

Press the Confirm Change (Instrument will Reboot) softkey. The signal generator will reboot.

Launch your PC or workstation web browser.

ag &~ w D P

Enter the IP address of the signal generator in the web browser address field. For example,
http://101.101.101.101. Replace 101.101.101.101 with your signal generator’s | P address. Press the
Enter key on the computer’s keyboard.

1. Microsoft is a registered trademark of Microsoft Corp.
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NOTE The IP (Internet Protocol) address can change depending on your LAN configuration.
Use the LAN Config Manual DHCP softkey to select aManual or DHCP (dynamic host
communication protocol) LAN configuration. Refer to PSG Key Reference for more

information.

6. Pressthe enter key on the computer’s keyboard. The web browser will display the signal generator’s
homepage as shown below in Figure 2-12. This web page displays information about the signal

generator and provides access to Agilent’s website.

Figure 2-12 Signal Generator Web Page

7 Welcome to Agilent Technologies Web-Enabled Site - Micrasoft Internet Explarer

File Edit View Favorites Tools Help

Ggack ~ = - @ [@) & Qoearch (GFavortes Pveda B | By S B -

Address I wkkp: 11101, 101,101, 101 /defaulk, kb

UL NI PSG Series Microwave Signal Generator

Welcome to your

Web-Enabled P5G

= Msianal Generator
Web Control

Infermation about this Web-Enabled PSG:

Serial Numb Ug44100080
D

escription: Agilent EB2ZE7D (LUS44100080)

IP Address: 141.121.949
VISA TCPIP Connect String: TCPIPO:GALLP3:INSTR

Support | Manuals | P

Anather web-gnabled instrument

from Agilent Technologies

.
00:30:D3:05:58:38
"

Use the navigation bar on the |eft to access your signal generatar and related information

@ Agilent Technologies, Inc, 2002

[&] bene

| @ miernet

7. Click the Signa Generator Web Control menu button on the left of the page. A new web page will be

displayed as shown below in Figure 2-13.
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Figure 2-13 Web Page Front Panel

ZJ http://141.121.94.9/display - Microsoft Internet Explorer 5 =10l x|
File Edit ‘iew Favorites Tools Help |

4=tk - = - (D | Qeearch CEFavoriies Fveda 8| By S B - =]

Addressl http: /101,101,101, 101 display j PG ‘Linlrs >>|
=
FREQUENCY AMPLITUDE aRe || Freg || Mode | MUX AM | Bweep
101.000 000 000 1 ‘ -130.00 n o Sewp | Awx | | Uiy
Fulse | LF Qut

DIGNoD non Select
/0 OH Haveform

| gavgfugm,
Eament.s
Continuous HELP (press ’Help” to exit) <

Trigg || Help

MOD On/Off

Haveform,|
Sequences

RF OnfOff

Pressing this key allows Uou &ccess to a menu ARE Setupk
for operat.ing the Arbitrary waveform generator.
Option required.

Preset Local

Trigaer,
{Cont inuous )

=== PROTO CODE == WOT FOR CUSTOMER USE === 10405,/2004 03:00
SCPIL commandl SEND
@& e e

This web page remotely accesses all signal generator functions and operations. Use the mouse pointer to
click on the signal generator’s hardkeys and softkeys. The results of each mouse click selection will be
displayed on the web page. For example, click on the Frequency hardkey then use the front-panel key pad to
enter afrequency. You can also use the up and down arrow keys to increase or decrease the frequency.

You can use the SCPI Command text box at the bottom of the front-panel display to send commands to the
signal generator. Enter avalid SCPI command, then click the SEND button. The results of the command will
be displayed on a separate web page titled, “ SCPI Command Processed”. You can continue using this web
page to enter SCPI commands or you can return to the front panel web page.

NOTE It may be necessary to use the web browser Refresh function if the web page does not
update with new settings.
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3 Basic Digital Operation

This chapter provides information on the functions and features avail able for the E8267D PSG vector signal

generator with Option 601or 602.

e “Custom Modulation” on page 78

« “Arbitrary (ARB) Waveform File Headers” on page 80
e “Using the Dual ARB Waveform Player” on page 91

e “Using Waveform Markers’ on page 97

e “Triggering Waveforms®’ on page 113

e “Using Waveform Clipping” on page 119

e “Using Waveform Scaling” on page 127

Seedlso:

e “Custom Arb Waveform Generator” on page 161
» “Multitone Waveform Generator” on page 213

* “Two-Tone Waveform Generator” on page 223
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Custom Modulation

For creating custom modulation, the signal generator offers two modes of operation: the Arb Waveform
Generator mode and the Real Time |I/Q Baseband mode. The Arb Waveform Generator mode has built-in
modul ation formats such as NADC or GSM and pre-defined modulation types such as BPSK and 16QAM
that can be used to create asignal. The Real Time I/Q Baseband mode can be used to create custom data
formats using built-in PN sequences or custom-user files along with various modulation types and different
built-in filters such as Gaussian or Nyquist.

Both modes of operation are used to build complex, digitally modulated signals that simulate
communication standards with the flexibility to modify existing digital formats, define or create digitally
modulated signals, and add signal impairments.

Custom Arb Waveform Generator

The signal generator’s Arb Waveform Generator mode is designed for out-of-channel test applications. This
mode can be used to generate data formats that simulate random communication traffic and can be used as a
stimulus for component testing. Other capabilities of the Arb Waveform Generator mode include:

« configuring single or multicarrier signals. Up to 100 carriers can be configured.

« creating waveform files using the signal generator’s front panel interface. The waveform files, when
created as random data, can be used as a stimulus for component testing where device performance such
as adjacent channel power (ACP) can be measured. The AUTOGEN WAVEFORMfile that is
automatically created when you turn the Arb Waveform Generator on can be renamed and stored in the
signal generator’s non-volatile memory. Thisfile can later be loaded into volatile memory and played
using the Dual ARB waveform player.

For more information, refer to the sections “ Using the Dual ARB Waveform Player” on page 91 and “Modes
of Operation” on page 7.
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Custom Real Time I/Q Baseband

The real -time mode simulates single-channel communication using user-defined modulation types along
with custom FIR filters, and symbol rates. Data can be downloaded from an external source into PRAM
memory or supplied as real time data using an external input. The Rea Time 1/Q Baseband mode can also
generate pre-defined data formats such as PN9 or FIX4. A continuous data stream generated in this mode
can be used for receiver bit error analysis. Thismodeislimited to asingle carrier. The Real Time I/Q
Baseband mode:

« has more data and modulation types available than the Arb Waveform Generator mode.
« supports custom 1/Q constellation formats.

« has the capability to generate continuous PN sequences for bit error rate testing (BERT).
* needs no waveform build time when signal parameters are changed.

For more information, refer to the custom arb section “Overview” on page 162, the custom real time section
“Overview” on page 190 and the section on “Digital Modulation” on page 7.
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Arbitrary (ARB) Waveform File Headers

An ARB waveform file header enables you to save instrument setup information (key format settings) along
with awaveform. When you retrieve a stored waveform, the header information is applied so that when the
waveform starts playing, the dual ARB player is set up the same way each time.

Headers can also store a user-specified 32-character description of the waveform or sequencefile.

A default header is automatically created whenever awaveform is generated, a waveform segquence is
created, or awaveform fileis downloaded to the PSG (for details on downloading files, see the PSG
Programming Guide).

The following signal generator settings are saved in afile header:

ARB sample clock rate

Runtime scaling (only in the dual ARB player)

Marker settings and routing functions (page 97)

— Polarity

— ALChold

— RF blanking

High crest mode (only in the dual ARB player)

Modulator attenuation

Modulator filter

1/Q output filter (used when routing signals to the rear panel 1/Q outputs)
Other instrument optimization settings (for files generated by the PSG) that cannot be set by the user.
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Arbitrary (ARB) Waveform File Headers

Creating a File Header for a Modulation Format Waveform

When you turn on a modulation format, the PSG generates atemporary waveform file
(AUTOGEN_WAVEFORM), with a default file header. The default header has no signal generator settings

saved toit.

This procedure, which is the same for all ARB formats, demonstrates how to create afile header for a

Custom digital modulation format.

1. Preset the signal generator.

2. Turn on the Custom modulation format:

Press Mode > Custom > ARB Waveform Generator > Digital Modulation Off On to On

A default file header is created, and the temporary waveform file (AUTOGEN_WAV EFORM) plays.

Figure 3-1 shows the PSG's display.

Figure 3-1 Custom Digital Modulation First-Level Softkey Menu
FRECUEMCY AMPLITUOE nodgig%%g%
44.000 000 000 000 &= | -130.00 cen or¢
DTGHOD ’7 ﬂ Multicarrier
lﬁ!ﬂ OH I On

I0 Mod Filter: LO.000MHz
Data: Random
Sumbol Rate:2h.300ksps

DIGMOD Dig Moo Satup: NADC
Mod Tupe: HDOPSK

[]r] Filter: RWYD(n=0.3500
Trig Tupe: Continuous (Free FAun) Retrigger: On

Trig Source: Ext (Patt Trig In 1) Polaritu: Neg
Oelau: Off

Setup Salect)
EhIAOC )

Digital Mod
Define

M
ARE SetupM

Trioger
(Cont.inuous)

First-Level Softkey Menu

(Some ARB formats
have a second page)

At this point, a default file header has been created, with default (unspecified) settings that do not reflect
the current signal generator settings for the active modulation. To save the settings for the active
modulation, you must modify the default settings before you save the header information with the
waveform file (see “Modifying Header Information in a Modulation Format” on page 82).

NOTE Each time an ARB modulation format is turned on, a new temporary waveform file
(AUTOGEN_WAVEFORM) and file header are generated, overwriting the previous
temporary file and file header. Because all ARB formats use the same file name, this happens
even if the previous AUTOGEN_WAVEFORM file was created by a different

ARB modulation format.
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Modifying Header Information in a Modulation Format

This procedure builds on the previous procedure, explaining the different areas of afile header, and showing
how to access, modify, and save changes to the information.

In amodulation format, you can access afile header only while the modulation format is active (on). This
procedure uses the Custom digital modulation format. All ARB modulation formats and the dual ARB
player access the file header the same way, except that in some modulation formats, you may have to go to
page two of thefirst-level softkey menu.

1. From thefirst-level softkey menu (shown in Figure 3-1 on page 81), open the Header Utilities menu:
Press ARB Setup > Header Utilities
Figure 3-2 shows the default header for the Custom digital modulation waveform. The Saved Header
Set ti ngs column, shows that the signal generator settings for the active format are Unspeci fi ed,
which means that no settings have been saved to the file header.
NOTE If asetting is unspecified in the file header, the signal generator’s current value for that setting
does not change when you select and play the waveform in the future.
TheQurrent Inst. Settings column shows the current signal generator settings for the active
modulation. These settings become the saved header settings when they are saved to the file header (as
demonstrated in Step 2).
Figure 3-2 Custom Digital Modulation Default Header Display
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2. SavetheinformationintheCQurrent Inst. Settings columnto thefile header:
Press Save Setup To Header.

Both the Saved Header Settings columnandtheCQurrent Inst. Settings columnnow
display the same settings; the Saved Header Setti ngs column liststhe settings saved in thefile
header.

Thefile header contains the following signal generator settings:

32-Character A description entered for the header, such as athe waveform'’s function (saved/edited with
Description: the Edit Description key, see Figure 3-2 on page 82).

Sample Rate: The ARB sample clock rate.

Runtime Scaling: The Runtime scaling value. Runtime scaling is applied in real-time while the waveformis

playing. This setting can be changed only for filesin the dual ARB player.
Marker 1...4 Polarity: The marker polarity, positive or negative (described on page 112).
ALC Hold Routing: ~ Which marker, if any, implements the PSG’s ALC hold function (described on page 99).

RF Blank Routing: Which marker, if any, implements the PSG’s RF blanking function (described on

page 111).

1/Q Mod Filter: The 1/Q modulator filter setting. The modulator filter affects the 1/Q signal modulated onto
the RF carrier.

1/Q Output Filter: The I/Q output filter setting. The 1/Q output filter is used for 1/Q signals routed to the rear

panel | and Q outputs.

Mod Attenuation: The I/Q modulator attenuation setting.

3. Returnto the ARB Setup menu: Press Return.

Inthe ARB Setup menu (shown in Figure 3-3), you can change the current instrument settings. Figure
3-3 also shows the softkey paths used in steps four through nine.

4. Set the ARB sample clock to 5 MHz: Press ARB Sample Clock > 5 > MHz.

Set the modul ator attenuation to 15 dB:
Press More (1 of 2) > Modulator Atten n.nn dB Manual Auto to Manual > 15 > dB.

6. Set the 1/Q modulation filter to athrough:
Press I/Q Mod Filter Manual Auto to Manual > Through.

7. Set marker one to blank the RF output at the set marker point(s):
Press More (2 of 2) > Marker Utilities > Marker Routing > Pulse/RF Blank > Marker 1.

For information on setting markers, see “Using Waveform Markers’ on page 97.

8. Set the polarity of Marker 1 negative:
Press Return > Marker Polarity > Marker 1 Polarity Neg Pos to Neg.

Chapter 3 83



Basic Digital Operation
Arbitrary (ARB) Waveform File Headers

9. Return to the Header Utilities menu: Press Return > Return > Header Utilities.

Noticethat theQurrent Inst. Settings column now reflects the changes made to the current
signal generator setup in steps 4 through 8, but that the saved header values have not changed (as shown
in Figure 3-4 on page 86).

10. Save the current settings to the file header: Press Save Setup To Header softkey.
The settingsfromthe Qurrent 1 nst. Setti ngs column now appear inthe Saved Header

Set ti ngs column. The file header has been modified and the current instrument settings saved. Thisis
shown in Figure 3-5 on page 86.

While amodulation format is active (is on), the waveform file (AUTOGEN_WAVEFORM) plays and you
can modify the header information within the active modulation format. Once you turn the modulation
format off, the header information is available only through the dual ARB player.

NOTE If you turn the modulation format off and then on, you overwrite the previous
AUTOGEN_WAVEFORM file and itsfile header. To avoid this, rename the file before you
turn the modulation format back on (see page 96).

Storing awaveform file (see page 96) stores the saved header information with the waveform.
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Figure 3-4 Differing Values between Header and Current Setting Columns
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Figure 3-5 Saved File Header Changes
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Storing Header Information for a Dual ARB Player Waveform Sequence

When you create a waveform segquence (described on page 93), the PSG automatically creates a default file
header, which takes priority over the headers for the waveform segments that compose the waveform
sequence. During a waveform sequence playback, the waveform segment headers are ignored (except to
verify that all required options are installed). When you store the waveform sequence, itsfile header is
stored with it.

Modifying and Viewing Header Information in the Dual ARB Player

Once amodulation format is turned off, the waveform file is available only to the dual ARB player. Thisis
also true for downloaded waveform files. Because of this, future edits to a waveform’s header information
must be performed using the dual ARB player.

To modify header information in the dual ARB player, the waveform file must be playing in the dual ARB
player (although you can view the header information in the dual ARB player without playing the file)

You can reapply saved header settings by reselecting the waveform file for playback. When you do this, the
valuesfrom the Saved Header Setti ngs column are applied to the PSG
Modifying Header Information

All of the same header characteristics shown in “Modifying Header Information in a Modulation Format” on
page 82 arevalid in the dual ARB player. This task guides you through selecting awaveform file and
accessing the header for the selected file, then refers you back to the af orementioned procedure to perform
the modifications.

1. Select awaveform:

a Press Mode > Dual ARB > Select Waveform.
b. Using the arrow keys, highlight the desired waveform file.
c. Pressthe Select Waveform softkey.
2. Play the waveform: Press ARB Off On to On.
3. Accessthe header: Press ARB Setup > Header Utilities.
4. Refer to “Modifying Header Information in a Modulation Format” to edit the header information:

« For adefault header, read the information in step one on page 82, then perform the remaining stepsin
the procedure.

« Tomodify an existing file header, start with step three on page 83.
Therest of this section focuses on the additional file header operations found in the dual ARB player.
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Viewing Header Information with the Dual ARB Player Off

One of the differences between a modul ation format and the dual ARB player is that even when the dual
ARB player is off, you can view afile header. You cannot, however, modify the displayed file header unless

the dual ARB player ison, and the displayed header is selected for playback. With the dual ARB player off,
perform the following steps.

1. Select awaveform:

a Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired waveform file.
c. Pressthe Select Waveform softkey.

2. Accessthefile header: Press ARB Setup > Header Utilities.

The header information is now visible in the PSG display. As shown in Figure 3-6, the header editing
softkeys are grayed-out, meaning they are inactive.

Figure 3-6
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While awaveform is playing in the dual ARB player, you can view the header information of a different
waveform file, but you can modify the header information only for the waveform that is currently playing.
When you select another waveform file, the header editing softkeys are grayed-out (see Figure 3-6). This

task guides you through the available viewing choices.

1. View the waveform file list: Press Mode > Dual ARB > ARB Setup > Header Utilities > View Different Header.

Asshown in Figure 3-7, there is an aphabetical list of waveform filesin the table.

Figure 3-7 Waveform File List for Viewing a Different Header
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2. View all waveform segmentsin non-volatile memory:

Current waveform file type

Seq

HFA1

a. Pressthe Catalog Type softkey. As shown in Figure 3-7, you have a choice of three waveform file
types that can be displayed in the table accessed in step one.

NVWFM displays all waveform segments stored in non-volatile memory
Seq displays all waveform sequencefiles
WFM1 displays all waveform segments stored in volatile memory

b. Pressthe NVWFM softkey. The table displays the waveform files in non-volatile memory.

3. View awaveform file's header information: Highlight afile and press the View Header softkey.

The header information for the selected waveform file appearsin the PSG display. If thereisawaveform
playing, its header information is replaced by thisinformation, but the waveform settings used by the
signal generator do not change. To return to the header information for the playing waveform, either

press View Different Header, select the current playing waveform file, and press View Header, or

press Return > Header Utilities.
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Playing a Waveform File that Contains a Header

After awaveform file (AUTOGEN_WAVEFORM) is generated in a modulation format and the format is
turned off, the file becomes accessible to and can only be played back by the dual ARB player. Thisistrue
for downloaded waveform files (downloading filesis described in the Programming Guide). When the
waveform is selected for playback, the saved header information is used by the signal generator. Some of
these settings appear as part of the labels of the softkeys used to set the parameters, and also appear on the

dual ARB summary display (see Figure 3-8).

NOTE The signal generator used to play back a stored waveform file must have the same options

as are required to generate thefile.

For details on applying file header settings and playing back a waveform, see “Playing a Waveform™ on

page 94.
To properly set up the instrument:
1. Select the waveform.

2. Maodify the signal generator settings as desired.
3. Turnonthedua ARB.

Figure 3-8 File Header Settings
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Using the Dual ARB Waveform Player

The dual arbitrary (ARB) waveform player is used to create, edit, and play waveform files. There are two
types of waveform files: segments and sequences. A segment is awaveform file that is created using one of
the signal generator’s pre-defined ARB formats. A sequence can be described as several segments strung
together to create one waveform file. Waveform files can also be created remotely using another signal
generator or using computer programs and downl oaded to the PSG for playback by the Dual ARB waveform
player. For information on downloading waveforms, refer to the PSG Programming Guide.

A waveform fileis automatically generated whenever an ARB modulation format is turned on. This
automatically generated fileis named AUTOGEN WAVEFORM Because this default file name is shared
among all ARB formats, it must be renamed if you want to save the information. If the fileis not renamed, it
will be overwritten when another ARB format is turned on.

The Dual ARB waveform player provides markers (page 97), triggering (page 113), and clipping (page 119)
capabilities.

Before you can work with any waveform file, it must reside in volatile memory. The signal generator has
two types of memory, WFM 1 (volatile waveform memory) and NVWFM (non-volatile waveform memory).
A newly generated waveform file (AUTOGEN WAVEFCRM), created when the Arb Waveform Generator is
turned on, initially residesin WFM1. If you want to save thisfile, renameit and storeit in NVWFM. Load a

stored waveform file from NVWFM into volatile memory (WFM1) where it can be edited or played by the
ARB waveform player. Refer to “ Custom Modulation” on page 78 for more information.

Accessing the Dual ARB Player

Press Mode > Dual ARB.

hisfirst-level softkey menu is shown in the following figure. Most procedures start from this menu.
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Creating Waveform Segments

There are two ways to provide waveform segments for use by the waveform sequencer. You can either
download a waveform viathe remote interface, or generate a waveform using one of the ARB modulation
formats. For information on downloading waveforms via the remote interface, see the Programming Guide.

A waveform sequence is made up of segments but can also contain other sequences. Any number of
segments, up to 32768, can be used to create a sequence. This limit count is determined by the number of
segments in the waveform sequence. Segments and sequences can be repeated within a waveform sequence
and the total of all segments and repeated segments cannot exceed the limit count. The following diagram
shows a waveform segquence made up of two sequences and three segments. In this example the segment
count is eleven.

Figure 3-9 Waveform Sequence Diagram

Sequence
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Segqment

Sequence [ Feqrent T
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The following procedure describes how to create two waveform segments, then name and store them in
ARB memory. After you name and store the two waveform segments in ARB memory, you can use them to
build a waveform sequence, as described on page 93.

Wanse Earm
Sequence

1. Generate the first waveform:

a. PressPreset > Mode > Two Tone > Alignment Left Cent Right to Right.

b. Press Two Tone Off On to On, then to Off.
You turn off the Two Tone mode after generation because a waveform cannot be renamed as a
segment whileitisin use.

This generates a two tone waveform with the tone on the right placed at the carrier frequency. During
waveform generation, the T- TONE and | / Qannunciators activate. The waveform is stored in volatile
memory, with the default file name AUTOGEN WAVEFCRM
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NOTE Because there can be only one AUTOGEN WAVEFCRMwaveform in memory at any given
time, you must rename thisfile to clear the way for a second waveform.

2. Create the first waveform segment:

Press Mode > Dual ARB > Waveform Segments > Load Store to Store.

Highlight the default segment AUTOGEN WAVEFORM

Press Rename Segment > Editing Keys > Clear Text.

Enter afile name (for example, TTONE), and press Enter > Store Segment To NVWFM Memory.
This renames the waveform segment, and stores a copy in non volatile memory.

cooTo

3. Generate the second waveform:

a  Press Mode > Multitone > Initialize Table > Number Of Tones > 9 > Enter > Done.
b. Press Multitone Off On to On, then Off.
Remember that a waveform cannot be renamed as a segment whileitisin use.

This generates a multitone waveform with nine tones. During waveform generation, the M TONE and
I / Qannunciators activate. The waveform is stored in volatile memory with the default file name
AUTOGEN_WAVEFORM

4. Create the second waveform segment:

Repeat Step 2, giving this segment a descriptive name (for example, MTONE).

Building and Storing a Waveform Sequence

This example shows how to build and edit a waveform sequence using the two waveform segments created
on page 92. To use a segment in a sequence, the segment must reside in volatile memory; for information on
loading waveform segments from non volatile to volatile memory, see page 96.

1. Select the waveform segments:

Define a sequence as one repetition of the two-tone waveform segment followed by one repetition of the
nine-tone multitone waveform segment.

a. Press Mode > Dual ARB > Waveform Sequences > Build New Waveform Sequence > Insert Waveform.
b. Highlight the awaveform segment (for example, TTONE) and press Insert Selected Waveform.
¢. Highlight a second waveform segment (for example, MTONE) and press Insert Selected Waveform.
d. Press Done Inserting

2. Optional: Enable markers as desired for the segments in the new sequence: see page 108.

3. Name and store the waveform sequence to the Cat al og of Seq Fi | es inthe memory catalog:
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a Press Name and Store.
b. Enter afile name (for example, TTONE+MIONE).

C. PresseEnter.

Playing a Waveform

This procedure appliesto playing either a waveform segment or awaveform sequence.
This exampl e plays the waveform sequence created in the previous procedure.

1. Select awaveform sequence:

a  Press Mode > Dual ARB > Select Waveform.

b. Highlight awaveform sequence (for this example, TTONE+MIONE) from the Sequence column of
the Sel ect \Wavef or mcatalog, and press Select Waveform.

The display shows the currently selected waveform
(for example, Sel ect ed Wavef orm SEQ TTONE+MIONE).

2. Generate the waveform:
Press ARB Off On to On.

This plays the selected waveform sequence.
During the waveform sequence generation, the ARB and | / Qannunciators activate.

Editing a Waveform Sequence

This example shows how to edit waveform segments within a waveform sequence, and then save the edited
seguence under a new name. Within the editing display, you can change the number of times each segment
plays (the repetitions), delete segments, add segments, toggle markers (described on page 108), and save
changes.

NOTE If you do not store changes to the waveform sequence prior to exiting the waveform
sequence editing display, the changes are removed.

Press Waveform Sequences > Edit Selected Waveform Sequence, and highlight the first entry.
Press Edit Repetitions > 100 > Enter. The second segment is automatically selected.

Press Edit Repetitions > 200 > Enter.

A wDd P

Save the edited file as a new waveform sequence:

a  Press Name And Store.
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b. PressEditing Keys > Clear Text, then enter anew file name (for example, TTONEL0O0+MICNE200).
C. PressEnter.

You have now changed the number of repetitions for each waveform segment entry from 1 to 100 and 200,
respectively. The sequence has been stored under anew nameto the Cat al og of Seq Fil es inthe
signal generator’s memory catalog.

For information on playing a waveform sequence, refer to page 94.

Adding Real-Time Noise to a Dual ARB Waveform

The signal generator with option 403 can apply AWGN (additive white gaussian noise) to acarrier in real
time while the modulating waveform file is being played by the Dual ARB waveform player. The AWGN
can be configured using front-panel softkeys. The Carrier to Noise Ratio softkey allows you to specify the
amount of noise power relative to carrier power that is applied to the signal. The Carrier Bandwidth softkey
sets the bandwidth over which the noise is integrated and the Noise Bandwidth Factor softkey allows you to
select aflat noise bandwidth. These softkeys are described in the PSG Key Reference.

The following procedure sets up a carrier and modulates it using the pre-defined SI NE_ TEST_ WM
waveform file. AWGN is then applied to the carrier.

Configuring AWGN

Preset the signal generator. Press the Preset hardkey.

Press the Frequency hardkey and enter 15 GHz.

Press the Amplitude hardkey and enter =10 dBm.

Press RF On Off to On.

Press Mode > Dual ARB > Select Waveform and select the SINE_ TEST WFM waveform.
Press Select Waveform.

Press ARB Off On to On.

Press ARB Setup > ARB Sample Clock enter 50 MHz.

© o N o 0 M W NP

Press Real-time Noise Setup > Carrier to Noise Ratio and enter 30 dB.
10. Press Carrier Bandwidth and enter 40 MHz.
11. Press Real-time Noise Off On to On.

This procedure applies AWGN to the 15 GHz carrier. The displayed power level of the signal generator, —10
dBm, will include the noise power which is set as a carrier to noise ratio (C/N) of 30 dB. Noise power, for
the purpose of C/N, is applied across a carrier bandwidth of 40 MHz. The default noise bandwidth factor is
1, which provides a flat noise signal bandwidth of aleast 0.8 times the 50 MHz sample rate.
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Storing and Loading Waveform Segments

Waveform segments can reside in volatile memory as WFM1 files, or they can be stored to non-volatile
memory as NVWFM files, or both. To play or edit awaveform file, it must reside in volatile memory.
Because files stored in volatile memory do not survive apower cycle, it isagood practice to store important
files to non-volatile memory and load them to volatile memory whenever you want to use them.

Storing Waveform Segments to Non-volatile Memory

1. PressMode > Dual ARB > Waveform Segments.

2. If necessary, press Load Store to Store.

3. Press Store All To NVWFM Memory.

Copies of all WFM1 waveform segment files have been stored in non-volatile memory as NVWFM files.
To storefilesindividually, highlight the file and press Store Segment To NVWFM Memory.

Loading Waveform Segments from Non-volatile Memory

1. Clear out the volatile memory and delete all WFM 1 files: Power cycle the instrument.

2. Press Mode > Dual ARB > Waveform Segments.

3. If necessary, press Load Store to Load.

4. PressLoad All From NVWFM Memory.

Copies of all NVWFM waveform segment files have been loaded into volatile memory as WFM 1 files.
To load files individually, highlight the file and press Load Segment From NVWFM Memory.

Renaming a Waveform Segment

1. Press Mode > Dual ARB > Waveform Segments.

2. Highlight the desired file and press Rename Segment > Editing Keys > Clear Text.

3. Enter the desired file name and then press Enter.
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Using Waveform Markers

The signal generator provides four waveform markers to mark specific points on a waveform segment.
When the signal generator encounters an enabled marker, an auxiliary output signal is routed to the rear
panel event connector (described in “Rear Panel” on page 22) that corresponds to the marker number. You
can use this auxiliary output signal to synchronize another instrument with the waveform, or as atrigger
signal to start a measurement at a given point on awaveform.

You can also configure markersto initiate ALC hold, or RF Blanking (which includes ALC hold).

Creating a waveform segment (page 92) aso creates a marker file that places a marker point on the first
sample point of the segment for markers one and two. When awaveform file is downloaded that does not
have a marker file associated with it, the signal generator creates a marker file without any marker points.
Factory-supplied segments have a marker point on the first sample for all four markers.

The following procedures demonstrate how to use markers while working in the dual ARB player, but the
process is the same when working in any ARB format.

These procedures al so discuss two types of points: a marker point and a sample point. A marker pointisa
point at which a given marker is set on awaveform; you can set one or more marker points for each marker.
A sample point is one of the many points that compose a waveform.

There are three basic stepsto using waveform markers:

“1. Clearing Marker Points from a Waveform Segment” on page 104

“2. Setting Marker Pointsin a Waveform Segment” on page 105

“3. Controlling Markersin a Waveform Sequence (Dual ARB Only)” on page 108

This section a so provides the following information:

»  “Waveform Marker Concepts’ on page 98

» “Accessing Marker Utilities’ on page 102

*  “Viewing Waveform Segment Markers’ on page 103

*  “Viewing aMarker Pulse” on page 110

e “Using the RF Blanking Marker Function” on page 111
e “Setting Marker Polarity” on page 112
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Waveform Marker Concepts

The signal generator’s ARB formats provide four waveform markers to mark specific points on awaveform
segment. You can set each marker’s polarity and marker points (on a single sample point or over arange of
sample points). Each marker can also perform ALC hold or RF Blanking and ALC hold.

E— J—L Positive 43 EVENT N
Marker
File > O | Marker N
BitN —_— RF Blank Off On
Set Marker Marker - Marker N
E— ; Negative /
On Off Polarit |, BlanksRF
y O_ when Marker
. is Low
When the signal generator encounters an enabled marker (described on 1 RF Blank Only: includes ALC Hold
page 108), an auxiliary output signal is generated and routed to the rear : Marker N
panel event connector that corresponds to the marker number (N). /(V)_ Holds ALC
The EVENT 3 and 4 connectors are pins on the AUXILIARY 1/O connector when Marker
(connector locations are shown in Figure 1-3 on page 22). is Low
Marker N

ALC Hold Off On

Marker File Generation

Generating awaveform segment (see page 92) automatically creates a marker file that places amarker point
on the first sample point of the segment for markers one and two.

Downloading awaveform file (as described in the PSG Programming Guide) that does not have a marker
file associated with it creates a marker file that does not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in volatile memory
(see “Loading Waveform Segments from Non-volatile Memory” on page 96).

In the dual ARB player, you can modify a waveform segment’s marker points without playing the
waveform, or while playing the waveform in an ARB modulation format.

In an ARB modulation format, you must play the waveform before you can modify a segment’s marker
points.

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, or cycle
the PSG power. To ensure that awaveform uses the correct settings when it is played, set the marker
polarities or routing (RF Blanking and ALC Hold), and save the information to the file header (page 80).
Thisis especially important when the segment plays as part of a sequence because the previoudly played
segment could have different marker and routing settings.
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey |abel) either before or after
you set marker points (page 105), setting a marker function before setting marker points may cause power
spikes or loss of power at the RF output.

Use the AL C hold function by itself when you have a waveform signal that incorporatesidle periods, or
when the increased dynamic range encountered with RF blanking (page 111) is not desired.

The ALC hold marker function holds the ALC circuitry at the average (RMS) value of the sampled points
set by the marker(s). For both positive and negative marker polarity, the AL C samples the RF output signal
(the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.
Negative The signal is sampled during the off marker points.

The marker signal has aminimum of atwo sample point delay in itsresponse rel ative to the waveform signal
response. To compensate for the marker signal delay, offset marker points from the waveform sample at
which you want the ALC sampling to begin.

NOTE Because it can affect the waveform’s output amplitude, do not use the AL C hold for longer than
100 ms. For longer time intervals, refer to “ Setting Power Search Mode” on page 281.

Markers set early in time
to account for marker response

g
-‘F. .

RF OUTPUT : >

==
Marker n >3 H
- ) . << .
Positive Polarity .
E“- 100 ms :E
. Max ALC hold time '
CAUTION Incorrect ALC sampling can create a sudden unleveled condition that may create aspikein

the RF output, potentially damaging aDUT or connected instrument. To prevent this
condition, ensure that you set markersto let the ALC sample over an amplitude that
accounts for the higher power levels encountered within the signal.
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Example of Correct Use

Waveform: 1022 points
Marker range: 95-97
Marker polarity: Positive

This example shows a marker set to sample the waveform'’s area of
highest amplitude. Note that the marker is set well before the
waveform’s area of lowest amplitude. This takes into account the
response difference between the marker and the waveform signal.

Close-up of averaging

The AL C samples the waveform when the marker signal goes
high, and uses the average of the sampled waveform to set the
ALC circuitry.

Here the AL C samples during the on marker points (positive
polarity).

Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Positive

This example shows a marker set to sample the low part of the — I ol o il A S
same waveform, which sets the ALC modulator circuitry for Marker l Marker
that level; this usually resultsin an unleveled condition for the

signal generator when it encounters the high amplitude of the /
pulse. Pulse Unleveled
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Example of Incorrect Use

Waveform: 1022 points
Marker range: 110-1022
Marker polarity: Negative
Thisfigure shows that a negative polarity marker goes low during —

the marker on points; the marker signal goes high during the off g Marker on L Maker | on ~
points. The ALC samples the waveform during the off marker SR o i P S S W b
points.

Sample range begins on first point of signal

Sampling both on and off time sets the modulator circuitry
incorrectly for higher signal levels. Note the increased amplitude

at the beginning of the pulse.

Marker Marker
<« Marker On Of =~ On *~

Negative range set between signal and
off time
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Accessing Marker Utilities

Use the following procedure to display the marker parameters. This procedure uses the Dual ARB player,
but you can access the marker utilities through the ARB Setup softkey in all ARB formats.

1. Select the ARB waveform player:

press Mode > Dual ARB

2. Press ARB Setup > Marker Utilities.

ARE Sample Clock

100.0000000 MHz
Select

ARE Reference

Haveform Ext.
Haveform,)
Seaments
Haveform,

N Laveform,
Sequences Utilities
AFE Setup > Harker,

Utilities
Tricoer,|
! Header
(Cont.inUous ) Utilities"
More
(1 of 23

Marker Polaritus

Marker Routingh

Set Markersh

>/

When using an ARB format other than
Dual ARB, you must turn on the format
to enable the Set Markers softkey.

NOTE

Most of the proceduresin this section begin at the Marker Utilities softkey menu.
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Markers are applied to waveform segments. Use the following steps to view the markers set for a segment
(this example uses the factory-supplied segment, SI NE_ TEST WM.

1. Inthe Marker Utilities menu (page 102), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

3. Press Display Markers > Zoom in Max. The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range greater
than 460 points may not show the marker locations.

Marker Polaritum

Marker Routingh

Set Markersh

|

FREQUENCY

44.000 000 000 000 &tz

‘ AMPY

LITUDE

130.00 den

#

Select a segment — |

The Set Marker display -

Catalog of UFM1 Files

Points

RAMP_TEST_WFM

200

Marker
EN: 34

Set Marker On
First Point

Set. Marker On
Range Of Points

Set Marker Off

Fange OF Pointsh

Set Marker Off
All Points

Display Markersy

The display below shows the | and Q components of the waveform, and
the marker points set in a factory-supplied segment.

'

First sample

FREQUENCY

44.000 000 000 000 s

AMPLITUDE

-130.00 den

IEm"\/p_omt shown on
Sample F'oinr-I display

Zoom In

Zoom Out

Arb laveforn Marker:
UFIT1 -STHE_TEST_UF)

Marker
points on

T W\ 8

firstsample

Sample Point

28

Zoom In Maw

Zoom Out. Maw

point

These softkeys

}change the range
of waveform
sample points
shown on the
marker display.

Each press of the
softkey changes
the sample range
by approximately
a factor of two
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1. Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to existing
points. Because markers are cumulative, before you set points, view the segment (page 103) and remove any
unwanted points. With all markers cleared, the level of the event output signal is OV.

Clearing All Marker Points

1
2.

5.

In the Marker Utilities menu (page 102), press Set Markers.

Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

Highlight the desired marker number:
Press Marker 12 3 4.

For the selected marker number, remove all marker pointsin the selected segment:
Press Set Marker Off All Points.

Repeat from Step 3 for any remaining marker points that you want to remove.

Clearing a Range of Marker Points

The following exampl e uses awaveform with marker points (Marker 1) set across points 10-20. This makes
it easy to see the affected marker points. The same process applies whether the existing points are set over a
range (page 105) or asindividual points (page 106).

1. Inthe Marker Utilities menu (page 102), select the desired marker (for this example, Marker 1).
2. Set thefirst sample point that you want off (for this example, 13):
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.

3. Set thelast marker point in the range that you want off to a value less than or equal to the number of
points in the waveform, and greater than or equal to the value set in Step 2 (for this example, 17):
Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

Thisturns off al marker points for the active marker within the range set in Steps 2 and 3, as shown in
the following figure.
Arb laveforn Markers
UFM1:RANP_TEST_UFN
I
0
1
2
3
L
1 Sample Point 28
Viewing markers is described on page 103
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Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points’ on page 104, but set both the first and last
marker point to the value of the point you want to clear. For example, if you want to clear a marker on point
5, set both the first and last value to 5.

2. Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in volatile memory (page 96).

When you set marker points, they do not replace points that already exist, but are set in addition to existing
points. Because markers are cumulative, before you set marker points within a segment, view the segment
(page 103) and remove any unwanted points (page 104).

Placing a Marker Across a Range of Points

1. Inthe Marker Utilities menu (page 102), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

3. Highlight the desired marker number:
Press Marker 12 3 4

4. Set thefirst sample point in the range (in this example, 10):
Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set thelast marker point in the range to avalue less than or equal to the number of pointsin the
waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.
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6. Press Apply To Waveform > Return.

This sets arange of waveform marker points. The marker signal starts on sample point 10, and ends on
sample point 20, as shown in the following figure.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 103

Placing a Marker on a Single Point
On the First Point

1. Inthe Marker Utilities menu (page 102), press Set Markers.

2. Highlight the desired waveform segment.
In an ARB format, there is only one file (AUTOGEN WAVEFCRM) and it is already highlighted.

3. Highlight the desired marker number:

Press Marker 12 3 4
4. Press Set Marker On First Point.

This sets amarker on the first point in the segment for the marker number selected in Step 3.
On Any Poaint

Use the steps described in “Placing a Marker Across a Range of Points’ on page 105, but set both the first
and last marker point to the value of the point you want to set. For example, if you want to set a marker on
point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped points)
between each marker. You must set the spacing before you apply the marker settings; you cannot apply
skipped points to apreviously set range of points.

1. Remove any existing marker points (page 104).
2. Inthe Marker Utilities menu (page 102), press Set Markers.
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Highlight the desired waveform segment.
In ARB formatsthere is only one file AUTOGEN_WAVEFORM) and it is already highlighted.

Highlight the desired marker number: Press Marker 12 3 4

Set the first sample point in the range (in this example, 5):
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

Set the last marker point in the range to a value less than the number of points in the waveform, and
greater than or equal to the first marker point (in this example, 25):
Press Last Mkr Point > 25 > Enter.

Enter the number of sample points that you want skipped (in this example, 1):
Press # Skipped Points > 1 > Enter.

Press Apply To Waveform > Return.

This causes the marker to occur on every other point (one sample point is skipped) within the marker point
range, as shown below.

Arb laveform Markers
UFITL :RAMP_TEST_UFTI

F WM O

1 Sample Point 28

Viewing markers is described on page 103

One application of the skipped point feature is the creation of a clock signal as the auxiliary output.
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3. Controlling Markers in a Waveform Sequence (Dual ARB Only)

In awaveform segment, an enabled marker point generates an auxiliary output signal that is routed to the
rear panel event connector (described in “Rear Panel” on page 22) corresponding to that marker number. For
awaveform sequence, you enable or disable markers on a segment-by-segment basis; this enables you to
output markers for some segments in a sequence, but not for others. Unless you change the marker settings
or cycle the power, the setting remains the same for the next loaded sequence.

As You Create a Waveform Sequence

After you select the waveform segments to create a waveform sequence, and before you name and save the
sequence, you can enable or disable each segment’s markers independently. Enabling a marker that has no
marker points (page 105) has no effect on the auxiliary outputs.

1. Select the waveform segments (Step 1 on page 93).
2. Toggle the markers as desired:

a. Highlight the first waveform segment.
b. PressEnable/Disable Markers.

c. Asdesired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.
Toggling a marker that has no marker points (page 105) has no effect on the auxiliary outputs.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that segment;
no entry in the column means that all markers are disabled for that segment

d. Inturn, highlight each of the remaining segments and repeat Step c.
3. PressReturn.
4. Name and store the waveform sequence (Step 3 on page 93).

The following figure shows a sequence built reusing the same factory-supplied waveform segment; a
factory-supplied segment has a marker point on the first sample for al four markers. In this example,
Marker 1is enabled for the first segment, Marker 2 is enable for the second segment, and markers 3 and 4
are enabled for the third segment.

Toogle Marker 3
SIME_TEST_HFM| (UNSTORED) UNTITLED s Marker Col
(1/2) 5 t 5 e| (1/1) Uaveforn  Repsty/fik® equence Marker Column
AUTOGEN_PRAM_1 ZKELZKKM WFM1:SINE_TEST_WFH 10t Togole Marker b .
RAMP_TEST_MFH A WFHL:SINE_TEST MFHM 1]z This entry shows that
SIHE_TEST_UFN ARZ2 LIFF1: S IME-TES T LIFH @D ) markers 3 and 4 are enabled
EDHPLEE for this segment.

For each segment, only the markers enabled for that segment produce arear-panel auxiliary output signal. In
this example, the Marker 1 auxiliary signal appears only for the first segment, because it is disabled for the
remaining segments. The Marker 2 auxiliary signal appears only for the second segment, and the marker 3
and 4 auxiliary signals appear only for the third segment.
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If you have not already done so, create and store a waveform segquence that contains at least three segments
(page 93). Ensure that the segment or segments are available in volatile memory (page 96).

1
2.
3.

4,
5.
6.

Press Mode > Dual ARB > Waveform Sequences, and highlight the desired waveform sequence.
Press Edit Selected Waveform Sequence, and highlight the first waveform segment.
Press Enable/Disable Markers > Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 4.

Toggling a marker that has no marker points (page 105) has no effect on the auxiliary outputs.

Anentry inthe Mkr column indicates that the marker is enabled for that segment; no entry in the column
means that all markers are disabled for that segment

Press Return > Name And Store > Enter.

Highlight the next waveform segment and toggle the desired markers (in this example, markers 1 and 4).

Repeat Step 4 as desired (for this example, select the third segment and toggle marker 3).

The markers are enabled or disabled per your selections, and the changes have been saved to the selected
sequencefile.

FREQUEMNCY

44.000 000 000 000 &+

‘QHPLITUDE

30.00 n

B

RAMP_TEST_LIFM

(UHSTORED)

EXANPLE

1/1) Seoment Sequence | (1/1) Haveform Repswﬁia\
RANP_TEST_UFN EXAMPLE HFM1:SINE_TEST_LFM 1 (1234

SINE_TEST_LIFM EXANMPLEZ
GH_SEQ
G_EL+8CH_COMA
LULTITOME_SEQUENCE
SIME_¥_20_SEG

T

HCOMA+GESM_K1ER

HFML RAMP_TEST_LFH
JIFM1:SIKE_TEST LFH

Toogle ker 3

Togole Marker 1

Togole Marker 2

Togole Marker 4

Sequence Marker Column
//’/// q

This entry shows that only
marker 3 is enabled for this
segment.

Goto Rouk
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Viewing a Marker Pulse

When awaveform plays (page 94), you can detect a set and enabled marker’s pulse at the rear panel event
connector that corresponds to that marker number. This example demonstrates how to view amarker pulse
generated by a waveform segment that has at least one marker point set (page 105). The processisthe same
for awaveform sequence.

This exampl e uses the factory-supplied segment, S| NE_ TEST WFMin the Dual ARB Player.
Factory-supplied segments have a marker point on the first sample point for all four markers, as shown.

Arb laveform Markers
UFITL :STHE_TEST_UFTI

Marker points on
first sample point of
waveform segment

rmmM -
[

Sample Point 28
Viewing markers is described on page 103

1. Press Mode > Dual ARB > Select Waveform, and highlight the desired segment (in this example,
SI NE_TEST_WFM).

2. Press ARB Off On to On.

3. Connect an oscilloscope input to the EVENT 1 connector, and trigger on the Event 1 signal.
When amarker is present, the oscilloscope displays a marker pulse, as shown in the following example.

RF Output

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set amarker function (described as Marker Routing on the softkey label) either before or after
setting the marker points (page 105), setting amarker function before you set marker points may change the
RF output. RF Blanking includes AL C hold (described on page 99, note Caution regarding unlevel ed
power). The signal generator blanks the RF output when the marker signal goes low.

1. Using the factory-supplied segment SI NE_TEST WM set Marker 1 across points 1-180 (page 105).
2. From the Marker Utilities menu (page 102), assign RF Blanking to Marker 1:
Press Marker Routing > Pulse/RF Blank > Marker 1.

Marker Polarity = Positive

RF Signal When marker polarity is positive (the

default setting), the RF output is blanked
during the off maker points.
| h

||-|II IInII
|
'

SN 0. NP R M Ao =3.3V

ov

Marker Polarity = Negative

When marker polarity is negative, the
RF output is blanked during the on
maker points

R S S RS S oV

|<«—Segment——»|
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Setting Marker Polarity
Setting a negative marker polarity inverts the marker signal.

1. Inthe Marker Utilities menu (page 102), press Marker Polarity.

2. Select the marker polarity as desired for each marker number.

: Marker 1 Polgritd
Marker Polarit > . o
Arker Folaritd Neo Nzl Default Marker Polarity = Positive

; Marker 2 Polarit
Marker Routingh Heg lﬁ o
Set each marker polarity independently.
Marker 3 Polarit
Set. Markersh e |

) See Also: “Saving Marker Polarity and Routing Settings” on page 98.
Marker hNgSlarlti

|
As shown on page 111:
Positive Polarity:  On marker points are high (=3.3V).
Negative Polarity: On marker points are low (OV).
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Triggering Waveforms

Triggering is available in both ARB and real-time formats. ARB triggering controls the playback of a
waveform file; real-time custom triggering controls the transmission of a data pattern. The examples and
discussions in this section use the Dual ARB Player, but the functionality and method of access (described
on page 115) are similar in al (ARB and real-time) formats.

Triggers control datatransmission by telling the PSG when to transmit the modulating signal. Depending on
the trigger settings, the data transmission may occur once, continuoudly, or the PSG may start and stop the
transmission repeatedly (Gated mode).

A trigger signal comprises both positive and negative signal transitions (states), which are also called high
and low periods; you can configure the PSG to trigger on either state. It is common to have multipletriggers,
also referred to as trigger occurrences or trigger events, occur when the signal generator requires only a
single trigger. In this situation, the PSG recognizes the first trigger event and ignores the rest.

When you select atrigger mode, you may lose the signal (carrier plus modulation) from the RF output until
you trigger the modulating signal. This is because the PSG setsthe | and Q signalsto zero volts prior to the
first trigger event, which suppresses the carrier. If you create a data pattern with the initial | and Q voltages
set to values other than zero, this does not occur. After the first trigger event, the signal’sfinal | and Q levels
determine whether you see the carrier signal or not (zero = no carrier, other values = visible carrier). At the
end of most data patterns, the final | and Q points are set to avalue other than zero.

There are four parts to configuring a waveform trigger:

»  Source determines how the PSG receives the trigger that initiates waveform play.

* Mode determines the waveform'’s overall behavior when it plays.

* Response determines the specifics of how the waveform responds to a trigger.

» Polarity determines the state of the trigger to which the waveform responds (used only with an external
trigger source); you can set either negative, or positive.

Source

Tricger Keu 4@——The Trigger hardkey

Eus yv@——A command sent through the rear-panel GPIB, LAN, or Auxiliary (RS-232) interface

An external trigger signal applied to either the PATTERN TRIG IN connector, or the PATT TRIG IN 2

Ext 1 ) . L
* pin on the AUXILIARY 1/O connector (connector locations are shown in Figure 1-3 on page 22).

(Patt '%;5"195%'"%. The following parameters affect an external trigger signal:

» The source (Input connector) of the external trigger signal (see page 115)
Ext Polarity
Pos » The polarity of the external trigger (described on page 115)
Ext Delay « Any desired delay between when the PSG receives an external trigger and when the
an waveform responds to it (see page 115).
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Mode and Response

The arbitrary waveform player provides four trigger modes; each mode has one or more possible responses:

Single plays the waveform once. Arb formats have the following retriggering options:

— Off ignores triggers received during play; atrigger received after playback completes restarts the
playback.

— On causes atrigger received during play to repeat the waveform after the current play compl etes.

— Immediate causes atrigger received during play to immediately restart the waveform.

Gated causes the waveform to wait for the first active trigger signal state to begin transmission, then
repeatedly start and stop in response to an externally applied gating signal (example on page 116). You
select the active state with the Gate Active Low High softkey (see page 115).

In an ARB format, the waveform plays during the inactive state, and stops during the active state.
In real-time Custom, behavior depends on whether the signal incorporates framed or unframed data.

Because the PSG provides only unframed data, to transmit a framed data signal you must create an
externa file that incorporates the framing and download it to the PSG (see the Programming Guide).

— Unframed data transmits during active states, and stops during inactive states. The signal stops at the
last transmitted symbol and restarts at the next symbol.

— Framed data starts transmitting at the beginning of a frame during active states, and stops at the end
of aframe when the end occurs during inactive states. If the end of the frame extends into the next
active state, the signal transmits continuoudly.

Segment Advance (Dual ARB only) causes a segment in a sequence to require atrigger to play. The
trigger source controls how play moves from segment to segment (example on page 118). A trigger
received during the last segment |oops play to thefirst segment in the sequence. You have two choices as
to how the segments play:

— Single causes a segment in a sequence to play once, then to stop and wait for atrigger before
advancing to the next segment, which plays to completion. Triggers received during play cause the
current segment to finish, then play advances to the next segment, which plays to completion.

— Continuous causes a segment in a sequence to play continuously until the waveform receives another
trigger. Triggers received during play cause the current segment to finish, then play advances to the
next segment, which plays continuously.

Continuous repeats the waveform until you turn the signal off or select another waveform, trigger mode,
or response. Continuous has the following options:

— Free Run immediately triggers and plays the waveform; triggers received during play areignored.

— Trigger & Run plays the waveform when atrigger is received; subsequent triggers are ignored.

— Reset & Run (not available in real-time Custom) plays the waveform when atrigger is received,
subsequent triggers restart the waveform.
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Accessing Trigger Utilities

The following figures show the menus for the trigger parameters. These figures show the Dual ARB player,
but you can access the trigger utilities through the Trigger softkey in all ARB formats, and the Pattern Trigger
softkey in the Real Time I/Q Baseband (Custom) format.

. PATTERN TRIG IN connector
Trigger Ked

Patt Trio In 1

e Continuous TrioBen S e Bus
; Fatt Trio In 2
Haveform, : Cont inuous Mode il _
Seament.s Sinale (Free Run) Ext
PAT TRIG IN 2 pinon

SuaueForm, Gated Retrioger ng?b (Patt I%xt S%urg?, the AUXILARY /O connector
equences n =} ria In

Seq Advance Mode Ext Polarity
ARE SetupM Seament. Advance (Cont.inuous )™ Pos

Active only when
Ext is selected.

Trigoer| o : Gate Aochive Ext [elad
(Cont.inuans) o Trigger Setupk—e» Lan an

Ext Delay Time
1.00000000 meec

» Todisplay thetrigger modes, press Mode > Dual ARB > Trigger.

» Todisplay the response selections available for a given trigger mode, press Trigger Setup, then select the
desired trigger mode. To see the selections for Single mode in an ARB format, select Retrigger Mode; in
real-time Custom, selecting Single mode causes the data pattern to play once when triggered.

» Todisplay thetrigger source options, press Trigger Setup > Trigger Source.
Setting the Polarity of an External Trigger

Gated Mode

The selections available with the gate active parameter refer to the low and high states of an external trigger
signal. For example, when you select High, the active state occurs during the high of the trigger signal.

ARB Formats When the active state occurs, the PSG stops the waveform file playback at the last
played sample point, and restarts the playback at the next sample point when the
inactive state occurs.

Real-Time Custom When the active state occurs, the PSG transmits the data pattern. When the inactive
state occurs, the transmission stops at the last transmitted symbol, and restarts at the
next symbol when the active state occurs.

Continuous, Single, or Segment Advance Modes

The Ext Polarity Neg Pos softkey selectionsrefer to the low (negative) and high (positive) states of an external
trigger. With Neg selected (the default), the PSG responds during the low state of the trigger signal.
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Using Gated Triggering

Gated triggering enables you to define the on (playback) and off states of a modulating waveform. This
exampl e uses the factory supplied segment, SI NE_ TEST WM

1. Connect the output of afunction generator to the signal generator’s rear-panel PATTERN TRIG IN, as
shown in the following figure.
Function Generator
N\
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Signal Generator TRIG IN Oscilloscope
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H
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i
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This connection is applicable to all external triggering methods. The optional oscilloscope connection
enables you to see the effect that the trigger signal has on the RF output.

2. Preset the signal generator.

3. Configurethe carrier signal output:

e Set the desired frequency.
e Set the desired amplitude.
e Turn on the RF output.

4. Select awaveform for playback (sequence or segment):

a. Preset the signal generator.

b. Press Mode > Dual ARB > Select Waveform.

¢. Highlight awaveform file (for this example, SI NE_TEST WFMN).
d. Press Select Waveform.

5. Select the waveform trigger method:

a  PressTrigger > Gated.

b. PressTrigger > Trigger Setup and note that for the Gate Active Low High softkey, the default selection is
High, which is the selection used in this example.
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6. Select the trigger source and rear panel input:

a. For the Trigger Source softkey, the default selection isExt, which is the selection used in this example
(gated triggering requires an external trigger).

b. PressTrigger Source and note that for the Ext Source softkey, the default selection is Patt Trig In 1, which
isthe selection used in this example.

7. Generate the waveform:

Press ARB Off On to On.
8. Onthe function generator, configurea TTL signal for the external gating trigger.
9. (Optional) Monitor the current waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external triggering
signal. You will see the waveform modulating the output during the gate inactive periods (low).

The following figure shows an example display.

Modulating Waveform RF Output

.
S W W\I\'ﬁ&” AN

]

Externally Applied Gating Signal
Gate Active = High

NOTE In the real-time Custom mode, the behavior is reversed: when the gating signal is high, you
see the modul ated waveform.
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Using Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform sequence. The
following example uses a waveform sequence that has two segments.

If you have not created and stored a waveform sequence, complete the steps in the sections, “ Creating
Waveform Segments’ on page 92, and “Building and Storing a Waveform Sequence” on page 93.

1. Preset the signal generator.
2. Configure the RF output:

e Set the desired frequency.
e Set the desired amplitude.
e Turn on the RF output.

3. Select awaveform sequence for playback:

a  Press Mode > Dual ARB > Select Waveform.
b. Highlight awaveform sequencefile.
C. Press Select Waveform.

4. Select the waveform trigger method and trigger source:

a. PressTrigger > Segment Advance.

b. PressTrigger > Trigger Setup and note that the Seg Advance Mode softkey displays the default selection
(Continuous), which is the selection used in this example.

C. PressTrigger Source > Trigger Key.

5. Generate the waveform sequence:
Press Return > Return > ARB Off On to On.

6. Trigger the first waveform segment to begin playing repeatedly:
Press the Trigger hardkey.

7. (Optional) Monitor the current waveform:

Connect the output of the signal generator to the input of an oscilloscope, and configure the oscill oscope
so that you can see the output of the signal generator.

8. Trigger the second segment:
Press the Trigger hardkey.

The second segment in the sequence now plays. Pressing the Trigger hardkey causes the current playback
to finish and the next segment to start; when the last segment plays, pressing the Trigger hardkey causes
the first segment in the waveform sequence to start when the current segment finishes.
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Using Waveform Clipping

Waveforms with high power peaks can cause intermodul ation distortion, which generates spectral regrowth
(acondition that interferes with signalsin adjacent frequency bands). The clipping function enables you to
reduce high power peaks by clipping the | and Q data to a selected percentage of its highest peak.

The clipping feature is available only with the Dual ARB mode.

How Power Peaks Develop

To understand how clipping reduces high power peaks, it isimportant to know how the peaks develop asthe
signal is constructed.

1/Q waveforms can be the summation of multiple channels (see Figure 3-10). Whenever most or all of the
individual channel waveforms simultaneously contain a bit in the same state (high or low), an unusually
high power peak (negative or positive) occurs in the summed waveform. This does not happen frequently
because the high and low states of the bits on these channel waveforms are random, which causes a
cancelling effect.

Figure 3-10 Multiple Channel Summing
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Chapter 3 119



Basic Digital Operation
Using Waveform Clipping

The | and Q waveforms combine in the 1/Q modulator to create an RF waveform. The magnitude of the RF

envelope is determined by the equation /12+Q2, where the squaring of | and Q always resultsin a positive
value.

Asshown in Figure 3-11, simultaneous positive and negative peaksin the | and Q waveforms do not cancel
each other, but combine to create an even greater peak.

Figure 3-11 Combining the | and Q Waveforms
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How Peaks Cause Spectral Regrowth

Because of the relative infrequency of high power peaks, awaveform will have a high peak-to-average
power ratio (see Figure 3-12). Because atransmitter’s power amplifier gain is set to provide a specific
average power, high peaks can cause the power amplifier to move toward saturation. This causes
intermodulation distortion, which generates spectral regrowth.

Figure 3-12 Peak-to-Average Power

———————————————— Peak Power

Average Power

Spectral regrowth is arange of frequencies that develops on each side of the carrier (similar to sidebands)
and extends into the adjacent frequency bands (see Figure 3-13). Consequently, spectral regrowth interferes
with communication in the adjacent bands. Clipping can provide a solution to this problem.

Figure 3-13 Spectral Regrowth Interfering with Adjacent Band
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How Clipping Reduces Peak-to-Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the waveform to a
selected percentage of its peak power. The PSG vector signal generator provides two different methods of
clipping: circular and rectangular.

During circular clipping, clipping is applied to the combined | and Q waveform (]I + jQJ). Notice in Figure
3-14 that the clipping level is constant for all phases of the vector representation and appears asacircle.
During rectangular clipping, clipping is applied to the | and Q waveforms separately (|l|, |Q|). Noticein
Figure 3-15 on page 123 that the clipping level is different for | and Q; therefore, it appears asarectanglein
the vector representation. With either method, the objectiveisto clip the waveform to alevel that effectively
reduces spectral regrowth, but does not compromise theintegrity of the signal. Figure 3-16 on page 124 uses
two complementary cumulative distribution plots to show the reduction in peak-to-average power that
occurs after applying circular clipping to awaveform.

The lower you set the clipping value, the lower the peak power that is passed (or the morethe signal is
clipped). Often, the peaks can be clipped successfully without substantially interfering with the rest of the
waveform. Datathat might be lost in the clipping processis salvaged because of the error correction inherent
in the coded systems. If you clip too much of the waveform, however, lost dataisirrecoverable. You may
have to try several clipping settings to find a percentage that works well.

Figure 3-14 Circular Clipping
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Figure 3-15 Rectangular Clipping
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Figure 3-16 Reduction of Peak-to-Average Power
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Configuring Circular Clipping

This procedure shows you how to configure circular clipping. The circular setting clips the composite I/Q
data (I and Q data are clipped equally). For more information about circular clipping, refer to “How Clipping
Reduces Peak-to-Average Power” on page 122.

1

© © N o

Press Preset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMI s highlighted on the
display. AUTOGEN_WAVEFORM is the default name assigned to the waveform you generated in the
previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.

Press ARB 0Off On to On. The Dual Arb player must be turned on to display the CCDF plot in the following
steps.

Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFCRMis
highlighted on the display.

Press CCDF Plot and observe the position of the waveform’s curve, which is the darkest line.
Press Return > Return > Clipping.
Ensure that the Clipping Type |1+jQ] |1],]1Q] softkey is set to |1+jQ], whichis circular clipping.

Press Clip |1+jQ] To > 80 > % > Apply to Waveform. The | and Q data are both clipped by 80%. Once
clipping is applied to the waveform it cannot be undone. Repeated use of the clipping function has a
cumulative effect on the waveform.

10. Press Waveform Statistics > CCDF Plot and observe the waveform’s curve. Notice the reduction in

peak-to-average power, relative to the previous plot, after applying clipping.
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Configuring Rectangular Clipping

This procedure shows you how to configure rectangular clipping. The rectangular setting clipsthe | and Q
dataindependently. For more information about rectangular clipping, refer to “How Clipping Reduces
Peak-to-Average Power” on page 122.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN_WAVEFORM is the default name assigned to the waveform you generated in the
previous step.

Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.

4. PressARB Off On to On. The Dua Arb player must be turned on to display the CCDF plot in the following
steps.

5. Press ARB Setup > Waveform Utilities > Waveform Statistics and ensure that AUTOGEN WAVEFCRMis
highlighted on the display.

6. Press CCDF Plot and observe the position of the waveform's curve, which is the darkest line.
7. PressReturn > Return > Clipping.

8. Ensure that the Clipping Type |1+jQ] |1],1Q] softkey isset to |1],]Q]. This activates the Clip |1] To and
Clip |Q| To softkeys that enable you to configure rectangular (independent) | and Q data clipping.

9. PressClip |1] To > 80 > %.

10. Press Clip | Q] To > 40 > % > Apply to Waveform. The | and Q data are individually clipped by 80% and
40%, respectively. Once clipping is applied to the waveform it cannot be undone. Repeated use of the
clipping function has a cumulative effect on the waveform.

11. Press Waveform Statistics > CCDF Plot and observe the waveform'’s curve. Notice the reduction in
peak-to-average power, relative to the previous plot, after applying clipping.
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Using Waveform Scaling

Waveform scaling is used to eliminate DA C over-range errors. The PSG provides two methods of waveform
scaling. You can perform runtime scaling, which enables you to make real -time scaling adjustments of a
currently playing waveform, or you can permanently scale a non-playing waveform file residing in volatile
memory. This section describes how DAC over-range errors occur and how you can use waveform scaling to
eliminate these errors effectively.

The scaling feature is available only with the Dual ARB mode.

How DAC Over-Range Errors Occur

The PSG utilizes an interpolator filter in the conversion of the digital | and Q baseband waveforms into
analog waveforms. The clock rate of the interpolator is four times that of the baseband clock. The
interpolator therefore cal cul ates sample points between the incoming baseband samples to equal the faster
clock rate and smooth out the waveform, giving it a more curve-like appearance (see Figure 3-17).

Figure 3-17 Waveform Interpolation
INTERPOLATED SAMPLES
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BASEBAND SAMPLES

Theinterpolation filters in the DAC's have overshoot. If a baseband waveform has afast-rising edge, the
interpolator filter's overshoot or frequency response becomes a component of the interpolated baseband
waveform. This response causes aripple or ringing effect at the peak of therising edge. If this ripple exceeds
(or overshoots) the upper limit of the DAC's range, the interpolator calculates erroneous sample points and
is unable to replicate the true form of the ripple (see Figure 3-18). As aresult, the PSG reportsa DAC
over-range error.
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Figure 3-18
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How Scaling Eliminates DAC Over-Range Errors

Scaling reduces or shrinks a baseband waveform’s amplitude while maintaining its basic shape and
characteristics, such as peak-to-average power ratio. If the fast-rising baseband waveform is scaled enough
to allow an adequate margin for the overshoot, the interpolator filter is then able to calculate sample points
that include the ripple effect, thereby eliminating the over-range error (see Figure 3-19).

Figure 3-19 Waveform Scaling
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Although scaling maintains the basic shape of the waveform, too much scaling can compromise itsintegrity
because the bit resolution can be so low that the waveform becomes corrupted with quantization noise.
Maximum accuracy and optimum dynamic range are achieved by scaling the waveform just enough to
remove the DAC over-range error. Optimum scaling varies with waveform content.

Scaling a Currently Playing Waveform (Runtime Scaling)

This procedure enables you to make real-time scaling adjustments to a currently playing waveform. This
type of scaling does not affect the waveform file and is well suited for eliminating DAC over-range errors.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN_WAVEFORM is the default name assigned to the waveform you generated in the
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
4. Press ARB Off On to On. This plays the selected waveform.

5. Press ARB Setup > More (1 of 2) > Waveform Runtime Scaling and adjust the front panel knob or use the
number keys to enter a new value. The new scaling value isinstantly applied to the playing waveform.
Runtime scaling adjustments are not cumulative, as the values are always rel ative to original amplitude
of the waveform file.

Scaling a Waveform File in Volatile Memory

This procedure enables you to permanently scale awaveform file. You can then store the scaled waveform
segment to non-volatile memory for future use. Scaling is cumulative and non-reversible.

1. PressPreset > Mode > Custom > Arb Waveform Generator > Digital Modulation Off On to On. This generates a
custom arbitrary waveform for use in this procedure. You can aso use a previously stored or
downloaded waveform.

2. Press Mode > Dual ARB > Select Waveform and ensure that AUTOGEN WAVEFCRMi s highlighted on the
display. AUTOGEN_WAVEFORM is the default name assigned to the waveform you generated in the
previous step.

3. Press Select Waveform. This selects the waveform and returns you to the previous softkey menu.
4. Press ARB Setup > Waveform Utilities and ensure that AUTOGEN WAVEFORMI s highlighted on the display.

5. Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform. The waveform is now reduced to 70
percent of its original amplitude. Once this type of scaling is applied to the waveform it cannot be

undone. Repeated scaling applications have a cumulative effect on the waveform.
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4 Optimizing Performance

In the following sections, this chapter describes proceduresthat improve the performance of the Agilent PSG
signal generator.

e “Usingthe ALC” on page 132

e “Using External Leveling” on page 133

e “Creating and Applying User Flatness Correction” on page 137

e “Adjusting Reference Oscillator Bandwidth (Option UNR)” on page 149
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Using the ALC

Selecting ALC Bandwidth

For internal leveling, the signal generator uses automatic leveling control (ALC) circuitry prior to the RF
output. AL C bandwidth has five selections: automatic, 100 Hz, 1 kHz, 10 kHz, and 100 kHz. In automatic
mode (the preset selection), the signal generator automatically selects the AL C bandwidth depending on the
configuration and settings (see Figure 4-1).

Figure 4-1 Decision Tree for Automatic ALC Bandwidth Selection
ALC BW AM OFF | No AM OFF |[No AMON |[No AM ON
100 Hz PULSE OFF [ pyLse on [P PULSE ON P> | bULSE OFF
es Yes| Yes Yes
Yes Ves + +
Arson |N° |RFOUTPUT| No ALC BW ALC BW ALC BW,

—>
> <2 MHz 1 kHz 10 kHz 100 kHz

To Select an ALC Bandwidth

Press Amplitude > ALC BW > 100 Hz, 1 kHz, 10 kHz, or 100 kHz.
This overrides the signal generator’s automatic AL C bandwidth selection with your specific selection.

For waveforms with varying amplitudes, high crest factors, or both, the recommended AL C loop bandwidth
is 100 Hz. Limiting the loop bandwidth of the ALC circuit will prevent the ALC from sampling the fast
rising edges of pulsed waveforms with high crest factors found in formats such as 802.11b, CDMA, and
OFDM. A limited, or narrow bandwidth will result in alonger ALC sample time and amore accurate
representation of the signal’s level.

NOTE Do not use the 10 kHz AL C bandwidth for any 1/Q modulated signal, asthe ALC
integration time is too short. For CW signals, you can use higher AL C bandwidths.
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Using External Leveling

The PSG signal generator can be externally leveled by connecting an external sensor at the point where
leveled RF output power is desired. This sensor detects changes in RF output power and returns a
compensating voltage to the signal generator’s ALC input. The ALC circuitry raises or lowers (levels) the
RF output power based on the voltage received from the external sensor, ensuring constant power at the
point of detection.

There are two types of external leveling available on the PSG. You can use external leveling with a detector
and coupler/power splitter setup, or amillimeter-wave source module.

To Level with Detectors and Couplers/Splitters

Figure 4-2 illustrates atypical external leveling setup. The power level feedback to the ALC circuitry is
taken from the external negative detector, rather than the internal signal generator detector. This feedback
voltage controls the ALC system, leveling the RF output power at the point of detection.

To use detectors and couplers/splitters for external leveling at an RF output frequency of
10 GHz and an amplitude of 0 dBm, follow the instructionsin this section.

Required Equipment

» Agilent 8474E negative detector
» Agilent 87301D directional coupler
» cables and adapters, as required

Connect the Equipment

Set up the equipment as shown in Figure 4-2.

Figure 4-2 External Detector Leveling with a Directional Coupler
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Configure the Signal Generator

o A w DN

Press Preset.

Press Frequency > 10 > GHz.
Press Amplitude > 0 > dBm.
Press RF On/0ff.

Press Leveling Mode > Ext Detector.

This deactivates the internal ALC detector and switches the AL C input path to the front panel ALC
INPUT connector. The EXT indicator is activated in the AMPLI TUDE area of the display.

NOTE

For signal generators with Option 1E1, notice that the ATTN HCOLD (attenuator hold)
annunciator is displayed. During external leveling, the signal generator automatically
uncouples the attenuator from the ALC system for all external leveling points. Whilein this
mode, the RF output amplitude adjustment is limited to —20 to +25 dBm, the adjustment
range of the ALC circuitry. For more information, see “External Leveling with Option 1E1
Signal Generators’ on page 136.

6. Observe the coupling factor printed on the directional coupler at the detector port. Typically, thisvalueis
-10to-20 dB.

Enter the positive dB value of this coupling factor into the signal generator.

7. Press More (1 of 2) > Ext Detector Coupling Factor > 16 (or the positive representation of the value listed at
the detector port of the directional coupler) > dB.

Leveled output power is now available at the output of the directional coupler.

NOTE While operating in external leveling mode, the signal generator’s displayed RF output
amplitude is affected by the coupling factor value, resulting in a calculated approximation of
the actual RF output amplitude. To determine the actual RF output amplitude at the point of
detection, measure the voltage at the external detector output and refer to Figure 4-3 or
measure the power directly with a power meter.
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Figure 4-3 shows the input power versus output voltage characteristics for typical Agilent Technologies
diode detectors. Using this chart, you can determine the leveled power at the diode detector input by
measuring the external detector output voltage. You must then add the coupling factor to determine the
leveled output power. The range of power adjustment is approximately -20 to +25 dBm.

Figure 4-3 Typical Diode Detector Response at 25° C
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External Leveling with Option 1E1 Signal Generators

Signal generators with Option 1E1 contain a step attenuator prior to the RF output connector. During
externa leveling, the signal generator automatically holds the present attenuator setting (to avoid power
transients that may occur during attenuator switching) as the RF amplitude is changed. A balance must be
maintained between the amount of attenuation and the optimum AL C level to achieve the required RF
output amplitude. For optimum accuracy and minimum noise, the ALC level should be greater than —10
dBm.

For example, leveling the CW output of a 30 dB gain amplifier to alevel of —10 dBm requires the output of
the signal generator to be approximately —40 dBm when leveled. This is beyond the amplitude limits of the
ALC modulator alone, resulting in an unleveled RF output. Inserting 45 dB of attenuation resultsinan ALC
level of +5 dBm, well within the range of the ALC modulator.

NOTE In the example above, 55 dB is the preferred attenuation choice, resulting in an ALC level
of +15 dBm. This provides adequate dynamic range for AM or other functionsthat vary the
RF output amplitude.

To achieve the optimum ALC level at the signal generator RF output of —40 dBm for an unmodul ated
carrier, follow these steps:

1. Press Amplitude > Set Atten > 45 > dB.
2. PressSet ALC Level > 5> dBm.

This sets the attenuator to 45 dB and the ALC level to +5 dBm, resulting in an RF output amplitude of -40
dBm, as shown in the AMPLI TUDE area of the display.

To obtain flatness-corrected power, refer to “ Creating and Applying User Flatness Correction” on page 137.

To Level with a mm-Wave Source Module

Millimeter-wave source module leveling is similar to external detector leveling. The power level feedback

signal to the AL C circuitry is taken from the millimeter-wave source module, rather than the internal signal
generator detector. This feedback signal levels the RF output power at the mm-wave source module output
through the signal generator’s rear panel SOURCE MODULE interface connector.

For instructions and setups, see Chapter 11, “Peripheral Devices,” on page 235.
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Creating and Applying User Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 frequency
pointsin any frequency or sweep mode. Using an Agilent E4416A/17A or E4418B/19B power meter
(controlled by the signal generator through GPIB) to calibrate the measurement system, a table of power
level correctionsis created for frequencies where power level variations or losses occur. These frequencies
may be defined in sequential linear steps or arbitrarily spaced.

To allow different correction arrays for different test setups or different frequency ranges, you may save
individual user flatness correction tables to the signal generator’s memory catalog and recall them on
demand.

Use the stepsin the next sections to create and apply user flatness correction to the signal generator’s RF
output.

Afterward, use the stepsin “Recalling and Applying a User Flatness Correction Array” on page 141 to recall
a user flatness file from the memory catalog and apply it to the signal generator’s RF output.

Creating a User Flatness Correction Array

In this example, you create a user flatness correction array. The flatness correction array contains ten
frequency correction pairs (amplitude correction values for specified frequencies), from 1 to 10 GHz in
1 GHzintervals.

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and E4413A
power sensor are used to measure the RF output amplitude at the specified correction frequencies and
transfer the results to the signal generator. The signal generator reads the power level datafrom the power
meter, calculates the correction values, and stores the correction pairsin the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB interface,
you can enter correction values manually.

Required Equipment

* Agilent E4416A/17A/18B/19B power meter
* Agilent E4413A E Series CW power sensor
* GPIB interface cable

e adapters and cables, as required

NOTE If the setup has an external leveling configuration, the equipment setup in Figure 4-4
assumes that the steps necessary to correctly level the RF output have been followed. If you
have questions about external leveling, refer to “Using External Leveling” on page 133.
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Configure the Power Meter

Select SCPI as the remote language for the power meter.

Zero and calibrate the power sensor to the power meter.

Enter the appropriate power sensor calibration factors into the power meter as appropriate.
Enable the power meter’s cal factor array.

E NN o

NOTE For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in Figure 4-4.

NOTE During the process of creating the user flatness correction array, the power meter is slaved
to the signal generator via GPIB. No other controllers are allowed on the GPIB interface.

Figure 4-4 User Flatness Correction Equipment Setup
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Configure the Signal Generator

10.

Press Preset.

Configure the signal generator to interface with the power meter.

a. Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > Power Meter > E4416A, E4417A, E4418B,
or E4419B.

b. Press Meter Address > enter the power meter’s GPIB address > Enter.
c. For E4417A and E4419B models, press Meter Channel A B to select the power meter’s active channel.

d. Press Meter Timeout to adjust the length of time before the instrument generates atimeout error if
unsuccessfully attempting to communicate with the power meter.

Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.

This opens the User Flatness table editor and presets the cal array frequency/correction list.
Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

Press Freq Start > 1 > GHz.

Press Freq Stop > 10 > GHz.

Press # of Points > 10 > Enter.

Steps 4, 5, and 6 enter the desired flatness-corrected frequencies into the step array.

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

This popul ates the user flatness correction array with the frequency settings defined in the step array.
Press Amplitude > 0 > dBm.

Press RF On/Off.

This activates the RF output and the R QN annunciator is displayed on the signal generator.
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Perform the User Flatness Correction

NOTE If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter
does not have a GPIB interface, you can perform the user flatness correction manually. For
instructions, see “ Performing the User Flatness Correction Manually” on page 140.

1. PressMore (1 of 2) > User Flatness > Do Cal.

This creates the user flatness amplitude correction value table entries. The signal generator enters the
user flatness correction routine and a progress bar is shown on the display.

2. PressDone.
This loads the amplitude correction values into the user flatness correction array.
If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the stored amplitude correction values.
The user flatness correction array title displays User Fl at ness: ( UNSTORED) indicating that the
current user flatness correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a
GPIB interface, complete the steps in this section and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value
(1 GHz) for row 1. The RF output changes to the frequency value of the table row containing the cursor
and 1. 000 000 000 00 isdisplayed inthe AMPLI TUDE area of the display.

Observe and record the measured value from the power meter.
Subtract the measured value from 0 dBm.

Move the table cursor over the correction valuein row 1.

g > W DN

Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the correction value entered.

o

Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Usethe down arrow key to place the cursor over the frequency value
for the next row. The RF output changes to the frequency value of the table row containing the cursor, as
shown in the AMPLI TUDE area of the display.

8. Repeat steps 2 through 7 for every entry in the User Flatness table.
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Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flathess correction dataasin the signal generator’s memory catal og.
With several user flatness correction files saved to the memory catalog, any file can be recalled, loaded into
the correction array, and applied to the RF output to satisfy specific RF output flatness requirements.

1. PressLoad/Store.

2. Press Store to File.

3. Enter thefile name FLATCAL1 using the al phanumeric softkeys, numeric keypad, or the knob.
4. PressEnter.

The user flatness correction array file FLATCAL1 is now stored in the memory catalog asa UFLT file.

Applying a User Flatness Correction Array
Press Return > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the
AVPLI TUDE section of the signal generator’s display and the frequency correction data contained in the
correction array is applied to the RF output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the stepsin this section, complete “ Creating a User Flatness Correction Array” on
page 137.

1. PressPreset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) >
Preset List > Confirm Preset.

Press More (2 of 2) > Load/Store.
4. Ensurethat the file FLATCAL1 is highlighted.
Press Load From Selected File > Confirm Load From File.

This popul ates the user flatness correction array with the data contained in the file FLATCAL1. The user
flatness correction array title displays User Fl at ness: FLATCAL1L.

6. PressReturn > Flatness Off On.

This applies the user flatness correction data contained in FLATCAL 1.
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Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is slaved to the signal generator via GPIB, and
no other controllers are allowed on the GPIB interface. The signal generator operatesin GPIB talker mode,
as adevice controller for the power meter. In this operating mode, it cannot receive SCPI commands via
GPIB.

If the signal generator isto beinterfaced to aremote controller after performing the user flatness correction,
its GPIB controller mode must be changed from GPIB talker to GPIB listener.

If an RF carrier has been previously configured, you must save the present instrument state before returning
the signal generator to GPIB listener mode.

1. Saveyour instrument state to the instrument state register.
For instructions, see “ Saving an Instrument State” on page 61.
2. PressGPIB Listener Mode.

This presets the signal generator and returnsit to GPIB listener mode. The signal generator can now
receive remote commands executed by a remote controller connected to the GPIB interface.

3. Recall your instrument state from the instrument state register.

For instructions, see “ Saving an Instrument State” on page 61.

Creating a User Flatness Correction Array with a mm-Wave Source Module

In this example, a user flatness correction array is created to provide flatness-corrected power at the output
of an Agilent 83554A millimeter-wave source module driven by an E8257D signal generator.

The flatness correction array contains 28 frequency correction pairs (amplitude correction values for
specified frequencies), from 26.5 to 40 GHz in 500 MHz intervals. Thiswill result in 28 evenly spaced
flatness corrected frequencies between 26.5 GHz and 40 GHz at the output of the 83554A millimeter-wave
source module.

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and R8486A
power sensor are used to measure the RF output amplitude of the millimeter-wave source module at the
specified correction frequencies and transfer the results to the signal generator. The signal generator reads
the power level datafrom the power meter, cal cul ates the correction val ues, and stores the correction pairsin
the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB interface,
you can enter correction values manually.
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Required Equipment

Agilent 83554A millimeter-wave source module

Adgilent E4416A/17A/18B/19B power meter

Agilent R8486A power sensor

Adgilent 8349B microwave amplifier (required for signal generators without Option 1EA)
GPIB interface cable

adapters and cables as required

NOTE The equipment setups in Figure 4-5 and Figure 4-6 assume that the steps necessary to

correctly level the RF output have been followed. If you have questions about leveling with
amillimeter-wave source module, refer to “ To Level with amm-Wave Source Module” on
page 136.

Configure the Power Meter

1. Select SCPI asthe remote language for the power meter.
2. Zero and calibrate the power sensor to the power meter.
3.
4

Enter the appropriate power sensor calibration factors into the power meter as appropriate.

Enable the power meter’s cal factor array.

NOTE For operating information on your particular power meter/sensor, refer to their operating

guides.
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Connect the Equipment

CAUTION To prevent damage to the signal generator, turn off the line power to the signal generator
before connecting the source module interface cable to the rear panel SOURCE MODULE
interface connector.

1. Turn off the line power to the signal generator.

2. Connect the equipment. For standard signal generators, use the setup in Figure 4-5. For Option 1EA
signal generators, use the setup in Figure 4-6.

NOTE During the process of creating the user flatness correction array, the power meter is slaved to
the signal generator via GPIB. No other controllers are allowed on the GPIB interface.

Figure 4-5 User Flatness with mm-Wave Source Module for a Signal Generator without Option 1EA
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Figure 4-6 User Flatness with mm-Wave Source Module and Option 1EA Signal Generator
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NOTE To ensure adequate RF amplitude at the mm-wave source module RF input when using

Option 1EA signal generators, maximum amplitude | oss through the adapters and cables
connected between the signal generator’s RF output and the mm-wave source module's RF
input should be lessthan 1.5 dB.

Configure the Signal Generator

1. Turnon thesignal generator’sline power. At power-up, the signal generator automatically does the
following:

* senses the mm-wave source module

« switchesthe signal generator’sleveling mode to external/source module

e setsthe mm-wave source module frequency and amplitude to the source modul€’s preset values
« displaysthe RF output frequency and amplitude available at the mm-wave source modul e output

The MMMCD indicator in the FREQUENCY area and the MMindicator in the AMPLI TUDE area of the signal
generator’s display indicate that the mm-wave source moduleis active

NOTE For specific frequency/amplitude ranges, see the mm-wave source modul e specifications.
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10.

Configure the signal generator to interface with the power meter.

a.  Press Amplitude > More (1 of 2) > User Flatness > More (1 of 2) > Power Meter > E4416A, E4417A, E4418B,
or E4419B.

b. Press Meter Address > enter the power meter’'s GPIB address > Enter.
c. For E4417A and E4419B models, press Meter Channel A B to select the power meter’s active channel.

d. Press Meter Timeout to adjust the length of time before the instrument generates atimeout error if
unsuccessfully attempting to communicate with the power meter.

Press More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset.

This opens the User Flatness table editor and resets the cal array frequency/correction list.
Press Configure Step Array.

This opens a menu for entering the user flatness step array data.

Press Freq Start > 26.5 > GHz.

Press Freq Stop > 40 > GHz.

Press # of Points > 28 > Enter.

This enters the desired flatness-corrected frequencies (26.5 GHz to 40 GHz in 500 MHz intervals) into
the step array.

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

This populates the user flatness correction array with the frequency settings defined in the step array.
Press Amplitude >0 > dBm.

Press RF On/Off.

This activates the RF output and the R= QN annunciator is displayed on the signal generator.

Perform the User Flatness Correction

NOTE If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter

does not have a GPIB interface, you can perform the user flatness correction manually. For
instructions, see “ Performing the User Flatness Correction Manually” below.

1

Press More (1 of 2) > User Flatness > Do Cal.

This creates the user flatness amplitude correction value table entries. The signal generator beginsthe
user flatness correction routine and a progress bar is shown on the display.
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2. When prompted, press Done.
This loads the amplitude correction values into the user flatness correction array.
If desired, press Configure Cal Array.

This opensthe user flatness correction array, where you can view thelist of defined frequencies and their
calculated amplitude correction values. The user flatness correction array title displays User
Fl at ness: (UNSTORED) indicating that the current user flatness correction array data has not been
saved to the memory catal og.

Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a
GPIB interface, complete the steps in this section and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value (26.5 GHz) for
row 1. The RF output changes to the frequency val ue of the table row containing the cursor and 26. 500
000 000 00 isdisplayedinthe AMPLI TUDE area of the display.

Observe and record the measured value from the power meter.
Subtract the measured value from 0 dBm.

Move the table cursor over the correction value in row 1.

o > W DN

Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the correction value entered.

o

Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Usethe down arrow key to place the cursor over the frequency value for the next row. The RF output
changes to the frequency value highlighted by the cursor, as shown in the AMPLI TUDE area of the
display.

8. Repeat steps 2 through 7 for each entry in the User Flatness table.
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Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as afile in the signal generator’s memory
catalog. With several user flatness correction files saved to the memory catalog, specific files can be
recalled, loaded into the correction array, and applied to the RF output to satisfy various RF output flatness
requirements.

1. PressLoad/Store.

2. Press Store to File.

3. Enter thefile name FLATCAL?2 using the al phanumeric softkeys and the numeric keypad.
4. PressEnter.

The user flatness correction array file FLATCALZ2 is now stored in the memory catalog asa UFLT file.

Applying the User Flatness Correction Array

1. PressReturn > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the
AMVPLI TUDE section of the signal generator’s display and the frequency correction data contained in the
correction array is applied to the RF output amplitude of the mm-wave source module.

Recalling and Applying a User Flatness Correction Array

Before performing the stepsin this section, complete the section “ Creating a User Flatness Correction Array
with amm-Wave Source Module” on page 142.

1. PressPreset.

2. Press Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) >
Preset List > Confirm Preset.

3. Press More (2 of 2) > Load/Store.
4. Ensurethat the file FLATCALZ is highlighted.
5. Press Load From Selected File > Confirm Load From File.

This popul ates the user flatness correction array with the data contained in the file FLATCAL2. The user
flatness correction array title displays User Fl at ness: FLATCAL2.

6. PressReturn > Flatness Off On.

This activates flatness correction using the data contained in the file FLATCAL2.
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Adjusting Reference Oscillator Bandwidth (Option UNR)

The reference oscillator bandwidth (sometimes referred to as loop bandwidth) in signal generators with
Option UNR (improved close-in phase noise < 1 kHz) is adjustable in fixed steps for either an internal or
external 10 MHz frequency reference. The reference oscillator bandwidth can be set to 25, 55, 125, 300, or
650 Hz; models without option UNR have afixed reference oscillator bandwidth of about 15 Hz.

At frequency offsets below approximately 1 kHz, the stability and phase noise are determined by the internal
or external frequency reference. At frequency offsets above 1 kHz, stability and phase noise are determined
by the synthesizer hardware.

To optimize the overall phase noise performance of the signal generator for your particular application,
make this adjustment depending on your confidence in the stability and phase noise of the external or
internal reference versus the synthesizer hardware for various frequency offsets from the carrier.

To Select the Reference Oscillator Bandwidth

When using the internal timebase reference;

1. Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > Internal Ref Bandwidth.
2. Select the desired bandwidth.

When using an external timebase reference:

1. Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > External Ref Bandwidth.

2. Select the desired bandwidth.

To Restore Factory Default Settings:

Internal Timebase: 125 Hz
External Timebase: 25 Hz

Press Utility > Instrument Adjustments > Reference Oscillator Adjustment > Restore Factory Defaults.
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5  Analog Modulation

In the following sections, this chapter describes the standard continuous waveform and optional analog
modulation capability in Agilent E8257D PSG Analog and E8267D PSG Vector signal generators.

“Analog Modulation Waveforms® on page 152

“Configuring AM (Option UNT)” on page 153

“Configuring FM (Option UNT)” on page 154

“Configuring ®M (Option UNT)” on page 155

“Configuring Pulse Modulation (Option UNU/UNW)” on page 156
“Configuring the LF Output (Option UNT)” on page 157
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Analog Modulation Waveforms

Available standard internal waveforms include:

Sine sine wave with adjustable amplitude and frequency

Dua-Sine dual-sine waves with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone (available from function generator only)

Swept-Sine swept-sine wave with adjustable start and stop frequencies, sweep rate, and sweep
trigger settings (available from function generator only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square sguare wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak-to-peak value (RMSvalueis

approximately 80% of the displayed value)

With Option UNT, the signal generator can modulate the RF carrier with amplitude, frequency, or phase
modulation. Option UNT also provides low-frequency output capability.

With Option UNU, the signal generator can modulate the RF carrier with standard pul se modulation (150 ns
minimum pulse width).

With Option UNW, the signal generator can modul ate the RF carrier with narrow pulse modulation (20 ns
minimum pulse width).
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Configuring AM (Option UNT)

In this example, you will learn how to generate an amplitude-modul ated RF carrier.

To Set the Carrier Frequency

1. PressPreset.

2. PressFrequency > 1340 > kHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the AM Depth and Rate

1. Pressthe AM hardkey.
2. Press AM Depth > 90 > %.
3. Press AM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, amplitude-modulated carrier at 1340 kHz with
the AM depth set to 90% and the AM rate set to 10 kHz. The shape of the waveform is a sine wave. Notice
that sine is the default selection for the AM Waveform softkey, which can be viewed by pressing (More 1 of 2).

To Turn on Amplitude Modulation
Follow these remaining steps to output the amplitude-modulated signal.
1. Pressthe AM Off On softkey to On.

2. Pressthe front panel RF On Off key.

The AMand RF ONannunciators are now displayed. Thisindicates that you have enabled amplitude
modulation and the signal is now being transmitted from the RF OUTPUT connector.
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Configuring FM (Option UNT)

In this example, you will learn how to create a frequency-modulated RF carrier.

To Set the RF Output Frequency

1. PressPreset.

2. PressFrequency > 1> GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the FM Deviation and Rate

1. Pressthe FM/®M hardkey.
2. PressFM Dev > 75 > kHz.
3. PressFM Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, frequency-modulated carrier at 1 GHz with a
75 kHz deviation and a 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sineisthe
default for the FM Waveform softkey. Press More (1 of 2) to see the softkey.)

To Activate FM

1. PressFM Off On to On.
2. PressRF On/Off.

The FMand RF ON annunciators are now displayed. This indicates that you have enabled frequency
modulation and the signal is now being transmitted from the RF OUTPUT connector.

DC Offset and External FM

Applying a DC offset to an external FM signal will shift the frequency of the FM signal above or below the
carrier frequency, depending on the polarity of the DC level. The amount frequency shift is directly related
to the amplitude of the DC level. A DC offset of +1.0 volt or greater will shift the external FM frequency by
an amount equal to the maximum deviation setting. For example, if the signal generator CW frequency is 1
GHz and the maximum deviation setting is set to 100 kHz, an external DC-coupled signal with a+1.0 volt
DC level used as the modulating source will center the FM signal at 1 GHz + 100 kHz. Keeping the same
setup and settings and changing the DC level to +0.5 volts will center the FM signal at 1 GHz + 50 kHz.
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Configuring ®M (Option UNT)

In this example, you will learn how to create a phase-modulated RF carrier.

To Set the RF Output Frequency

1. PressPreset.

2. PressFrequency > 3 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the ®M Deviation and Rate

1. Pressthe FM/®M hardkey.
2. Pressthe FM ©M softkey.
3. Press ®M Dev > .25 > pi rad.
4. Press ®M Rate > 10 > kHz.

The signal generator is now configured to output a 0 dBm, phase-modulated carrier at 3 GHz witha0.25 p
radian deviation and 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sine is the default
for the ®M Waveform softkey. Press More (1 of 2) to see the softkey.)

To Activate ®M

1. Press ®M Off On.
2. PressRF On/Off.

The ®Mand RF ONannunciators are now displayed. Thisindicates that you have enabled phase modulation
and the signal is now being transmitted from the RF OUTPUT connector.
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Configuring Pulse Modulation (Option UNU/UNW)

In this example, you will learn how to create a gated, pulse-modulated RF carrier with an external trigger.

To Set the RF Output Frequency

1. PressPreset.

2. PressFrequency > 2 > GHz.

To Set the RF Output Amplitude

Press Amplitude > 0 > dBm.

To Set the Pulse Period, Width, and Triggering

1. PressPulse > Pulse Period > 100 > usec.
2. PressPulse > Pulse Width > 24 > usec.

3. PressPulse > Pulse Source > Int Gated.
4

. Connect aTTL signal to the Trigger In connector on the rear panel of the signal generator. To configure
the trigger signal polarity, Press Utility > Instrument Adjustments > Signal Polarity Setup > Trigger In Polarity.

The signal generator is now configured to output a 0 dBm, pulse-modulated carrier at 2 GHz with a
100-microsecond pulse period and 24-microsecond pulse width. The pulse sourceis set to internal gated.
(Noticethat Internal Free Runisthe default for the Pulse Source softkey.)

To Activate Pulse Modulation

Follow these remaining steps to output the pulse-modulated signal.
1. PressPulse Off On to On.

2. PressRF On/Off.

The Pul se and RF ONannunciators are now displayed. Thisindicates that you have enabled pulse
modulation and the signal is now being transmitted from the RF OUTPUT connector. The TTL trigger
signal state will control pulse modulation output.
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Configuring the LF Output (Option UNT)

With Option UNT, the signal generator has alow frequency (LF) output (described on page 12). The LF
output’s source can be switched between Internal 1 Monitor, Internal 2 Monitor, Function Generator 1, or Function
Generator 2.

Using Internal 1 Monitor or Internal 2 Monitor as the LF output source, the LF output provides a replica of the
signal from the internal source that is being used to modulate the RF output. The specific modulation
parameters for this signal are configured through the AM, FM, or FM menus.

Using Function Generator 1 or Function Generator 2 as the LF output source, the function generator section of
the internal modulation source drives the LF output directly. Frequency and waveform are configured from
the LF output menu, not through the AM, FM, or FM menus. You can select the waveform shape from the
following choices:

Sine sine wave with adjustable amplitude and frequency

Dua-Sine dual-sine waves with individually adjustable frequencies and a percent-of-
peak-amplitude setting for the second tone (available from function generator 1 only)

Swept-Sine a swept-sine wave with adjustable start and stop frequencies, sweep rate, and sweep
trigger settings (available from function generator 1 only)

Triangle triangle wave with adjustable amplitude and frequency

Ramp ramp with adjustable amplitude and frequency

Square sguare wave with adjustable amplitude and frequency

Noise noise with adjustable amplitude generated as a peak-to-peak value (RMSvalueis
approximately 80% of the displayed value)

DC direct current with adjustable amplitude

NOTE The LF Out Off On softkey controls the operating state of the LF output. However, when the

LF output source selection is Internal Monitor, you have three ways of controlling the output.
You can use the modulation source (AM, FM, or FM) on/off key, the LF output on/off key,
or the Mod On/0ff softkey.

The RF On/0ff hardkey does not apply to the LF OUTPUT connector.
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To Configure the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source.

NOTE Internal modulation (Internal Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source

1. PressPreset.

2. Pressthe FM/®M hardkey.

3. PressFM Dev > 75 > kHz.

4. PressFM Rate > 10 > kHz.

5. PressFM Off On.

You have set up the FM signal with arate of 10 kHz and 75 kHz of deviation. The FMannunciator is
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output

1. PressthelLF Out hardkey.
2. PressLF Out Amplitude > 3 > Vp.
3. PressLF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is
frequency modulated using the Internal 1 Monitor source selection (default source).
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To Configure the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source

1. PressPreset.
2. PresstheLF Out hardkey.

3. PressLF Out Source > Function Generator 1.

Configuring the Waveform

1. PressLF Out Waveform > Swept-Sine.
2. PressLF Out Start Freq > 100 > Hz.

3. PressLF Out Stop Freq > 1 > kHz.

4. PressReturn > Return.

This returns you to the top LF Output menu.

Configuring the Low Frequency Output

1. PressLF Out Amplitude > 3 > Vp.
This sets the LF output amplitude to 3 Vp.
2. PressLF Out Off On.

The LF output is now transmitting a signal using Function Generator 1 that is providing a
3 Vp swept-sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.
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6 Custom Arb Waveform Generator

In the following sections, this chapter describes the custom arbitrary waveform generator mode, which is
available only in E8267D PSG vector signal generators with Option 601 or 602:

*  “Overview” on page 162

»  “Working with Predefined Setups (Modes)” on page 163
e “Working with Filters” on page 167

o “Working with Symbol Rates’ on page 175

e “Working with Modulation Types’ on page 178

e “Configuring Hardware” on page 186

See also: “Basic Digital Operation” on page 77
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Overview

Custom Arb Waveform Generator mode can produce a single modulated carrier or multiple modulated
carriers. Each modulated carrier waveform must be cal culated and generated before it can be output; this
signal generation occurs on the internal baseband generator (Option 601 or 602). Once awaveform has been
created, it can be stored and recalled which enables repeatable playback of test signals.

To begin using the Custom Arb Waveform Generator mode, select whether to create a single modulated
carrier or amultiple modulated carrier waveform:

» If you want to create a single modulated carrier waveform, start by selecting a Digital Modulation Setup
from a set of predefined modes (setups). Once a predefined mode is selected, you can modify the
Modulation Type, the Filter being used, the Symbol Rate, and the type of Triggering; the Data Pattern is
random by default. This modified setup can then be stored and reused.

» If you want to create a multiple modulated carrier waveform, start by selecting a Multicarrier Setup from
a set of predefined modes (setups). Once a predefined mode is selected, you can modify the number of
carriersto be created, the frequency spacing between each carrier, whether the phase offset between each
carrier isto be fixed or random, and the type of Triggering; the Data Pattern is random by default, the
Filter is set to 40 MHz by default, and the Symbol Rate is automatically specified by the selected
Modulation Type being used.
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Working with Predefined Setups (Modes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol
rate, and modulation type) are automatically specified.

Selecting a Custom ARB Setup or a Custom Digital Modulation State

1. Preset the signal generator: press Preset.
2. Press Mode > Custom > Arb Waveform Generator > Setup Select.

3. Sdlect either:

« one of the predefined modulation setups: NADC, PDC, PHS, GSM, DECT, EDGE, APCO 25 w/C4FM, APCO
25 w/CQPSK, CDPD, PWT, or TETRA

This selects a predefined setup where filtering, symbol rate, and modulation type are defined by the
predefined modul ation setup (mode) that you selected and returns you to the top-level custom
modul ation menu; it does not include bursting or channel coding.

or
e Custom Digital Mod State

This selects a custom setup stored in the Cat al og of DMID Fi | es (see page 164 for information
on creating a custom digital modul ation setup).
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Working with User-Defined Setups (Modes)—Custom Arb Only

Modifying a Single-Carrier NADC Setup

In this procedure, you learn how to start with a single-carrier NADC digital modulation and modify it to a
custom waveform with customized modulation type, symbol rate, and filtering.

1. PressPreset.
2. Press Mode > Custom > ARB Waveform Generator > Setup Select > NADC.
3. PressDigital Mod Define > Modulation Type > PSK > QPSK and OQPSK > QPSK.
4. Press Symbol Rate > 56 > ksps.
5. PressFilter > Select > Nyquist.
6. PressReturn > Return > Digital Modulation Off On.
This generates a waveform with the custom single-carrier NADC digital modulation state. The display
changesto Di g Mbd Set up: NADC (Modi fi ed) . During waveform generation, the DI GMCD and
I / Qannunciators appear and the custom single-carrier digital modulation state is stored in volatile
memory.
7. Set the RF output frequency to 835 MHz.
8. Set the output amplitude to 0 dBm.
9. PressRF On/Off.
The user-defined NADC signal is now available at the RF OUTPUT connector.
10. Press Return > Return.
This returns to the top-level Digital Modulation menu, where Digital Modulation Off On is the first softkey.
11. Press Digital Mod Define > Store Custom Dig Mod State > Store To File.
If thereis already afile name from the Cat al og of DMID Fi | es occupying the active entry
area, press: Edit Keys > Clear Text
12. Enter afile name (for example, NADCQPSK) using the alpha keys and the numeric keypad.
13. Press Enter.
The user-defined single-carrier digital modulation state should now be stored in non-volatile memory.
The RF output amplitude, frequency, and operating state settings are not stored as part of a user-defined
digital modulation state file.
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Customizing a Multicarrier Setup

In this procedure, you learn how to customize a predefined multicarrier digital modulation setup by creating
acustom 3-carrier EDGE digital modulation state.

1. PressPreset.

2. Press Mode > Custom > Arb Waveform Generator > Multicarrier Off On.

3. Press Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done.

4. Highlight the Freq O f set value (500. 000 kHz) for the carrier in row 2, and
press Edit Item > —625 > kHz.

5. Highlight the Power value (0. 00 dB) for the carrier in row 2, and press Edit Item > -10 > dB.
You have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of =625 kHz and a
power level of —10.00 dBm.

6. PressReturn > Digital Modulation Off On.
This generates a waveform with the custom multicarrier EDGE state. The display changesto D g Mbd
Setup: Milticarrier (Mdified).Duringwaveform generation, the Dl GMDand |/ Q
annunciators appear and the new custom multicarrier EDGE state is stored in volatile memory.

7. Set the RF output frequency to 890.01 MHz.

8. Set the output amplitude to —10 dBm.

9. PressRF On/0ff.
The custom multicarrier EDGE waveform is available at the RF OUTPUT connector; it does not include
bursting or channel coding.

10. Press Mode > Custom > Arb Waveform Generator, where Digital Modulation Off On is the first softkey.

11. Press Multicarrier Off On > Multicarrier Define > More (1 of 2) > Load/ Store > Store To File.
If thereis already afile name from the Cat al og of MDMID Fi | es occupying the active entry area,
press Edit Keys > Clear Text.

12. Enter afile name (for example, EDGEML) using the alpha keys and the numeric keypad, and press Enter.
The user-defined multicarrier digital modulation state is now stored in non-volatile memory.

NOTE The RF output amplitude, frequency, and operating state settings (such as RF On/Off) are

not stored as part of a user-defined digital modulation state file. For more information,
refer to “Using Data Storage Functions” on page 59.
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Recalling a User-Defined Custom Digital Modulation State

In this procedure, you learn how to select (recall) apreviously stored custom digital modulation state from
the Memory Catalog (the Cat al og of DMID Fi | es).

1. PressPreset.

2. Press Mode > Custom > ARB Waveform Generator > Setup Select.

3. Press More (1 of 2) > Custom Digital Mod State.

4. Press Select File to select a custom modulation state from the Cat al og of DMID Fi | es.

The user-defined custom digital modulation state should now be recalled from non-volatile memory.
Because the RF output amplitude, frequency, and operating state settings are not stored as part of a
user-defined digital modulation state file, they must still be set or recalled separately. For more
information, refer to “Using Data Storage Functions” on page 59.
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Working with Filters

This section provides information on using predefined (page 168) and user-defined (page 169) FIR filters.

NOTE The proceduresin this section apply only to filters created in either the Custom Arb
Waveform Generator or Custom Real Time 1/Q Baseband mode; they do not work with
downloaded files, such as those created in Matlab.

The Filter menu selections enable you to apply afilter to the generated signal, define afinite impulse
response (FIR) filter, change a Root Nyquist or Nyquist filter alpha, change a Gaussian filter BbT, or restore
all filter parametersto their default state. In Custom Real Time I/Q mode, you can also optimize aFIR filter
for Error Vector Magnitude (EVM) or Adjacent Channel Power (ACP)

Predefined Filters (Filter > Select)

* Root Nyquist isaroot-raised cosine pre-modulation FIR filter. Use a Root Nyquist filter when you want to
place half of the filtering in the transmitter and the other half in the receiver. Theideal root-raised cosine
filter frequency response has unity gain at low frequencies, the square root of raised cosine function in
the middle, and total attenuation at high frequencies. The width of the middle frequenciesis defined by
theroll off factor or Filter Alpha (0 < Filter Alpha< 1).

* Nyquist isaraised cosine pre-modulation FIR filter. You can use a Nyquist filter to reduce the bandwidth
required by a signal without losing information. The ideal raised cosine filter frequency response
comprises unity gain at low frequencies, a raised cosine function in the middle, and total attenuation at
high frequencies. The width of the middle frequenciesis defined by the roll off factor or Filter Alpha (0
< Filter Alpha< 1).

* Gaussian isa Gaussian pre-modulation FIR filter.

* User FIR enables you to select from a Catalog of FIR filters; use this selection if the other predefined FIR
filters do not meet your needs. For more information, see Define User FIR, below.

* Rectangle is arectangular pre-modulation FIR filter.
* APCO 25 C4FM isan APCO 25-specified CAFM filter; thisisaNyquist filter with an alphaof 0.200 that is
combined with a shaping filter.

Filter Parameters

» Define User FIR is available for when the predefined FIR filters do not meet your needs. You can define
FIR coefficients and set the oversample ratio (number of filter coefficients per symbol) to be applied to a
custom FIR filter.
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* Filter Alpha enables you to adjust the filter alpha for a Nyquist or root Nyquist filter. If a Gaussian filter is
used, you will see Filter BbT; this softkey is grayed out when any other filter is selected.

e (Custom Realtime 1/Q Baseband Only) Optimize FIR for EVM ACP enables you to optimize a Nyquist
or root Nyquist filter for minimized error vector magnitude (EVM) or for minimized adjacent channel
power (ACP); the softkey is grayed out when any other filter is selected.

» Restore Default Filters replaces the current FIR filter with the default FIR filter for the selected format.

Using a Predefined FIR Filter

Selecting a Predefined FIR Filter

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select
or
Mode > Custom > Real Time 1/Q Baseband > Filter > Select >
3. Select the desired filter. If the filter you want is not in the first list, press More (1 of 2).

Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist Filter

1. Preset the instrument: Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Filter Alpha
or
Mode > Custom > Real Time 1/Q Baseband > Filter > Filter Alpha

3. Enter anew Filter Alphavalue and pressEnter.

Adjusting the Bandwidth-Bit-Time (BbT) Product of a Predefined Gaussian Filter

1. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select > Gaussian
or

Mode > Custom > Real Time 1/Q Baseband > Filter > Select > Gaussian

Press Filter BbT.

3. Enter anew Bandwidth-Bit-Time (BbT) product filter parameter and press Enter.

N

Optimizing a Nyquist or Root Nyquist FIR Filter for EVM or ACP (Custom Realtime 1/Q Baseband only)

1. Preset the instrument: Press Preset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Filter > Optimize FIR For EVM or ACP.
The FIR filter is now optimized for minimum error vector magnitude (EV M) or for minimum adjacent
channel power (ACP). Thisfeature applies only to Nyquist and root Nyquist filters; the softkey is grayed
out when any other filter is selected.
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Restoring Default FIR Filter Parameters

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Restore Default Filter.

This replaces the current FIR filter with the default filter for the selected modulation format.

Using a User-Defined FIR Filter

FIR filters can be created and modified by defining the FIR coefficients or by defining the oversample ratio
(number of filter coefficients per symbol) to be applied to your own custom FIR filter.

To Modify Predefined FIR Coefficients for a Gaussian Filter Using the FIR Values Editor

You can define from 1 to 32 FIR coefficients, where the maximum combination of symbols and oversample
ratio is 1024 coefficients. While the FIR Values editor allows a maximum filter length of 1024 coefficients,
the PSG hardwareislimited to 64 symbolsfor real-time and 512 symbolsfor arbitrary waveform generation
(the number of symbols equals the number of coefficients divided by the oversample ratio).

If you enter more than 64 symbols for real-time or 512 symbols for arbitrary waveform generation, the PSG
cannot use the filter; it will decimate the filter (throw away coefficients) until the required condition is met
and then use the filter, but fine resolution may be lost from the impul se response.

FIR filters stored in signal generator memory can easily be modified using the FIR Values editor. In this
example, you will load the FIR Values editor with coefficient values from a default FIR filter (or, if one has
been defined, a user-defined FIR file that has been stored in the Memory Catal og), modify the coefficient
values, and store the new file to the Memory Catal og.

1. PressPreset.

2. Press Mode > Custom > Arb Waveform Generator > Digital Mod Define > Filter
or Mode > Custom > Real Time I/Q Baseband > Filter

Press Define User FIR > More (1 of 2) > Load Default FIR > Gaussian.
Press Filter BbT > 0.300 > Enter.

Press Filter Symbols > 8 > Enter.

o 0 &~ W

Press Generate.

NOTE The actual oversample ratio during modulation is automatically selected by the instrument.
A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per
symbol of the modulation type, and the number of symbols.

7. Press Display Impulse Response. A graph displays the impul se response of the current FIR coefficients.
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10.
11.

12.
13.
14.
15.
16.

Inpulse Response A
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e
-0.2
1] Coefficient 31
Press Return.
Highlight coefficient 15.

Press 0 > Enter.
Press Display Impulse Response.
Impulse Response )
Oversample Ratio: L
1.5
u
a
1
u
e
-0.5
1] Coefficient 31

The graphic display can provide a useful troubleshooting tool (in this case, it indicates that a coefficient

value is set incorrectly, resulting in an improper Gaussian response).

Press Return.

Highlight coefficient 15.

Press 1 > Enter.

Press Load/Store > Store To File.

Name the file NEWFIR2, and press Enter.

The contents of the current FIR Values editor are stored to afile in the Memory Catal og and the Catalog

of FIR Filesis updated to show the new file.
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To Create a User-Defined FIR Filter with the FIR Values Editor

In this procedure, you usethe FI R Val ues editor to create and store an 8-symbol, windowed, sinc function
filter with an oversampleratio of 4. The Oversample Ratio (OSR) is the number of filter coefficients per
symbol.

You can define from 1 to 32 FIR coefficients, where the maximum combination of symbols and oversample
ratio is 1024 coefficients.

The FIR Values editor allows a maximum filter length of 1024 coefficients, but the PSG hardwareis limited
to 512 symbols for arbitrary waveform generation, and 64 symbols for real-time waveform generation. The
number of symbols equalsthe number of coefficients divided by the oversampleratio. If you enter more than
the maximum number of symbols, the PSG cannot use thefilter; it decimates the filter (throws away
coefficients) until the required condition is met and then uses the filter, but fine resolution may be lost from
the impul se response.

1. PressPreset.

2. Press Mode > Custom > Arb Waveform Generator > Digital Mod Define > Filter
or
Mode > Custom > Real Time 1/Q Baseband > Filter

3. Press Define User FIR > More (1 of 2).
4. Press Delete All Rows > Confirm Delete Of All Rows > More (2 of 2).
This brings up the FIR Values editor and clears the table of existing values.

FREQUEMCY

44.000 000 000 000 Gtz

AMPLITUOE

130 00 dBm Edit Item
’7 ﬂ Insert. Row

| Delete Row
FIR Values Oversample Ratio: L

Coeff. Ualue
M 0 ] Goto Rouy

Mirrar Table

Ouversample Rat iE

— Mare
(1 of 22

5. Presskdit Item.The Val ue field for coefficient O should be highlighted.
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6. Usethe numeric keypad to type the first value (—0.000076) from the following table and press Enter. As
you press the numeric keys, the numbers are displayed in the active entry area. (If you make a mistake,
you can correct it using the backspace key.) Continue entering the coefficient values from the table until

all 16 values have been entered.

Coefficient Value Coefficient Value Coefficient Value
0 —0.000076 6 0.043940 12 0.123414
1 -0.001747 7 0.025852 13 0.442748
2 -0.005144 8 —-0.035667 14 0.767329
3 —0.004424 9 -0.116753 15 0.972149
4 0.007745 10 -0.157348
5 0.029610 1 —0.088484
7. Press Mirror Table.
In awindowed sinc function filter, the second half of the coefficients are identical to the first half, but in
reverse order. The signal generator provides a mirror table function that automatically duplicates the
existing coefficient values in the reverse order; coefficients 16 through 31 are automatically generated
and the first of these coefficients (number 16) highlights, as shown in the following figure.
FREQUENCY AMPLITUDE :
Edit. It
44.000 000 000 000 =z | -130.00 den oo
’7 @ Insert Rou
| Delete Row
FIR Values CUNSTOREDY Owersample Ratio: L
Coeff. Ualue
] 10 —0.1573L8 Goto RouM
11 —0. 028434
12 0. 123414
13 0.L427Lg Mirror Table
14 0.767329
15 0.972149
16 Oversample Ratio
17 0.767329 L
18 0.L4L27u8
| 19 0. 123414 Mare
(1 of 22
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8. For this example, the desired OSR is 4, which is the default, so no action is necessary.

The Oversample Ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the FIR
Values editor is 1024. Remember, however, that the instrument hardware is limited to 64 symbols for
real-time waveform generation, and 512 symbols for arbitrary waveform generation. The number of
symbols equals the number of coefficients divided by the oversample ratio.

9. Press More (1 of 2) > Display FFT (fast Fourier transform).

A graph displays the fast Fourier transform of the current set of FIR coefficients. The signal generator
has the capability of graphically displaying the filter in both time and frequency dimensions.

FFT

ma

-100

Symbol Rate

[

10. Press Return > Display Impulse Response.

A graph shows the impul se response of the current set of FIR coefficients.

Inpulse Response

Oversample Ratio: L

[Nl

0 Coefficient

11. PressReturn > Load/Store > Store To File.

The Catalog of FIR Files appears along with the amount of memory available.

12. If thereis aready afile name occupying the active entry area, press: Edit Keys > Clear Text

13. Using the alphabetic menu and the numeric keypad, enter NEWFI R1 as the file name.
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14. Press Enter.

The NEWFIRL1 fileisthefirst file name listed. (If you have previously stored other FIR files, additional
file names are listed below NEWFIR1.) Thefile typeis FIR and the size of the file is 260 bytes. The
amount of memory used is also displayed. The number of filesthat can be saved depends on the size of
the files and the amount of memory used.

AMPLITUDE Load From

—130 00 dBem Selected File
’7 ﬂ Store To
o File

| Delete File

FREQUEMCY

44.000 000 000 000 s+

Cataloo of FIR Files 260 butes used BLL321126L butes free
File Hame Tupe Size Hodified
] ; Goto RoxM
Page Up
Paoge Doun
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Working with Symbol Rates

The Symbol Rate menu enables you to set the rate at which 1/Q symbols are fed to the I/Q modulator. The
default transmission symbol rate can also be restored in this menu.

Symbol Rate (displayed as Sym Rat e) isthe number of symbols per second that are transmitted using
the modulation (displayed as Mod Type) along with the filter and filter alpha (displayed asFi | t er).
Symbol rate directly influences the occupied signal bandwidth.

Symbol Rateisthe Bit Rate divided by the number of bits that can be transmitted with each symbol; this
is also known as the Baud Rate.

Bit Rateis the frequency of the system bit stream. The internal baseband generator (Option 602)
automatically streams the selected Data Pattern at the appropriate rate to accommodate the symbol rate
setting (Bit Rate = Symbols/s x Number of Bits/Symboal).

Occupied Signal Bandwidth = Symbol Rate x (1 + Filter Alpha); therefore, the occupied signal
bandwidth is dependent on the filter alpha of the Nyquist or Root Nyquist filter being used. (To change
the filter alpha, refer to the procedure, “ Adjusting the Filter Alpha of a Predefined Root Nyquist or
Nyquist Filter” on page 168.)

To Set a Symbol Rate

Press Preset.

Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Symbol Rate
or
Mode > Custom > Real Time 1/Q Baseband > Symbol Rate

Enter a new symbol rate and press Msps, ksps, or sps.

To Restore the Default Symbol Rate (Custom Real Time 1/Q Only)

Press Mode > Custom > Real Time 1/Q Baseband > Symbol Rate > Restore Default Symbol Rate.

This replaces the current symbol rate with the default symbol rate for the selected modul ation format.
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9 Ja1dey)

Bits Custom Real Time Only
Modulation Type Per Bit Rate = Internal Symbol Rate External Symbol Rate
Symbol | Symbols/s x Number of Bits/Symbol | (Minimum Maximum) (Minimum Maximum)
PSK QPSK and OQPSK 2 90 bps — 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps
(quadrature phase shift keying and
Phase offset quadrature phase shift keying)
Shift Includes: QPSK, 1S95 QPSK,
Keying Gray Coded QPSK, OQPSK,
1S95 OQPSK
BPSK 1 45 bps — 50 Mbps 45 sps - 50 Msps 45 sps - 50 Msps
(binary phase shift keying)
4 DQPSK 2 90 bps — 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps
8PSK 3 135 bps — 150 Mbps 45 sps— 50 Msps 45 sps - 16.67 Msps
(eight phase state shift keying)
16PSK 4 180 sps — 200 Mbps 45 gps - 50 Msps 45 sps—12.5 Msps
(sixteen phase state shift keying)
D8PSK 3 135 bps — 150 Mbps 45 sps— 50 Msps 45 sps - 16.67 Msps
(eight phase state shift keying)
MSK MSK 1 45 bps — 50 Mbps 45 sps - 50 Msps 45 sps - 50 Msps
Minimum | (GSM - Global System for
Shift M obile Communications)
Keying
FSK 2-Lvl FSK 1 45 bps - 50 Mbps 45 sps — 50 Msps 45 sps— 50 Msps
Frequency 4-Lvl FSK 2 90 bps — 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps
Shift
Keying 8-Lvl FSK 3 135 bps - 150 Mbps 45 sps— 50 Msps 45 sps - 16.67 Msps
16-Lvl FSK 4 180 bps — 200 Mbps 45 sps— 50 Msps 45 sps—12.5 Msps
C4FM 2 90 bps — 100 Mbps 45 sps - 50 Msps 45 sps - 25 Msps
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Bits Custom Real Time Only
Modulation Type Per Bit Rate = Internal Symbol Rate External Symbol Rate
Symbol | Symbols/s x Number of Bits/Symbol | (Minimum Maximum) (Minimum Maximum)
QAM 4Q0AM 2 90 bps — 100 Mbps 45 sps— 50 Msps 45 sps — 25 Msps
Quadrature | 16QAM 4 180 bps — 200 Mbps 45 gps - 50 Msps 45 sps - 12.5 Msps
Amplitude b b
Modulation 32QAM 5 225 bps — 250 Mbps 45 sps— 50 Msps 45 sps— 10 Msps
64QAM 6 270 bps — 300 Mbps 45 sps - 50 Msps 45 sps - 8.33 Msps
128QAM 7 315 bps — 350 Mbps 45 sps - 50 Msps 45 sps— 7.14 Msps
Thereis no preset value for this
modulation, it must be user defined.
256QAM 8 360 bps — 400 Mbps 45 sps— 50 Msps 45 sps - 6.25 Msps
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Working with Modulation Types

The Modulation Type menu enables you to specify the type of modulation applied to the carrier signal when
the Mod On Off hardkey is on.

When the Custom Off On softkey is on:

» For Custom Arb, the BBG (baseband generator) creates a sampled version of the 1/Q waveform based
on arandom data pattern and the modulation type that has been selected.

» For Custom Real Time 1/Q, the real-time custom 1/Q symbol builder creates I/Q symbols based on the
data pattern and modulation type that has been selected (see “ Working with Data Patterns’ on page 191
for information on selecting a data pattern).

In Custom Real Time 1/Q, you can also:

e Create user-defined modulation type (see page 179) that can be used immediately or saved to the
Memory Catal og.

» Restore all modulation parameters to their default state.

To Select a Predefined Modulation Type

1. Press Preset.

2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Modulation Type > Select
or
Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Select

3. Select one of the available modulation types.

NOTE If you select QPSK and OQPSK, you must make a specific selection from the menu that displays.
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To Use a User-Defined Modulation Type (Real Time 1/Q Only)

Creating a 128QAM 1/Q Modulation Type User File with the 1/Q Values Editor

In 1/Q modulation schemes, symbols appear in default positions in the I/Q plane. Using thel / Q Val ues
editor, you can define your own symbol map by changing the position of one or more symbols. Use the
following procedure to create and store a 128-symbol QAM modulation.

NOTE Although this procedure provides a quick way to implement a 128QAM modulation format,
it does not take full advantage of the I/Q modulator’s dynamic range. Thisis because you
begin with a256QAM constellation, and del ete unwanted points. The remaining points that
make up the 128QAM constellation are closer together than if you had mapped each point
specifically. Additionally, this approach does not enable you to define the hit pattern
associated with each symbol point, as you could if the 128QAM constellation had been
defined one point at atime.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User 1/Q >
More (1 of 2) > Load Default I/Q Map > QAM > 256QAM.

This loads a default 256QAM 1/Q modulation into thel / Q Val ues editor.
3. Press More (2 of 2) > Display 1/Q Map.

I/Q State Map
I/0 States: 256
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In the next steps, you will delete specific portions of this I/Q constellation and changeit into a 128QAM
with 128 |/Q states.
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4, PressReturn > Goto Row > 0011 0000 > Enter; thisis row 48.

5. Pressthe Delete Row softkey 16 times.

Repeat this pattern of steps using the following table:

Goto Row... Press the Delete Row softkey...
0110 0000 (96) 16 times
1001 0000 (144) 16 times
1100 0000 (192) 16 times
0001 0000 (16) 4 times
0001 010Q20) 4 times
0001 100Q24) 8times
0011 000Q/48) 4times
0011 010Q52) 4times
0011 100Q56) 4times
0101 100(88) 8times
0111 000Q(112) 4times
0111 010Q(116) 4times
0111 100Q120) 8 times

6. Press Display 1/Q Map to view the new constellation that has been
created. The I/Q State Map in this example has 128 symboals.

7. PressReturn. When the contents of an |1 / Q Val ues table have not
been stored, 1 / Q Val ues ( UNSTCRED) appears on the display.

8. Press More (1 of 2) > Load/Store > Store To File.

If thereisalready afilenamefromtheCatal og of I1Q Files
occupying the active entry area, press the following keys:

Editing Keys > Clear Text

9. Enter afile name (for example, 128QAN) using the alpha keys and

the numeric keypad.

10. Press Enter.

+1 I

oo Q2

I/Q State Map

I/0 States: 128

++++++++
++++++++

L
e
e
B

++++++++

-1

I Value +1

The user-defined 1/Q State Map should now be stored inthe Cat al og of 1Q Fil es.
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Creating a QPSK 1/Q Modulation Type User File with the 1/Q Values Editor

In 1/Q modulation schemes, symbols appear in default positions in the 1/Q plane. Using thel / Q Val ues
editor, you can define your own symbol map by changing the position of one or more symbols. Use the
following procedure to create and store a 4-symbol unbalanced QPSK modulation.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User 1/Q > More (1 of 2) >
Delete All Rows > Confirm Delete All Rows.

This loads a default 4QAM 1/Q modulation and clearsthe | / Q Val ues editor.
3. Enter thel and Q valueslisted in the following table:

Symbol Data | Value Q Value

0 0000 0.500000 1.000000
1 0001 —0.500000 1.000000
2 0010 0.500000 -1.000000
3 0011 -0.500000 -1.000000

a Press0.5 > Enter.
b. Press1 > Enter.
c. Enter theremaining | and Q values.

Asthel value updates, the highlight movesto the first Q entry (and provides a default value of 0) and an
empty row of data appears below thefirst row. Asthe Q value updates, the highlight movesto the next |
value. Asyou press the numeric keys, the numbers display in the active entry area. If you make a
mistake, use the backspace key and retype.

Also note that 0. 000000 appears asthefirst entry inthelist of D sti nct Val ues, and that
0. 500000 and 1. 000000 are listed as the distinct values.

4. PressMore (2 of 2) > Display 1/Q Map.
An1/Q State Map is displayed from the current valuesinthe | / Q Val ues table.

The I/Q State Map in this example has four symbols. The 1/Q State Map uses the following four unique
values: 0.5, 1.0, 0.5, and —1.0 to create the four symbols. It is not the number of values that defines how
many symbols a map has, but how those values are combined.

5. PressReturn.

When the contents of an | / Q Val ues table have not been stored, | / Q Val ues ( UNSTORED) appears
on the display.
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6.

Press More (1 of 2) > Load/Store > Store To File.

If there is already afile name from the Cat al og of 1 Q Fi | es occupying the active entry area, press
the following keys: Editing Keys > Clear Text

Enter afile name (for example, NEWIQAM) using the al pha keys and the numeric keypad.

Press Enter. The user-defined 1/Q State Map should now be stored inthe Cat al og of 1Q Fil es and
can be recalled even after the signal generator has been turned off.

Modifying a Predefined 1/Q Modulation Type (1/Q Symbols) & Simulating Magnitude Errors & Phase Errors

Use the following procedure to manipulate symbol |ocations which simulate magnitude and phase errors. In
this example, you edit a4QAM constellation to move one symbol closer to the origin.

1
2.

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User I/Q > More (1 of 2) >
Load Default I/Q Map > QAM > 4QAM.

This loads a default 4QAM 1/Q modulation into thel / Q Val ues editor.

3. Press More (2 of 2).

Inthel / Q Val ues editor, navigateto Dat a 00000000 and press Edit Item.

5. Press.235702 > Enter, then .235702 > Enter.

When you press Enter the first time, the | value updates and the highlight movesto the first Q entry. The
second time, the Q value updates and the highlight moves to the following | entry.

6. PressDisplay 1/Q Map. Note that one symbol has moved, as shown.
FREQUEMCY AMPLITUCE
44.000 000 000 000 &= | -130.00 e
B
|
I/Q0 State Map
o I1/0 States: L
0 /
U +
a
1
u
e
-1 1t +
-1 I Value +1
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Creating an FSK Modulation Type User File with the Frequency Values Editor

Use this procedure to set the frequency deviation for data 00, 01, 10, and 11 to configure a user-defined
FSK modulation.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) >
Delete All Rows > Confirm Delete All Rows.

This accesses the Fr equency Val ues editor and clears the previous values.
Press 600 > Hz.
Press 1.8 > kHz.
Press -600 > Hz.

o 0 A~ w

Press -1.8 > kHz.

Each time you enter avalue, the Dat a column increments to the next binary number, up to atotal of 16
datavalues (from 0000 to 1111). An unstored file of frequency deviation valuesis created for the
custom 4-level FSK file.

7. PressLoad/Store > Store To File.

If thereisalready afilenamefromthe Cat al og of FSK Fi | es occupying the active entry area, press
the following keys:

Edit Keys > Clear Text
8. Enter afile name (for example, NEWFSK) using the al pha keys and the numeric keypad.
9. PressEnter.
The user-defined FSK modulation should now be stored inthe Cat al og of FSK Fi | es.
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Modifying a Predefined FSK Modulation Type User File with the Frequency Values Editor

Using the Fr equency Val ues editor, you can define, modify, and store user-defined frequency shift
keying modulation. The Fr equency Val ues editor isavailable for custom Real-Time 1/Q Baseband
mode, but is not available for waveforms generated in custom Arb Waveform Generator mode. Use this
exampleto learn how to add errorsto a default FSK modulation.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) >
Load Default FSK.

3. PressFreq Dev > 1.8 > kHz.
4. Press4-Lvl FSK.

This sets the frequency deviation and opensthe Fr equency Val ues editor with the 4-level FSK
default values displayed. The frequency value for data 0000 is highlighted.

Press -1.81 > kHz.
Press -590 > Hz.
Press 1.805 > kHz.

© N o U

Press 610 > Hz.

Asyou modify the frequency deviation values, the cursor movesto the next datarow. An unstored file of
frequency deviation valuesis created for your custom 4-level FSK file.

9. PressLoad/Store > Store To File.

If thereisalready afilenamefromthe Cat al og of FSK Fi | es occupying the active entry area, press
the following keys:

Edit Keys > Clear Text
10. Enter afile name (for example, NEWFSK) using the alpha keys and the numeric keypad.
11. PressEnter.
The user-defined FSK modulation should now be stored inthe Cat al og of FSK Fi | es.
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Wide Band 1Q (Option 015)

The signal generator with Option 015 can use an external 1/Q modulation source such as a two channel
arbitrary waveform generator to generate up to 2 GHz modulation bandwidth at RF. To enable the wideband
1/Q inputs:

1. Pressthe front panel 17Q hardkey.
2. Press|/Q Off.

3. Press1/Q Path Wide (Ext Rear Inputs).
4. Press|/QoOn.

Connect the external 1/Q modulation source to the signal generator’s Wideband | and Wideband Q rear-panel
inputs. The voltage level at theinputsis+/—1 Vdc. Wideband 1Q (Option 015) is available for RF above 3.2
GHz. Refer to the Option 015 data sheet for more information.

Itis possibleto usethe signal generator’sinternal arbitrary waveform generator (ARB) as a baseband source
while using the wideband inputs at RF. The internal ARB | and Q signals are available at the rear panel of
the PSG. Use the following steps to setup the internal ARB as a baseband source and enabl e the wideband
inputs.

Set up the internal baseband generator with the desired signal.
Press the Mux hardkey.

Press 1/Q Out.

Press BBG1

Pressthe front panel 17Q softkey.

Press 1/Q Off.

Press 1/7Q Path Wide (Ext Rear Inputs).

© N oo g > wDd PP

Press 1/Q On.
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Configuring Hardware
* “To Set the ARB Reference” see page 187

To Set a Delayed, Positive Polarity, External Single Trigger

Using this procedure, you learn how to utilize an external function generator to apply a delayed
single-trigger to a custom multicarrier waveform.

1. Connect an Agilent 33120A function generator or equivalent to the signal generator PATT TRIGGER IN
port, as shown in Figure 6-1.

PATTERN
i TRIG IN FUNCTION

Figure 6-1

= > GENERATOR
2 = éﬂﬁﬁ g
oo non
© lg:l Eﬁﬁ 00 l:n:u:u:n:u:u:lE®0
o == |oonnonn O Doooooong

SIGNAL GENERATOR

pk719b

On the signal generator, press Preset.

Press Mode > Custom > Arb Waveform Generator.
Press Multicarrier Off On until On is highlighted.
Press Trigger > Single.

Press Trigger > Trigger Setup >Trigger Source > Ext.
Press Ext Polarity Neg Pos until Posis highlighted.
Press Ext Delay Off On until On is highlighted.

© © N o 0o &~ W DN

Press Ext Delay Time > 100 > msec.

The Custom Arb Waveform Generator has been configured to play a single multicarrier waveform
100 milliseconds after it detects achangein TTL state from low to high at the PATT TRIG IN rear panel
connector.

10. Set the function generator waveform to a 0.1 Hz square wave at an output level of 0 to 5V.
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11. Onthe signal generator, press Mode > Custom > Arb Waveform Generator > Digital Modulation Off On until
Onishighlighted.

This generates a waveform with the custom multicarrier state and the display changesto D g Mod
Setup: Milticarrier.

During waveform generation, the Dl GMOD and | / Qannunciators activate and the new custom
multicarrier state is stored in volatile ARB memory. The waveform should be modulating the RF carrier.

12. Press RF On/Off.

The externally single-triggered custom multicarrier waveform should be avail able at the signal
generator’'s RF OUTPUT connector 100 ms after receiving achangein TTL state from low to high at the
PATT TRIG IN.

To Set the ARB Reference

Setting for an External or Internal Reference
1. PressCustom > Arb Waveform Generator > More (1 of 2).
2. Press ARB Reference Ext Int to select either external or internal as the waveform sample clock reference.

< |If you select Ext, you must enter the reference frequency (250 kHz to 100 MHz) and apply the
reference signal to the rear-panel BASEBAND GEN REF IN.

e |If you select Int, the internal clock isused for the arbitrary waveform (ARB) frequency reference.

Setting the External Frequency

The external Arb reference frequency is only used when the ARB Reference Ext Int softkey has been set to Ext
(external).

1. PressCustom > Arb Waveform Generator > More (1 of 2).

2. PressReference Freq, enter adesired frequency (250 kHz to 100 MHz), and press MHz, kHz, or Hz.
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[/ Custom Real Time 1/Q Baseband

In the following sections, this chapter describes the custom real-time 1/Q baseband mode, which is available
only in E8267D PSG vector signal generators with Option 601 or 602:

e “Overview” on page 190

»  “Working with Predefined Setups (Modes)” on page 190
e “Working with Data Patterns’ on page 191

e “Working with Burst Shapes’ on page 197

e “Configuring Hardware” on page 202

e “Working with Phase Polarity” on page 204

e “Working with Differential Data Encoding” on page 205

See also: “Basic Digital Operation” on page 77
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Overview

Custom Real Time 1/Q Baseband mode can produce a single carrier, but it can be modulated with real time
datathat allowsreal time control over all of the parameters that affect the signal. The single carrier signal
that is produced can be modified by applying various data patterns, filters, symbol rates, modulation types,
and burst shapes.

To begin using the Custom Real Time I/Q Baseband mode, start by selecting from a set of predefined modes
(setups) or specify a setup by selecting a Data Pattern, Filter, Symbol Rate, Modulation Type, Burst Shape,
Configure Hardware, Phase Polarity, and whether Diff Data Encode is off or on.

Working with Predefined Setups (Modes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol
rate, and modulation type) are automatically specified.

Selecting a Predefined Real Time Modulation Setup

The following steps select a predefined mode where filtering, symbol rate, and modulation type are defined
by the APCO 25 w/C4FM digital modulation standard, and return to the top-level custom modulation menu.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband.

3. Press More (1 of 3) > More (2 of 3) > Predefined Mode > APCO 25 w/C4FM.
4. Press More (3 of 3).

Deselecting a Predefined Real Time Modulation Setup

To deselect any predefined mode that has been previously selected, and return to the top-level custom
modulation menu:

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband.

3. Press More (1 of 3) > More (2 of 3) > Predefined Mode > None.
4. Press More (3 of 3).

190 Chapter 7



Custom Real Time 1/Q Baseband
Working with Data Patterns

Working with Data Patterns

This section provides information on the following:

» “Using aPredefined Data Pattern” on page 192
» “Using aUser-Defined Data Pattern” on page 193
e “Using an Externally Supplied Data Pattern” on page 196

The Data menu enables you to select from predefined and user defined data patterns. Data Patterns are used
for transmitting continuous streams of unframed data. When the Custom Off On softkey is on, the real-time
custom 1/Q symbol builder creates 1/Q symbols based on the data pattern and modulation type that has been
selected. Refer to “Working with Modulation Types’ on page 178 for information on selecting amodulation

type.
The following data patterns are available:

» PN sequence alows you to access amenu (PN9, PN11, PN15, PN20, PN23) for internal data generation
of pseudorandom sequences (pseudorandom noise sequences); a pseudorandom noise sequenceis a
periodic binary sequence approximating, in some sense, a Bernoulli “coin tossing” process with
equiprobable outcomes.

» FIX4 0000 allows you to define a 4-bit repeating sequence data pattern and make it the active function.
The selected 4-bit pattern will be repeated as necessary to provide a continuous stream of data.

e Other Patterns allows you to access a menu of choices (4 1's& 40's,81's& 80's,16 1's& 16 0's, 32
1's& 320's,or 64 1's& 64 0's) from which you can select a data pattern. Each pattern contains an equal
number of ones and zeroes. The selected pattern will be repeated as necessary to provide a continuous
stream of data

e User File allows you to access a menu of choices from which you can create afile and storeit to the
Catalog of Bit Files, select from a Catalog of Bit Files and useiit, or select from a Catalog of Bit Files,
edit the file, and resave the file.

» Ext dlows data patterns to be fed into the I/Q symbol builder, through the DATA port, in real-time.
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Using a Predefined Data Pattern

Selecting a Predefined PN Sequence Data Pattern

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Data > PN Sequence.

3. Pressone of thefollowing: PN9, PN11, PN15, PN20, PN23.

Selecting a Predefined Fixed 4-bit Data Pattern

1. PressPreset.
2. Press Mode > Custom > Real Time 1/Q Baseband > Data > FIX4.

3. Press 1010 > Enter > Return.

Selecting a Predefined Data Pattern Containing an Equal Number of 1s & Os

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Data > Other Patterns.

3. Pressone of thefollowing:

41s&40s,81's&80’s,161's&160’s,321’s & 320’s, Or 64 1's & 64 0’s.
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Using a User-Defined Data Pattern

User Files (user-defined data pattern files) can be created and modified using the signal generator’s Bi t

Fi |l e Editor orthey can be created on aremote computer and moved to the signal generator for direct
use; these remotely created data pattern files can also be modified with the Bit File Editor. For information
on creating user-defined data files on aremote computer, see the programming guide.

These procedures demonstrate how to usetheBit Fi | e Edi t or to create, edit, and store user-defined
data pattern files for use within the custom real-time I/Q baseband generator modulation. For thisexample, a
user file is defined within a custom digital communication.

Creating a Data Pattern User File with the Bit File Editor

This procedure uses the Bit File Editor to create a Data Pattern User File and stores the resulting filein the
Memory Catalog (described on page 59).

1. PressPreset.
2. Press Mode > Custom > Real Time 1/Q Baseband > Data > User File > Create File.

This opens the Bit File Editor, which contains three columns, as shown in the following figure.

Offset Cursor Position
(in Hex) B|t Data indicator (in Hex)  Hexadecimal Data File Name indicator
FHEDU NCY AMPLITUDE |
4.00 000 000 000 & { -130.00 den
{___ HRD Inserty
| / / Deletey
Bit F11~ Editoy Fos:0 Size:0 ‘ UMTITLED
Of fset Binary Data Hex Data
0 i GotoM
APply Bit Errorsy
Mare
(1 of 2)
NOTE When you create a new file, the default name is UNTI TLED, or UNTI TLEDL, and so forth.

This prevents overwriting previous files.
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3.

Using the numeric keypad (not the softkeys), enter the 32 bit val ues shown.

Bit datais entered into the Bit File Editor in 1-bit format. The current hexadecimal value of the binary
datais shownin the Hex Dat a column and the cursor position (in hexadecimal) is shown in the
Posi ti on indicator.

Enter These Bit Values Hexadecimal Data

Cursor Position

wh.ﬂoo 000/600 000 &= | ~13000 en
| { ’7@ InsertM

DeleteM

Bit File Editor Pos:E0 Size:gk UNTITLED
Offset Binary Data Hex Data
0 0110 1101 1011 0110 1110 1101 1011 0110 EDBEECES Got.ok

20 1101 1011 0110 1101 1011 0110 1101 1011 DBEDEECE
Lo 0111 0110 1101 0100 0110 1101 1011 0110 TEOLEOEE
60 [ | Apply Bit Errorsk

More
(1 of 23

Press More (1 of 2) > Rename > Editing Keys > Clear Text.
Enter afile name (for example, USER1) using the alpha keys and the numeric keypad.
Press Enter.

The user file should be renamed and stored to the Memory Catalog with the name USERL.

Selecting a Data Pattern User File from the Catalog of Bit Files

In this procedure, you learn how to select a data pattern user file from the Catalog of Bit Files. If you have
not created and stored a user-defined data file, compl ete the steps in the previous section, “ Creating a Data
Pattern User File with the Bit File Editor” on page 193.

1
2
3.
4

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Data > User File.

Highlight the file to be selected (for example, USERL) .

Press Edit File.

TheBit File Editor should open the selected file (for example, USERL) .
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Modifying an Existing Data Pattern User File

In this example, you learn how to modify an existing data pattern user file by navigating to a particular bit
position and changing its value. Next, you will learn how to invert the bit values of an existing data pattern
user file.

If you have not already created, stored, and recalled a data pattern user file, complete the stepsin the
previous sections, “ Creating a Data Pattern User File with the Bit File Editor” on page 193 and “ Selecting a
Data Pattern User File from the Catalog of Bit Files” on page 194.

Navigating the Bit Values of an Existing Data Pattern User File

1. PressGoto >4 > C > Enter.

This moves the cursor to bit position 4C, of the table, as shown in the following figure.

Cursor moves to new position Position indicator changes
FHEDUEN
00 000 000 000 s+ ~130.00 aen
DRD Inserty
Deleten
Bit File Editor PDS Size:Sk USERL
Offset Binary Data Hex Data
1] 0110 1101 1041 0110 1110 1101 1011 0110 GOBGECEG Goton
20 1101 1011 01181101 1011 0110 1101 1011 DEEDBEOE
Lo 0111 0110 1101 W100 0110 1101 1011 0110 7EOuEOBE
60 APPlu Bit Errorsk
More
(1 of 2)
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Inverting the Bit Values of an Existing Data Pattern User File

1. Onthe keypad, press 1011.

Thisinverts the bit values that are positioned 4C through 4F. Notice that hex datain this row has now
changed to 76DB6DBS6, as shown in the following figure.

Bits 4C through 4F inverted Hex Data changed
L
FREQUSCY AMPLITUDE
‘ .000 000 000 000 &z | -130.00/ den
’7 @ Inserty
| / Deletew
Bit File Editor Posx%Oo Size:Se8 LSER1
Offset \\5\\ Binary Data Hen/nata
0 0110 1101 181 0110 1110 1101 1011 0110 GOBSEDBS Got.o

20 1101 1011 01D 1101 1011 0110 1101 1011 DEPOBEOE
Lo 0111 0110 1101 1011 110 1101 1011 0110 7EDBE0OEG
60 APply Bit Errorsk

More
(1 of 23

To Apply Bit Errors to an Existing Data Pattern User File

This example demonstrates how to apply bit errors to an existing data pattern user file. If you have not
created and stored a data pattern user file, first complete the steps in the previous section, “ Creating a Data
Pattern User File with the Bit File Editor” on page 193.

1. Press Apply Bit Errors.
2. PressBit Errors > 5 > Enter.
3. Press Apply Bit Errors.
Notice both Bit Errors softkeys change value as they are linked.

Using an Externally Supplied Data Pattern

In this procedure, an external real time data pattern is supplied through DATA, DATA CLOCK, and
SYMBOL SYNC connectors.

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Data > Ext.
Connect the real-time data to the DATA input.

Connect the data clock trigger signal to DATA CLOCK inpuit.
Connect the symbol sync trigger to the SYMBOL SYNC input.

agrwDNE
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Working with Burst Shapes

e “Configuring the Burst Rise and Fall Parameters’ on page 198
» “Using User-Defined Burst Shape Curves’ on page 199

The Burst Shape menu enables you to modify the rise and fall time, rise and fall delay, and the burst shape
(either sine or user file defined). In addition, you can define the shape of the burst and preview the burst
shape through a Rise Shape Editor, or restore all of the burst shape parameters back to their original default
State.

Rise time the period of time, specified in bits, where the burst increases from a minimum of
—70 dB (0) to full power (1).

Fall time the period of time, specified in bits, where the burst decreases from full power (1) to a
minimum of =70 dB (0).

Rise delay the period of time, specified in bits, that the start of the burst riseis delayed. Rise delay

can be either negative or positive. Entering a delay other than zero shifts the full power
point earlier or later than the beginning of the first useful symbol.

Fall delay the period of time, specified in bits, that the start of the burst fall is delayed. Fall delay
can be either negative or positive. Entering a delay other than zero shifts the full power
point earlier or later than the end of the last useful symbol.

User-defined

burst shape up to 256 user-entered values, which define the shape of the curve in the specified rise
or fall time. The values can vary between 0 (no power) and 1 (full power) and are scaled
linearly. Once specified, the values are resampled as hecessary to create the cubic spline
that passes through all of the sample points.

The default burst shape of each format isimplemented according to the standards of the format selected. You
can, however, modify the following aspects of the burst shape:

User-Defined )
Vglirese e \L};ﬁrﬁ;?efmed
1]
g Rise Rise Fall Fall
- Delay Time Delay Time
o
0 ® ] °
Time —»
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Burst shape maximum rise and fall time values are affected by the following factors:

» thesymbol rate
» the modulation type

When the rise and fall delays equal 0O, the burst shape attempts to synchronize the maximum burst shape
power to the beginning of the first valid symbol and the ending of the last valid symbal.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when you turn
bursting on, you can adjust the burst shape to assist with troubleshooting.

Configuring the Burst Rise and Fall Parameters

Press Preset.

Press Mode > Custom > Real Time 1/Q Baseband > Burst Shape.
Press Rise Time > 5 > hits.

PressRise Delay > 1 > bhits.

Press Fall Time > 5 > bits.

o o A W DN P

Press Fall Delay > 1 > bits.

This configures the burst shape for the custom real-time 1/Q baseband digital modulation format. For
instructions on creating and applying user-defined burst shape curves, see “To Create and Store
User-Defined Burst Shape Curves’ on page 199.
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Using User-Defined Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curve using the R se Shape and Fal |
Shape editors. Each editor enables you to enter up to 256 values, equidistant in time, to define the shape of
the curve. The values are then resampled to create the cubic spline that passes through al of the sample
points.

The R se Shape and Fal | Shape editors are available for custom real-time 1/Q baseband generator
waveforms. They are not available for waveforms generated by the dual arbitrary waveform generator.

You can also design burst shape files externally and download the data to the signal generator. For more
information, see the programming guide.
To Create and Store User-Defined Burst Shape Curves

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall shape values
to create a symmetrical burst curve.

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Burst Shape.

3. Press Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of All Rows.
4

Enter values similar to the sample valuesin the following table:

Rise Shape Editor
Sample Value Sample Value
0 0.000000 5 0.900000
1 0.400000 6 0.950000
2 0.600000 7 0.980000
3 0.750000 8 0.990000
4 0.830000 9 1.000000
a. Highlight the value (1. 000000) for sample 1.
b. Press.4 > Enter.
C. Press.6 > Enter.

d. Enter the remaining values for samples 3 through 9 from the table above.

e. Press More (2 of 2) > Edit Fall Shape > Load Mirror Image of Rise Shape >
Confirm Load Mirror Image of Rise Shape.

This changes the fall shape valuesto a mirror image of the rise shape values.
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Figure 7-1
FREQUEMCY AMPLITUDE Edit Ttem
44.000 000 000 000 &+ | -130.00 den
HRD Insert Rou
| Delete Row
Rise Shape Editor (UNSTORED) Fall Shape Editor (UNSTORED)
Sample Ualue Sample Ualue
0 0.000000 0 Goto FRouWM
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5. Press More (1 of 2) > Display Burst Shape.

This displays agraphical representation of the waveform’srise and fall characteristics.

Figure 7-2
FREQUEMCY AMPLITUCE
44.000 000 000 000 &z | -130.00 den
B
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|
] Burst Shape
1 Burst Rise Shape Burst Fall Shape
U
a
1
u
e
1]
Time
NOTE To return the burst shape to the default conditions, press Return > Return >

Confirm Exit From Table Without Saving > Restore Default Burst Shape.

6. PressReturn > Load/Store > Store To File.

If thereis already afile name fromthe Cat al og of SHAPE Fi | es occupying the active entry

area, press the following keys: Editing Keys > Clear Text
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Enter afile name (for example, NEWBURST) using the alpha keys and the numeric keypad.
Press Enter.

The contents of the current R se Shape and Fal | Shape editors are stored to the Cat al og of
SHAPE Fi | es. This burst shape can now be used to customize a modulation or as abasis for anew
burst shape design.

To Select and Recall a User-Defined Burst Shape Curve from the Memory Catalog

Once a user-defined burst shape fileis stored in the Memory Catalog, it can be recalled for use with
real-time 1/Q baseband generated digital modulation.

This example requires a user-defined burst shape file stored in memory. If you have not created and stored a
user-defined burst shape file, complete the steps in the previous sections.

1

Press Preset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Burst Shape > Burst Shape Type > User File.
3.
4

. Press Select File.

Highlight the desired burst shape file (for example, NEVBURST).

The selected burst shape file is now applied to the current real-time 1/Q baseband digital modulation
state.

Press Return > Custom Off On.

This generates the custom modulation with user-defined burst shape created in the previous steps.
During waveform generation, the CUSTOMand | / Qannunciators activate. The waveform is now
modulating the RF carrier.

Press RF On/Off.

The current real-time 1/Q baseband digital modulation format with user-defined burst shape should be
available at the signal generator’s RF OUTPUT connector.
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Configuring Hardware

» “To Set the BBG Reference” on page 202

e “To Set the External DATA CLOCK to Receive Input as Either Normal or Symbol” on page 203
* “To Set the BBG DATA CLOCK to External or Internal” on page 203

* “ToAdjust thel/Q Scaling” on page 203

To Set the BBG Reference

Setting for an External or Internal Reference

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware displays a menu where you can set the BBG Reference to External or Internal.

2. PressBBG Ref Ext Int to select either external or internal as the bit-clock reference for the data generator.
If external is selected, apply the reference frequency to the rear-panel BASEBAND GEN REF IN
connector.

Setting the External Frequency

The BBG reference external frequency is used only when the BBG Ref Ext Int softkey has been set to Ext
(external).

1. Press Mode > Custom > Real Time 1/Q Baseband > More (1 of 3) > Configure Hardware.
Configure Hardware displays a menu where you can set the external BBG reference frequency.
2. PressExt BBG Ref Freq.

3. Usethe numeric keypad to a desired frequency, then press MHz, kHz, or Hz.
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To Set the External DATA CLOCK to Receive Input as Either Normal or Symbol

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware allows you to access amenu from which you can set the external DATA CLOCK to
receive input as either Normal or Symbol.

2. PressExt Data Clock to select either Normal or Symbol; this setting has no effect in internal clock mode.
¢ When set to Normal, the DATA CLOCK input connector requires a bit clock.
¢ When set to Symbol, aone-shot or continuous symbol sync signal must be provided to the SY MBOL
SYNC input connector.

To Set the BBG DATA CLOCK to External or Internal

1. PressMode > Custom > Real Time 1/Q Baseband > More (1 of 3) > Configure Hardware.

Configure Hardware allows you to access a menu from which you can set the BBG DATA CLOCK to
receive input from External or Internal.

2. PressBBG Data Clock Ext Int to select either external or internal.
*  When set to Ext (external), the DATA CLOCK connector is used to supply the BBG Data Clock.
e When setto Int (internal), the internal data clock is used.

To Adjust the 1/Q Scaling

Adjusting the I/Q Scaling (amplitude of the 1/Q outputs) multipliesthe | and Q data by the 1/Q scaling factor
that is selected and can be used to improve the Adjacent Channel Power (ACP). Lower scaling values equate
to better ACP. This setting has no effect with MSK or FSK modulation.

1. Press Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.
Configure Hardware allows you to access a menu from which you can adjust the I/Q Scaling.

2. Press1/Q Scaling, enter adesired I/Q scaling level, and press %.
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Working with Phase Polarity

To Set Phase Polarity to Normal or Inverted

1. Press Mode > Custom > Real Time 1/Q Baseband > More (1 of 3) > Phase Polarity Normal Invert.

Phase Polarity Normal Invert enables you to either leave the selection as Normal (so that the phase
relationship between the | and Q signalsis not altered by the phase polarity function), or set to Invert and
invert the internal Q signal, reversing the rotation direction of the phase modulation vector.

When you choose Invert, the in-phase component lags the quadrature-phase component by 90° in the
resulting modulation. Inverted phase polarity is required by some radio standards and it is useful for
lower sideband mixing applications. The inverted selection also appliesto thel, I-bar, Q, and Q-bar
output signals.
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Working with Differential Data Encoding

The Diff Data Encode Off On menu enables you to toggle the operational state of the signal generator’s
differential data encoding.

*  When set to Off, data bits are not encoded prior to modulation.

*  When set to On, data bits are encoded prior to modulation. Differential encoding uses an exclusive-OR
function to generate a modulated bit. Modulated bits will have avalue of 1 if adatabit is different from
the previous bit or they will have avalue of 0 if adata bit is the same as the previous hit.

This section provides information about the following:

» “Understanding Differential Encoding”
» “Using Differential Encoding” on page 210

Understanding Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal change
rather than a particular signal state. Using differential encoding, binary datain any user-defined 1/Q or FSK
modul ation can be encoded during the modulation process via symbol table offsets defined in the
Differential State Map.

For example, consider the signal generator’s default 4QAM 1/Q modulation. With a user-defined modulation
based on the default 4QAM template, thel / Q Val ues editor contains data that represent four symbols (00,
01, 10, and 11) mapped into the I/Q plane using two distinct values, 1.000000 and -1.000000. These four
symbols can be differentially encoded during the modulation process by assigning symbol table offset values
associated with each data value. Figure 7-3 on page 206 shows the 4QAM modulationinthel / Q Val ues
editor.
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Figure 7-3
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NOTE The number of bits per symbol can be expressed using the following formula. Because the

equation is a ceiling function, if the value of x contains a fraction, x is rounded up to the
next whole number.

x= Logzgr)

Where x = bits per symbol, and y = the number of differential states.

The following illustration shows a4QAM modulation 1/Q State Map.

2nd Symbol
Data = 00000001

Distinct values: -1, +1

3rd Symbol
Data = 00000010

Distinct values: -1, -1

I/Q State Map
s S I/0 States: L |
+176 o
]
u
a
1
u
e
~—
e o
-1 I Ualue +1

1st Symbol
Data = 00000000
Distinct values: +1, +1

4th Symbol
Data = 00000011
Distinct values: +1, -1
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Differential Data Encoding

In real-time 1/Q baseband digital modulation waveforms, data (1's and 0's) are encoded, modulated onto a
carrier frequency and subsequently transmitted to areceiver. In contrast to differential encoding, differential
data encoding modifies the data stream prior to 1/Q mapping. Where differential encoding encodes the raw
data by using symbol table offset values to manipulate 1/Q mapping at the point of modulation, differential
data encoding uses the transition from one bit value to another to encode the raw data.

Differential data encoding modifies the raw digitized data by creating a secondary, encoded data stream that
is defined by changesin the digital state, from 1 to O or from 0 to 1, of the raw data stream. This
differentially encoded data stream is then modulated and transmitted.

In differential data encoding, achangein araw databit's digital state, from 1to O or from 0 to 1, produces a
1in the encoded data stream. No change in digital state from one bit to the next, in other words a bit with a
value of 1 followed by another bit with avalue of 1 or abit with avalue of O followed by the same, produces
a0in the encoded data. For instance, differentially encoding the data stream containing 01010011001010
renders 1111010101111.

Differential data encoding can be described by the following equation:
transmittedbit(i)= databit(i —1) O databit(i)
For abit-by-hit illustration of the encoding process, see the following illustration:

0101001100101

raw (unencoded) data I I I I \ I I I I

\ . \

change= -———~ .‘
nochange= —=-------- - ‘

\ \ \
1111010101111

differentially encoded data ...l I I I I I

How Differential Encoding Works

Differential encoding employs offsets in the symbol table to encode user-defined modulation schemes. The
Dfferential State Mp editorisused tointroduce symbol table offset values, which in turn cause
transitions through the 1/Q State Map based on their associated data value. Whenever adatavalueis

modul ated, the offset value stored in the Differential State Map is used to encode the data by transitioning
through the I/Q State Map in a direction and distance defined by the symbol table offset value.
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Entering avalue of +1 causes a 1-state forward transition through the 1/Q State Map. As an example,
consider the following data/symbol table offset values. These symbol table offsets result in one of the
transitions shown.

NOTE The following I/Q State Map illustrations show all possible state transitions using a
particular symbol table offset value. The actua state-to-state transition depends on the state
in which the modulation starts.

Example 1 Example 2
Example Data Offset transition 1 state forward transition 1 state backward
Value
I,fu State Map Ix’u State Map
1 00000000 | +1 1/0 States: L 1/0 States: L
+1 1 +1 1
2 00000001 -1
0 0
3 00000010 +2 v U
4 00000011 | O 7 g
u u
e e
-1 'l.: :__ 1 I‘/\.‘“
=1 I Ualue +1 =1 I Ualue +1
Example 3 Example 4
transition 2 states forward no transition
Ifu State Map I/0 State Nhap
I/0 States: 4 I/0 States: 4
+1 | L +1
0 ! D O
U U
a a
1 1
u u
**' o Q)
-1 14 L) -1
-1 I Ualue +1 -1 I Ualue +1
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I/0 State Map .

J 1st Symbol 5th Symbol
+1 Y 3rd Symbol Y
u Data = 0011100001
U 2nd Symbol 4th Symbol
a 4th
]_ Data Value Symbol Table Offset
u 00 +1
01 -1
e 10 +2
11 +0
-1 19 L4}

-1 I Value +1

When applied to the user-defined default 4QAM 1/Q map, starting from the 1st symbol (data 00), the
differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the previous
illustration.

Asyou can seg, the 1st and 4th symbols, having the same data value (00), produce the same state transition
(forward 1 state). In differential encoding, symbol values do not define location; they define the direction
and distance of atransition through the 1/Q State Map.

For instructions on configuring differential encoding, see “Understanding Differential Encoding” on
page 205.
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Using Differential Encoding

Differential encoding is a digital-encoding technique that denotes a binary value by asignal change rather
than a particular signal state. It isavailable for Custom Real Time I/Q Baseband mode. It is not available for
waveforms generated by Arb Waveform Generator mode.

Thesignal generator’'sDi fferenti al State Map editor enablesyou to modify the differential state map
associated with user-defined 1/Q and user-defined FSK modulations. In this procedure, you create a
user-defined 1/Q modulation and then configure, activate, and apply differential encoding to the user-defined
modulation. For more information, see “Understanding Differential Encoding” on page 205.

This section includes information on following:

* “Configuring User-Defined I/Q Modulation”
» “Accessing the Differential State Map Editor” on page 211
» “Editing the Differential State Map” on page 211

Configuring User-Defined 1/Q Modulation

1. PressPreset.

2. Press Mode > Custom > Real Time 1/Q Baseband > Modulation Type > Define User 1/Q > More (1 of 2) >
Load Default I/Q Map > QAM > 4QAM.

Thisloads a default 4QAM 1/Q modulation and displaysit in the 1/Q Values editor. The default 4QAM 1/Q
modul ation contains data that represent 4 symbols (00, 01, 10, and 11) mapped into the I/Q plane using 2
distinct values (1.000000 and —1.000000). These 4 symbolswill be traversed during the modulation process
by the symbol table offset values associated with each symbol of data.

FREQUENCY AMPLITUOE
Load/StoreM
44.000 000 000 000 &z | -130.00 den
noo Lomd Default|
oH I/0 Hap
| Oelete All Rows
1/0 Values
Data I Value 0 Value Differential
00000000 1.000000 Encoding
00000001 -1.000000 1.000000 on
00000010 -1.000000 -1.000000 .
00000011 1.000000 -1.000000 Difronfiagre ]
00000100 Encoding
Offset 0
on
Mare
2 of 2)
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Accessing the Differential State Map Editor

¢ Press Configure Differential Encoding.

ThisopenstheDi fferential State Map editor. At this point, you see the data for the 1st symbol
(0O0000000) and the cursor prepared to accept an offset value.You are now prepared to create a custom
differential encoding for the user-defined default 4QAM 1/Q modulation.

Data Symbol Table Offset Values Entry Area

FHEDUEN4EY4 0 ﬁ 0 000 00 / ﬂﬂPLfTéD[ElU 0 . Edit Item
’7 @ Inzert Rouw

Delete Row

DlFFere ial State Hap
ata Sumbol Table Offsel

00000000 | ——— | Goto RonM

Oelete ALl Rows

Editing the Differential State Map

1. Press1 > Enter.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward through
the state map by 1 value when a data value of 0 is modulated.

2. Press+/->1> Enter.

This encodes the second symbol by adding a symbol table offset of -1. The symbol rotates backward
through the state map by 1 value when a data value of 1 is modulated.

NOTE At this point, the modulation has one bit per symbol. For the first two data values
(00000000 and 00000001) only the last bits (the 0 and the 1, respectively) are
significant.

3. Press2 > Enter.

This encodes the third symbol by adding a symbal table offset of 2. The symbol rotates forward through
the state map by 2 values when a data value of 10 is modulated.
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4. Press0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate through
the state map when a data value of 11 is modulated.

NOTE At this point, the modulation has two bits per symbol. For the data values 00000000,
00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.

5. PressReturn > Differential Encoding Off On.
This applies the custom differential encoding to a user-defined modul ation.

NOTE Noticethat (UNSTORED) appearsnexttoDi fferential State Map onthesignal
generator’s display. Differential state maps are associated with the user-defined
modulation for which they were created.

To save a custom differential state map, you must store the user-defined modulation for
which it was designed. Otherwise the symbol table offset datais purged when you press
the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK
editor.
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8  Multitone Waveform Generator

In the following sections, this chapter describes the multitone mode, which isavailable only in E8267D PSG
vector signal generators with Option 601 or 602:

* “Overview” on page 214
» “Creating, Viewing, and Optimizing Multitone Waveforms’ on page 215

See also: “Basic Digital Operation” on page 77
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Overview

The multitone mode builds awaveform that has up to 64 CW signals, or tones. Using the Mul ti t one
Set up table editor, you can define, modify, and store waveforms for playback. Multitone waveforms are
generated by the internal 1/Q baseband generator.

The multitone waveform generator is typically used for testing the intermodulation distortion characteristics
of multi-channel devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when
non-linear devices with multiple input frequencies cause unwanted outputs at other frequencies or interfere
with adjacent channels. The multitone waveform generator supplies a waveform with a user-specified
number of tones whose IMD products can be measured using a spectrum analyzer and used as a reference
when measuring the IMD generated by a device-under-test.

Multitone waveforms are created using the internal 1/Q baseband generator and stored in ARB memory for
playback. Although the multitone mode generates a high-quality waveform, a small amount of IMD, carrier
feedthrough, and feedthrough-related IMD occurs. Carrier feedthrough may be observed when an even
number of tones are generated, since there are no tones at the center carrier frequency to mask the
feedthrough. To minimize carrier feedthrough for an even-numbered multitone signal, it is necessary to
manually adjust the | and Q offsets while observing the center carrier frequency with a spectrum analyzer.

For measurements that require more than 64 tones or the absence of IMD and carrier feedthrough, you can
create up to 1024 distortion-free multitone signals using Agilent Technologies Signal Studio software
Option 408.

NOTE For more information about multitone waveform characteristics and the PSG vector signal
generator multitone format, download Application Note 1410 from our website by going to
http: //mww.agilent.com and searching for “AN 1410” in Test & Measurement.
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Creating, Viewing, and Optimizing Multitone Waveforms

This section describes how to set up, generate, and optimize a multitone waveform while viewing it with a
spectrum analyzer. Although you can view a generated multitone signal using any spectrum analyzer that
has sufficient frequency range, an Agilent Technologies PSA high-performance spectrum analyzer was used
for this demonstration. Before generating your signal, connect the spectrum analyzer to the signal generator
as shown in Figure 8-1.

Figure 8-1 Spectrum Analyzer Setup
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To Create a Custom Multitone Waveform

UsingtheMul tit one Set up table editor, you can define, modify and store user-defined multitone
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

Preset the signal generator.

Set the signal generator RF output frequency to 20 GHz.

Set the signal generator RF output amplitude to 0 dBm.

Press Mode > Multitone > Initialize Table > Number of Tones > 9 > Enter.
Press Freq Spacing > 1 > MHz.

Press Initialize Phase Fixed Random to Random.

Press Done.

Press Multitone Off On to On.

© 0o N o 0 M W NP

Turn on the RF output.
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The multitone signal should be available at the signal generator RF OUTPUT connector.

Figure 8-2 shows what the signal generator display should look like after al steps have been completed.
Notice that the M TONE, | / Q RF ON, and MOD ON annunciators are displayed and the parameter settings
for the signal are shown in the status area of the signal generator display. The multitone waveform is stored
in volatile ARB memory.

The waveform has nine tones spaced 1 MHz apart with random initial phase values. The center toneis
placed at the carrier frequency, while the other eight tones are spaced in 1 MHz increments from the center
tone. If you create an even number of tones, the carrier frequency will be centered between the two middle

tones.
Figure 8-2
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To View a Multitone Waveform

This procedure describes how to configure the spectrum analyzer to view a multitone waveform and its IMD
products. Actual key presses will vary, depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 20 GHz.

3. Set the frequency span to 20 MHz.

4. Set the amplitude for a 10 dB scale with a4 dBm reference.

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1
kHz setting was used in our example.

6. Turn on the peak detector.
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7. Set the attenuation to 14 dB, so you' re not overdriving the input mixer on the spectrum analyzer.

You should now see awaveform with nine tones and a 20 GHz center carrier frequency that is similar to the
one shown in Figure 8-3. You will also see IMD products at 1 MHz intervals above and below the highest
and lowest tones.

Figure 8-3
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To Edit the Multitone Setup Table

This procedure builds upon the previous procedure.

1. Pressnitialize Table > Number of Tones > 10 > Enter.

2. PressDone.

3. Highlight the value ((n) in the St at e column for the tone in row 2.

4. PressToggle State.

5. Highlight the value (O dB) in the Power column for the tonein row 4.
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Press Edit Item > -10 > dB.
Highlight the value (0) in the Phase column for the tonein row 4.

Press Edit Item > 123 > deg.

© ® N o

Press Apply Multitone.

NOTE Whenever achange is made to a setting while the multitone generator is operating (Multitone
Off On set to On), you must apply the change by pressing the Apply Multitone softkey before
the updated waveform will be generated. When you apply a change, the baseband generator
creates a multitone waveform using the new settings and repl aces the existing waveformin
ARB memory.

You have now changed the number of tones to 10, disabled tone 2, and changed the power and phase of
tone 4. Figure 8-4 shows what the multitone setup table display on the signal generator should ook like after
all steps have been completed. The spectrum analyzer should display a waveform similar to the one shown
in Figure 8-5 on page 219. Notice that even-numbered multitone waveforms have a small amount of carrier
feedthrough at the center carrier frequency.

Figure 8-4
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Figure 8-5
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To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between
the tones and their intermodul ation distortion products. Carrier feedthrough can only be observed with
even-numbered multitone waveforms.

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100-200 ms. Thiswill allow you to dynamically view the carrier feedthrough spike as you make
adjustments.

2. Onthe signal generator, press 1/Q > 1/Q Adjustments > I/Q Adjustments Off On to On.

3. Press| Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum
analyzer. Changing the | offset in the proper direction will reduce the feedthrough level. Adjust the level
aslow aspossible.
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Turn on waveform averaging.

© © N o o &

spaced 10 MHz from the marked tone.

Create amarker and place it on the peak of one of the end tones.

10. Measure the power difference between the tone and its distortion product.

Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

On the spectrum analyzer, return the resolution bandwidth to its previous setting.

Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be

You should now see adisplay that is similar to the one shown in Figure 8-6. Your optimized multitone signal
can now be used to measure the IMD products generated by a device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically
readjust your | and Q offsets to keep the signal optimized.

Figure 8-6
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To Determine Peak to Average Characteristics

This procedure describes how to set the phases of the tonesin a multitone waveform and determine the peak
to average characteristics by plotting the complementary cumulative distribution function (CCDF).

Press Mode > Multitone > Initialize Table > Number of Tones > 64 > Enter.
Press Freq Spacing > 20 > kHz.

Press Initialize Phase Fixed Random to Fixed.

Press Done.

Press Apply Multitone.

o o A W N BB

Press More (1 of 2) > ARB Setup > Waveform Utilities > Waveform Statistics > Plot CCDF.

You should now see adisplay that is similar to the one shown in Figure 8-7. The CCDF plot displays the
peak to average characteristics of the waveform with all phases set to zero.

Figure 8-7 CCDF Plot with Fixed Phase Set
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7. Press Mode Setup > Initialize Table.
8. Press Initialize Phase Fixed Random to Random.

9. PressRandom Seed Fixed Random to Random.
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10.
11

Press Done.

Press Apply Multitone.

12. Press More (1 of 2) > Waveform Statistics > Plot CCDF.

You should now see adisplay that is similar to the one shown in Figure 8-8. The CCDF plot displaysthe
peak to average characteristics of the waveform with randomly generated phases and a random seed.

The random phase setup simulates the typically random nature of multitone waveforms. Notice that
randomly distributed phases result in a much lower peak to average ratio than fixed phases. An increase
in the number of tones with random phases will decrease the probability of a maximum peak power

occurrence.
Figure 8-8 CCDF Plot with Random Phase Set
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O Two-Tone Waveform Generator

In the following sections, this chapter describes the two-tone mode, which isavailable only in E8267D PSG
vector signal generators with Option 601 or 602:

*  “Overview” on page 224
e “Creating, Viewing, and Modifying Two-Tone Waveforms’ on page 225

See also: “Arbitrary (ARB) Waveform File Headers” on page 80
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Two-Tone Waveform Generator
Overview

Overview

The two-tone mode builds awaveform that has two equal-powered CW signals, or tones. The default
waveform has two tones that are symmetrically spaced from the center carrier frequency, and have
user-defined amplitude, carrier frequency, and frequency separation settings. The user can also align the
tones left or right, relative to the carrier frequency.

The two-tone waveform generator is designed for testing the intermodulation distortion characteristics of
non-linear devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when non-linear
devices with multiple input frequencies interfere with adjacent channels or cause unwanted outputs at other
frequencies. The two-tone waveform generator supplies a signal whose IMD products can be measured
using a spectrum analyzer and used as a reference when measuring the IMD generated by a
device-under-test.

Two-tone waveforms are created using the internal 1/Q baseband generator and stored in ARB memory for
playback. Although the two-tone mode generates a high-quality waveform, a small amount of IMD occurs.
In addition to IMD, a small amount of carrier feedthrough and feedthrough-related IMD may be present
when the spacing between thetonesis centered on the carrier frequency. To minimize carrier feedthrough for
atwo-tone signal, you must manually adjust the | and Q offsets while observing the center carrier frequency
with a spectrum analyzer. For measurements that require the absence of IMD and carrier feedthrough, you
can create distortion-free multitone signals using Agilent Technologies' Signal Studio software Option 408.

NOTE For more information about two-tone waveform characteristics and the PSG vector signal
generator two-tone format, download Application Note 1410 from our website by going to
http: //mww.agilent.com and searching for “AN 1410” in Test & Measurement.
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Creating, Viewing, and Modifying Two-Tone Waveforms

This section describes how to set up, generate, and modify atwo-tone waveform while viewing it with a
spectrum analyzer. Although you can view a generated two-tone signal using any spectrum analyzer that has
sufficient frequency range, an Agilent Technologies PSA Series High-Performance Spectrum Analyzer was
used for this demonstration. Before generating your signal, connect the spectrum analyzer to the signal
generator as shown in Figure 9-1.

Figure 9-1 Spectrum Analyzer Setup
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To Create a Two-Tone Waveform
This procedure describes how to create and a basic, center-aligned, two-tone waveform.

1. Preset the signal generator.

2. Setthe signal generator RF output frequency to 20 GHz.
3. Setthesigna generator RF output amplitude to O dBm.
4. Press Mode > Two Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 9-2 on page 226
shows what the signal generator display should look like after all steps have been completed. Notice that the
T-TONE, | / Q RF A\, and MOD ON annunciators are displayed and the parameter settings for the signal
are shown in the status area of the signal generator display.
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Figure 9-2
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To View a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two-tone waveform and its IMD
products. Actual key presses will vary, depending on the model of spectrum analyzer you are using.

1
2
3
4.
5

6.
7.

Preset the spectrum analyzer.

Set the carrier frequency to 20 GHz.

Set the frequency span to 60 MHz.

Set the amplitude for a 10 dB scale with a4 dBm reference.

. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1

kHz setting was used in our example.
Turn on the peak detector.

Set the attenuation to 14 dB, so you're not overdriving the input mixer on the spectrum analyzer.

You should now see atwo-tone waveform with a 20 GHz center carrier frequency that is similar to the one
shown in Figure 9-3 on page 227. You will also see IMD products at 10 MHz intervals above and below the
generated tones, and a carrier feedthrough spike at the center frequency with carrier feedthrough distortion
products at 10 MHz intervals above and below the center carrier frequency.
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Figure 9-3
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To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between
the tones and their intermodulation distortion products. Carrier feedthrough only occurs with center-aligned
two-tone waveforms.

This procedure builds upon the previous procedure.

1

© o N o 0 &

On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about
100-200 ms. Thiswill allow you to dynamically view the carrier feedthrough spike as you make
adjustments.

On the signal generator, press 1/Q > 1/Q Adjustments > I/Q Adjustments Off On to On.

Press | Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum
analyzer. Changing the | offset in the proper direction will reduce the feedthrough level. Adjust the level
aslow aspossible.

Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
On the spectrum analyzer, return the resolution bandwidth to its previous setting.

Turn on waveform averaging.

Create a marker and place it on the peak of one of the two tones.

Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be
spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product.

You should now see adisplay that is similar to the one shown in Figure 9-4 on page 229. Your optimized
two-tone signal can now be used to measure the IMD products generated by a device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically
readjust your | and Q offsets to keep your signal optimized.
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Figure 9-4
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To Change the Alignment of a Two-Tone Waveform

This procedure describes how to align atwo-tone waveform left or right, relative to the center carrier
frequency. Because the frequency of one of the tones is the same as the carrier frequency, this alignment
eliminates carrier feedthrough. However, image frequency interference caused by left or right alignment
may cause minor distortion of the two-tone signal. This procedure builds upon the previous procedure.

1. Onthesignal generator, press Mode Setup > Alignment Left Cent Right to L eft.

2. Press Apply Settings to regenerate the waveform.

NOTE Whenever a change is made to a setting while the two-tone generator is operating

(Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey
before the updated waveform will be generated. When you apply a change, the baseband
generator creates a two-tone waveform using the new settings and replaces the existing

waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more quickly.
You should now see aleft-aligned two-tone waveform that is similar to the one shown in Figure 9-5.

Figure 9-5
¥ Agilent 12:81:27 Jun 7, 2082

Ref @ dBm #Atten 14 dB

#Peak

Log

18

a8/ Two-Tone | — Upper| Tone
Chanpels <= Aligned with

Carrier
Frequency

Intermodulation
Distortion

LgAv Y\

1868 ™~

ML s2 T

$3 FC \

RA

£

FTun |

SHD [T N | R A J_-—w*’j/ WWJL-M

Center 20,0600 86 GHz Span 88 MHz

#Res BH 9.1 kHz VEH 9.1 HHz Sweep 1165 =

Carrier
Frequency
230 Chapter 9



10 AWGN Waveform Generator

In the following sections, this chapter contains examples for using the AWGN waveform generator, which is
available only in E8267D vector PSGs with Options 601 or 602 and Option 403:

e “Arb Waveform Generator AWGN” on page 232
e “Rea Timel/Q Baseband AWGN" on page 233

For adding real-time AWGN to waveforms using the Dual ARB player, see “Adding Real-Time Noiseto a
Dua ARB Waveform” on page 95
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Configuring the AWGN Generator

The AWGN (additive white Gaussian noise) generator is available for the Arb Waveform Generator mode
and the Real Time 1/Q Baseband mode. The AWGN generator can be configured with user-defined noise
bandwidth, noise waveform length, and noise seed parameters.

+ Bandwidth — the noise bandwidth can be set from 50 kHz to 15 MHz.

»  Waveform Length — the waveform length is the length in samples of the noise waveform. Longer
waveform lengths provide more statistically correct noise waveforms.

» Noise Seed — the noise seed selection can be either random or fixed. The noise seed determines whether
the noise waveform datais repeatabl e (using the fixed selection) or random (using the random selection).

When the AWGN generator is active, an annunciator, labeled AWGN, is displayed on the front panel of the
signal generator.

Arb Waveform Generator AWGN

Press Preset.

Press Mode > More (1 of 2) > AWGN > Arb Waveform Generator AWGN
Press Bandwidth > 1.25 > MHz.

Press Waveform Length > 131072.

o A WD

Press Noise Seed Fixed Random until Random is highlighted.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.
2. Set the output amplitude to —10 dBm.
3. PressRF On/0ff.

This configures arandomly seeded AWGN waveform with abandwidth of 1.25 MHz and awaveform length
of 131072 hits.

The AWGN waveform is now available at the signal generator’s RF OUTPUT connector.

Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During
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waveform generation, the AWAN and | / Qannunciators activate and the AWGN waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.

Real Time 1/7Q Baseband AWGN

1. PressPreset.
2. Press Mode > More (1 of 2) > AWGN > Real Time 1/Q Baseband AWGN
3. PressBandwidth > 10 > MHz.

Configuring the RF Output

1. Set the RF output frequency to 500 MHz.

2. Set the output amplitude to —10 dBm.

3. PressRF On/Off.

The AWGN waveform is now available at the signal generator’s RF OUTPUT connector.

Generating the Waveform
Press AWGN Off On until On is highlighted.

This generates an AWGN waveform with the parameters defined in the previous procedure. During
waveform generation, the AWAN and | / Qannunciators activate and the AWGN waveform is stored in
volatile ARB memory. The waveform is now modulating the RF carrier.
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11 Peripheral Devices

This chapter provides information on peripheral devices used with PSG signal generators. The N5102A
Baseband Studio digital signal interface module and extended frequency source module operation and
features are described in the following sections:

N5102A Digital Signal Interface Module

= “Clock Timing” on page 236

= “Connecting the Clock Source and the Device Under Test” on page 248
= “DataTypes’ on page 250

« “Operating the N5102A Module in Output Mode” on page 251

e “Operating the N5102A Modulein Input Mode” on page 260

Millimeter-Wave Source Modules

= “Using Agilent Millimeter-Wave Source Modules’ on page 270
e “Using Other Source Modules’ on page 273
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N5102A Digital Signal Interface Module

Clock Timing

This section describes how clocking for the digital datais provided. Clock timing information and diagrams
are supplied for the different port configurations (serial, parallel, or parallel interleaved data transmission)
and phase and skew settings. All settings for the interface module are available on the signal generator user
interface (Ul).

Clock and Sample Rates

A sampleisagroup of bits where the size of the sample is set using the Word Size softkey. The clock isthe
signal that tells when the bits of asample are valid (in anon-transition state). The clock and sample rates are
displayed in the first-level and data setup softkey menus. The clock rate and sample rate are usually the
same. They will differ when serial mode is selected, or when there are multiple clocks per sample.

Figure 11-1 Data Setup Menu for a Parallel Port Configuration
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See the PSG User’s Guide for information

The N5102A module clock rateis set using the Clock Rate softkey and has arange of 1 kHz to
400 MHz. The samplerate is automatically calculated and has arange of 1 kHz to 100 MHz. These ranges
can be smaller depending on logic type, data parameters, and clock configuration.
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Maximum Clock Rates

The N5102A module maximum clock rate depends on the logic and signal type. Table 11-1 and

Table 11-2 show the warranted rates and the maximum clock rates for the various logic and signal types.
Notice that LVDS in the output mode using an IF signal is the only logic type where the warranted and
maximum rates are the same.

Table 11-1 Warranted Parallel Output Level Clock Rates and Maximum
Clock Rates
Warranted Level Clock Rates Maximum Clock Rates (typical)
Logic Type
1Q Signal Type IF Signal Type! IQ Signal Type IF Signal Type
LVTTL and CMOS | 100 MHz 100 MHz 150 MHz 150 MHz
LVDS 200 MHz 400 MHz 400 MHz 400 MHz

1. The IF signal type is not available for a serial port configuration.

Table 11-2 Warranted Parallel Input Level Clock Rates and Maximum Clock
Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS | 100 MHz 100 MHz

LVDS 100 MHz 400 MHz

Thelevels will degrade above the warranted level clock rates, but they may still be usable.

Serial Port Configuration Clock Rates

For a seria port configuration, the lower clock rate limit is determined by the word size (word size and
sampl e size are synonymous), while the maximum clock rate limit remains constant at 150 MHz for LVTTL
and CMOS logic types, and 400 MHz for an LVDS logic type.

Thereverseistrue for the sample rate. Thelower sample (word) rate value of 1 kHz remains while the upper
limit of the sample rate varies with the word size. For example, afive-bit sasmple for an LVTTL or CMOS
logic typeyields the following values in serial mode:

= Clock rate of 5 kHz through 150 MHz

= Samplerate of 1 kHz through 30 MHz
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Refer to Table 11-3 and Table 11-4, for the seria clock rates.

Table 11-3 Output Serial Clock Rates
Logic Type Minimum Rate Maximum Rate
LVDS 1 x (word size) kHz 400 MHz
LVTTL and CMOS 1 x (word size) kHz 150 MHz
Table 11-4 Input Serial Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
LVDS Samples 1 x (word size) kHz 400
Pre-FIR 1 x (word size) kHz the smaller of: 50t x (word size) MHz
Samples or
400 MHz
LVTTL and CMOS | N/A 1 x (word size) kHz 150 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. Refer to “Input Mode” on page
250 for more information.

Parallel and Parallel Interleaved Port Configuration Clock Rates

Parallel and parallel interleaved port configurations have ather limiting factors for the clock and sample
rates:

= logictype

= Clocks per sample selection

« 1Qor IF digita signa type

Clocks per sample (clocks/sample) isthe ratio of the clock to sample rate. For an 1Q signal type, the sample
rateisreduced by the clocks per sample value when the value is greater than one. For an | F signal or an input

signal, clocks per sample is aways set to one. Refer to Table 11-5 for the Output mode parallel and parallel
interleaved port configuration clock rates.
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Table 11-5 Output Parallel and Parallel Interleaved Clock Rates
Logic Type | Signal Type | Minimum Rate Maximum Rate
LVDS 1Q 1 x (clocks/sample) kHz | the smaller of: 100 x (clocks /sample) MHz
Z[)O MHz
IF 4 kHz 400 MHz
Other 1Q 1 x (clocks/sample) kHz | the smaller of: 100 x (clocks /sample) MHz
g.)rSO MHz
IF 4 kHz 150 MHz

For Input mode, the maximum clock rate is limited by the following factors:

e samplesize
- datatype
= selected filter for Pre-FIR Samples

Refer to Table 11-6 for the Input mode parallel and parallel interleaved port configuration clock rates.

Table 11-6 Input Parallel and Parallel Interleaved Clock Rates
Logic Type Data Type Minimum Rate Maximum Rate
N/A Samples 1kHz 100 MHz
Pre-FIR Samples 1kHz 50 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. Refer to “Input Mode”
on page 250 for more information.
Clock Source
The clock signal for the N5102A module is provided in one of three ways through the following selections:
= Internal: generated internally in the interface module (requires an external reference)

= External: generated externally through the Ext Clock In connector
= Device: generated externally through the Device Interface connector
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The clock sourceis selected using the N5102A module Ul on the signal generator, as shown in Figure 11-2.

Figure 11-2 Clock Source Selection
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When you select a clock source, you must let the N5102A module know the frequency of the clock signal
using the Clock Rate softkey. Inthe internal clock source mode, use this softkey to set theinternal clock rate.
For device and external clock sources, this softkey must reflect the frequency of the applied clock signal.

When the clock source is Internal, afrequency reference must be applied to the Freq Ref connector. The
frequency of this applied signal needs to be specified using the Reference Frequency softkey, unless the
current setting matches that of the applied signal.

The selected clock source provides the interface module output clock signal at the Clock Out and the Device
Interface connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting of arbitrary clock rates for
the device under test. In general, the clock rate inside the PSG will be different from the interface module
clock rate, so the interface module performs arate conversion. An important aspect of this conversionisto
have accurate clock rate information to avoid losing data. The module relies on relative clock accuracy,
instead of absolute accuracy, that must be ensured by using a single frequency reference for all clock rates
involved in the test setup. This can be implemented in various ways (see the five drawingsin Figure 11-3 on
page 241), but whatever way it is implemented, the clock inside the signal generator must have the same
base frequency reference as the clock used by the device under test.
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PSG Frequency Reference Connections
When afrequency reference is connected to the PSG, it is applied to one of two rear-panel connectors:

e 10MHzIN

= BASEBAND GEN REFIN

The BASEBAND GEN REF IN connector will accept afrequency referencein therange of 1to 100 MHz. If
the external or device under test clock source cannot provide or accept afrequency reference, that clock
signal can be applied to this connector and used as the frequency reference.

Whenever an external clock signal or frequency reference is connected to the BASEBAND GEN REF IN
connector, its frequency needs to be entered into the current signal generator modul ation format. For
information on the BASEBAND GEN REF IN connector refer to “5. BASEBAND GEN REF IN” on page
25. For information on the associated softkeys and fields for entering the frequency of the applied clock
signal or frequency reference, refer to the PSG Key Reference.

Peripheral Devices
N5102A Digital Signal Interface Module

Figure 11-3 Frequency Reference Setup Diagrams for the N5102A Module Clock Signal
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NOTE: Use only one of the two signal generator frequency reference inputs.
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Externally Supplied Clock
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NOTE: Use only one of the two signal generator frequency reference inputs.

Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A sample period consists of an |
and Q sample). For parallel datatransmissions, you can select one, two, or four clocks per sample. For
clocks per sample greater than one, the | and Q samples are held constant to accommodate the additional
clock periods. This reduces the sample rate relative to the clock rate by afactor equal to the clocks per
sample selection. For example, when four is selected, the sample rate is reduced by afactor of four (sample
rate to clock rate ratio). Figure 11-4 demonstrates the clock timing for each clocks per sample selection. For
input mode, the clocks per sample setting is always one.
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Figure 11-4 Clock Sample Timing for Parallel Port Configuration
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2 Clocks Per Sample
Sample rate decreases by a factor of two
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Clock Timing for Parallel Interleaved Data

The N5102A module provides the capahility to interleave the digital | and Q samples. There are two choices
for interleaving:

« 1Q, where the | sampleistransmitted first
= QlI, where the Q sampleistransmitted first

When parallel interleaved is selected, all samples are transmitted on the | data lines. This effectively
transmits the same number of samples during a sample period on half the number of datalines as compared
to non-interleaved samples. (A sample period consists of an | and Q sample.) Clocks per sampleisstill a
valid parameter for parallel interleaved transmissions and creates a reduction in the sample rate relative to
the clock rate. The clocks per sample selection isthe ratio of the reduction. Figure 11-5 shows each of the
clocks per sample selections, for aparalel 1Q interleaved port configuration, using aword sized of four bits
and the clock timing relative to the | and Q samples. For aparald QI interleaved port configuration, just
reverse the | and Q sample positions. For input mode, the clocks per sample setting is always one.

Figure 11-5 Clock Timing for a Parallel IQ Interleaved Port Configuration

1 Clock Per Sample

The | sample is transmitted on one clock transition and the Q sample is transmitted on the
other transition; the sample and clock rates are the same.

1 Sample Period

| 1Clock | | I I |
- | | | |
Clock [ I [ P | |
XOXOXOXOXO oko 0*0 0*
*1X1¥1X1)§1 1|X1 1X|1 1*
kzXz*zXzXz 2:X2 2X|2 2%
3X3X3X3|X3 3i3X3 3 3%(

| | | | | |

| sample Q sample

4 bits per word 4 bits per word
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2 Clocks Per Sample

The | sample is transmitted for one clock period and the Q sample is transmitted during the second
clock period; the sample rate decreases by a factor of two.

1 Sample Period

I 2 Clocks I I
e E— |
cok | L[ L [ [ | [ |
X 0 0 K 0 0 X 0
) 1 K1 1 K1
2 2 K2 2} 2
X 3
|

w
w
N
w
w

| sample Q sample
4 bits per word 4 bits per word

4 Clocks Per Sample

The | sample is transmitted for the first two clock periods and the Q sample is transmitted during the second two
clock periods; the sample rate is decreased by a factor of four.

1 Sample Period
4 Clocks

<
A

Clock

S —
S >em s L

|

| sample Q sample
4 bits per word 4 bits per word
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Clock Timing for Serial Data

Figure 11-6 shows the clock timing for aserial port configuration. Notice that the serial transmission
includes frame pulses that mark the beginning of each sample while the clock delineates the beginning of
each hit. For serial transmission, the clock and the bit rates are the same, but the sample rate varies
depending on the number of bits per word that are entered using the Word Size softkey. The number of bits
per word is the same as the number of bits per sample.

Figure 11-6 Clock Timing for a Serial Port Configuration
| |
|-t 1 Sample |
Frame Marker |
Clock | | | | | |
Data Bits >‘< 0 1 2 3 X 0

H//

4 bits per word

Clock Timing for Phase and Skew Adjustments

The N5102A modul e provides phase and skew adjustments for the clock relative to the data and can be used
to align the clock with the valid portion of the data. The phase has a 90 degree resolution (0, 90, 180, and
270 degree selections) for clock rates from 10 to 200 MHz and a 180 degree resolution (0 and 180 degree
selections) for clock rates below 10 MHz and greater than 200 MHz.

The skew is displayed in nanoseconds with a maximum range of +5 ns using a maximum of £127 discrete
steps. Both the skew range and the number of discrete steps are variable with a dependency on the clock rate.
The skew range decreases as the clock rate is increased and increases as the clock rate is decreased. The
maximum skew rangeis reached at a clock rate of approximately 99 MHz and is maintained down to a clock
rate of 25 MHz. For clock rates below 25 MHz, the skew adjustment is unavailable.

A discrete step is calculated using the following formula:

1
256 x Clock Rate

The number of discrete steps required to reach the maximum skew range decreases at lower frequencies. For
example, at aclock rate of 50 MHz, 127 steps would exceed the maximum skew range of 5 ns, so the actual
number of discrete steps would be less than 127.

Figure 11-7 is an exampl e of a phase and skew adjustment and shows the original clock and its phase
position rel ative to the data after each adjustment. Notice that the skew adjustment adds to the phase setting.
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Figure 11-7 Clock Phase and Skew Adjustments
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Connecting the Clock Source and the Device Under Test

Asshown in Figure 11-3 on page 241, there are numerous ways to provide a common frequency referenceto
the system components (PSG, N5102A module, and the device under test). Figure 11-8 shows an example
setup where the signal generator supplies the common frequency reference and the N5102A module
provides the clock to the device.

See the N5102A Digital Signal Interface Module Installation Guide for detailed information on device
interface connections.

CAUTION The Device Interface connector on the interface module communicates using high speed
digital data. Use ESD precautions to eliminate potential damage when making connections.

NOTE You must disconnect the digital bus cable and the digital module while downloading
firmware to the PSG.
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Figure 11-8 Example Setup using the PSG 10 MHz Frequency Reference

Signal generator 10 MHz Out

Common Freq Ref cable

\" Freq Ref connector
Device under test

Break-out board

Device interface connection User furnished ribbon cable(s) connect
between the device and break-out board.
The clock to the device is in the ribbon
cable.

1. Refer to the five setup diagramsin Figure 11-3 on page 241 and connect the frequency reference cable
according to the clock source.

2. If anexternal clock sourceisused, connect the external clock signal to the Ext Clock In connector on the
interface module.

3. Select the break-out board that has the output connector suited for the application. See the N5102A
Digital Sgnal Interface Module Installation Guide for information on breakout boards.

NOTE If the Device Interface mating connector is used with the device under test, refer to Figure
11-8 for the device interface connection and connect the device to the N5102A module.
Then proceed to “Operating the N5102A Module in Output Mode” on page 251 or
“Operating the N5102A Modulein Input Mode” on page 260.

4. Refer to Figure 11-8. Connect the breakout board to the N5102A module’s Device I nterface connector.

5. Connect the device to the break-out board. See the N5102A Digital Signal Interface Module Installation
Guide for information on breakout board connectivity.
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Data Types

The following block diagram indicates where in the PSG signal generation process the datais injected for
input mode or tapped for output mode.

Output
Mode
Pre-FIR
Samples Samples
A A
=
Data FIR »l Q > 1IQ a
Generator [~ A - Filtering | A DACs Modulator >
Pre-FIR Samples
Samples |
nput
Mgaje

Output Mode

When using an ARB format, the data type is always Samples and no filtering is applied to the data
samples.The samples are sent to the digital module at the ARB sample clock rate.

For real-time formats, choosing Samples as the data type will send filtered samples to the digital module at a
rate between 50 MHz and 100 MHz. Selecting Pre-FIR Samples, sends unfiltered samplesto the digital
modul e at arate equal to the sample rate of the current format.

Input Mode

When the data type is Samples, the data samples coming through the digital module are injected at a point
that bypasses the filtering process.

If Pre-FIR Samplesis selected, the data samples are injected before the filtering process. The maximum rate
will be determined by the selected filter. Refer to Table 11-7.
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Table 11-7 Maximum Sample Rate for Selected Filter

Filter Maximum Rate

Gaussian
Nyquist

Root Nyquist
Rectangle
Edge 50 MHz
UN3/4 GSM Gaussian
1S-95

IS 95 W/EQ

IS-95 Mod 25 MHz
IS-95 Mod W/EQ

APCO 25 C4FM 12.5 MHz

The Filter softkey accesses a menu that enables you set the desired filtering parameters.

Operating the N5102A Module in Output Mode

This section shows how to set the parameters for the N5102A Option 003 module in output mode using the
front-panel keys. Each procedure contains a figure that shows the softkey menu structure for the interface
module function being performed.

Setting up the Signal Generator Baseband Data

The digital signal interface module receives data from a baseband source and outputs adigital 1Q or digital
IF signal relative to the selected logic type. Because the PSG provides the baseband data, the first procedure
in operating the interface module is configuring the PSG using one of the real-time or ARB modulation
formats, or playing back a stored file using the Dual ARB player. For information on setting up real-time or
ARB waveforms, or to learn about using the Dual ARB player, refer to the appropriate chapter in this guide.
1. Preset the signal generator.

2. Select the modulation format (TDMA, Custom, and so forth) and set the desired parameters.

3. Turn-on the modulation format.

Accessing the N5102A Module User Interface
Press Aux Fctn > N5102A Interface.

This accesses the Ul (first-level softkey menu shown in Figure 11-9) that is used to configure the digital
signal interface module. Notice the graphic in the PSG display showing a setup where the N5102A module
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is generating its own internal clock signal. This graphic changes to reflect the current clock source selection.

Figure 11-9 First-Level Softkey Menu
FREQUENCY AMPLITUDE - Nsi0za
4.000 000 000 00 &z | -136.00 den o
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1/ oH ¢3.30 CHoS)
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tParallel)
Clock
Signal Generator NS102A > Ut Data Setupe

Freqg. FleF; T Clock Setupe

Clock Rate: 100.0000 MHz ) )
Sample Rate: 100.0000 HHz Disonost icse

Pass Through
\ Preset

\ Line is grayed out until the N5102A module interface is turned on

Choosing the Logic Type and Port Configuration

Figure 11-10 Logic and Port Configuration Softkey Menus
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Samele Rate: 100.0000 HHz Dimonost icse
Pass Through Parallel
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Serial

Par I0 Intrled
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1. Refer to Figure 11-10. Press the Logic Type softkey.
From this menu, choose alogic type.

CAUTION Changing thelogic type can increase or decrease the signal voltage level going to the device
under test. To avoid damaging the device and/or the N5102A module, ensure that both are
capable of handling the voltage change.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey selection
appears requesting confirmation.

3. Refer to Figure 11-10. Press the Port Configuration softkey.
In this menu, select either a seria, parallel, or parallel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, only softkeysthat are relative to the current
configuration are active. Softkeysthat are grayed out are not available for the current setup.
Refer to the help text to determine which parameter is causing the softkey to be unavailable.
To get help information, press the Help hardkey, then press the unavailable softkey.

4. Select the port configuration for the device.

Selecting the Output Direction
Press Data Setup > Direction Input Output to Output and press Return.

NOTE If Option 003 isthe only option installed, the direction softkey will be unavailable and the
mode will always be output. With both Option 003 (output mode) and Option 004 (input
mode) installed, the default direction is output.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names are
generally not mentioned. For example, the Word Size softkey. For more information on all of the softkeys,
refer to PSG Key Reference.

1. Refer to Figure 11-11. Press the Data Setup softkey.
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Figure 11-11 Data Setup Menu Location
FRECUENCY AMPLITUDE NE102A
4.000 00000000 &z | -136.00 den o
e | LA Sweoes
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Clock Rate: 100.0000 MHz
Sample Rate: 100.0000 MHz

Port. Config,
(Parallel)

Data Setups <@— Accesses the data setup menu
Clock Setupe
Dimonosticse

Pass Through
Preset.

This softkey menu accesses the various parameters that govern the data received by the device under
test. The status area of the display shows the number of datalines used for both | and Q along with the
clock position relative to the data. When the port configuration is parallel or parallel interleaved, the
number of datalinesindicated is equivalent to the word (sample) size. When the port configuration is
serial, the display will show that only one | and one Q data line is being used along with the frame
marker that delineates the beginning of a sample. Figure 11-12 shows the data setup menu structure.
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Figure 11-12 Data Setup Softkey Menu with Parallel Port Configuration
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If areal-time modulation format is being used, press the Data Type softkey. (This softkey isinactive when
an ARB modulation format is turned on.)

In this menu, select whether the real-time baseband data from the signal generator is either filtered
(Samples) or unfiltered (Pre-FIR Samples). The selection depends on the test needs. The Samples selection
provides FIR filtered baseband samples based on the communication standard of the active modulation
format. Thisisthe preset selection and the one most commonly used. However if the device being tested
aready incorporates FIR filters, the Pre-FIR Samples selection should be used to avoid double filtering.

Select the datatype that is appropriate for the test.
Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2's complement allows both
positive and negative data values. Use the Offset Binary selection when components cannot process
negative values.
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5. Select the numeric format required for the test.
6. Pressthe More (1 of 2) softkey.

From this softkey menu, select the bit order, swap | and Q, select the polarity of the transmitted data, and
access menus that provide data negation, scaling, gain, offset, and 1Q rotation adjustments.

7. Pressthe Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected
sample by expressing it in the two's complement form, multiplying it by negative one, and converting the
sample back to the selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested and how it needs to receive the data.

8. Pressthe Gain, Offset & Scaling softkey.

Use the softkeysin this menu for the following functions:

= reduce sample valuesfor both | and Q using the Scaling softkey

= increase or decrease the sample values independently for | and Q using the | Gain and Q Gain softkeys
= compensate for or add a DC offset using the | Offset and Q Offset softkeys

= rotate the data on the IQ plane using the Rotation softkey

9. Make any required scaling, gain, offset, or rotation adjustments to properly test the device.

10. Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal

1. Refer to Figure 11-13. Press the clock setup softkey.

Figure 11-13 Clock Setup Menu Location

FREQLENCY AMPLITUDE  N2i02A

4.000 000 000 00 &z | =136.00 dn Mo on
HCDMA non Logic Tupe,

1/0 OH (3.3V CHoS)
| Port Config,
(Parallel}
Clock
Signal Gererator NS102A 3  OUT Data Setuph
Freq. Ref T Clack Setups| <@— Accesses the Clock Setup Menu
Clock Fate: 100.0000 MHz ) )

Sample Rate: 100.0000 MHz Diagnost icsk

Pass Through

Preset

256

Chapter 11



Peripheral Devices
N5102A Digital Signal Interface Module

From this softkey menu, set al of the clock parameters that synchronize the clocks between the N5102A
module and the PSG. You can also change the clock signal phase so the clock occurs during the valid
portion of the data. Figure 11-14 shows the clock setup menu.

Figure 11-14 Clock Setup Softkey Menu for a Parallel Port Configuration
Inactive for a serial port configuration and the IF signal type
\\
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The top graphic on the display shows the current clock source that provides the output clock signal at the
Clock Out and Device Interface connectors. The graphic changes to reflect the clock source selection
discussed later in this procedure. The bottom graphic shows the clock position relative to the data. The
displayed clock signal will change to reflect the following:

= clocks per sample selection

= clock phase choice

= clock skew adjustment

< clock polarity selection

If the device or external clock does not match the frequency, one of the following error messages will
appear on the PSG:

805 Digital nodul e output FIFO overflow error; There are nore
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sanpl es bei ng produced than can be consuned at the current
clock rate. Verify that the digital nodule clock is set up

properly.
This error is reported when the output FIFO is overflowing in the
digital module. This error can be generated if an external clock
or itsreferenceis not set up properly, or if theinternal VCO is
unlocked.

806 Di gital nodule output FlIFO underflow error; There are not
enough sanpl es being produced for the current clock rate.
Verify that the digital nodule clock is set up properly.

This error is reported when the output FIFO is underflowing in the digital module.
Thiserror can be generated if an external clock or itsreferenceis not set up properly,
or if theinternal VCO is unlocked.

2. If the port configuration is parallel or paralld interleaved, using an IQ signal type, pressthe
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DA Cs require the ability to clock multiple
times for each sample; having a clocks per sample vaue greater than one reduces the sample rate by a
factor equal to the selected number of clocks per sample. The samplerateisviewed on the first-level and
Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.
4. Pressthe Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the
signal generator clock setup menu will change to reflect the current clock source. Thiswill be indicated
by a change in the graphic.

5. Select the clock source.
If External or Deviceis Selected
Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted each time the clock rate setting is
changed. Refer to “Clock Timing for Phase and Skew Adjustments’ on page 247.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock
In connector. For the Device selection, the clock signal is supplied through the Device Interface
connector, generally by the device under test.

258 Chapter 11



Peripheral Devices
N5102A Digital Signal Interface Module

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock signal. The

reference frequency signal must be applied to the Fregq Ref connector on the digital module.

a. Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency
reference.

b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 11-8 provides aquick view of the settings and connections associated with each clock source
selection.

Table 11-8 Clock Source Settings and Connectors

Clock Source |Softkeys

N5102A M odule Connection

Reference  |Clock Ratel Freqg Ref |Ext Clock In | Device Interface
Frequency

External . .

Device

Internal?

1. For the Internal selection, this sets the internal clock rate. For the External and Device selections, this
tells the interface module the rate of the applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector.

6. Pressthe Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock relative to the datain 90 degree

increments. The selections provide a coarse adjustment for positioning the clock on the valid portion of
the data. Selecting 180 degrees is the same as selecting a negative clock polarity.

The 90 degree and 270 degree selections are not available when the clock rateis set below 10 MHz or

above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rateis set below 10 MHz or

above 200 MHz, the phase will change to 0 degrees or 180 degrees, respectively.

NOTE

The clock phase and clock skew may need to be adjusted any time the clock rate setting is

changed. Refer to “Clock Timing for Phase and Skew Adjustments’ on page 247.

7. Enter the required phase adjustment.
8. Pressthe Return softkey to return to the clock setup menu.
9. Pressthe Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is a phase
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adjustment using increments of time. This enables greater skew adjustment capability at higher clock
rates. For clock rates below 25 MHz, this softkey isinactive.

The skew has discrete values with arange that i s dependent on the clock rate. Refer to “ Clock Timing for
Phase and Skew Adjustments’ on page 247 for more information on skew settings.

10. Enter the skew adjustment that best positions the clock with the valid portion of the data.
11. Pressthe Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock transition. This
has the same affect as selecting the 180 degree phase adjustment.

12.Make the clock polarity selection that isrequired for the device being tested.
13. Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is aso reflected in the first-level softkey menu graphic. For example, if the
deviceisthe new clock source, the graphic will show that the frequency reference is now connected to
the DUT and the DUT has an input clock line going to the N5102A module.

Generating Digital Data
Press the N5102A Off On softkey to On.

Digital datais now being transferred through the N5102A module to the device. The green status light
should be blinking. Thisindicates that the datalines are active. If the status light is solidly illuminated (not
blinking), all the datalines are inactive. The status light comes on and stays on (blinking or solid) after the
first time the N5102A module is turned on (N5102A Off On to On). The status light will stay on until the
modul e is disconnected from its power supply.

The interface module can only be turned on while a modulation format is active. If the modulation format is
turned off while the module is on, the module will turn off and an error will be reported.

NOTE If changes are made to the baseband data parameters, it is recommended that you first
disable the digital output (N5102A Off On softkey to Off) to avoid exposing your device and
the N5102A module to the signal variations that may occur during the parameter changes.

Operating the N5102A Module in Input Mode

This section shows how to set the parameters for the N5102A Option 004 module using the signal generator
Ul inthe input direction. Each procedure contains a figure that shows the softkey menu structure for the
interface modul e function being performed.

Refer to “ Connecting the Clock Source and the Device Under Test” on page 248 and configure the test
setup.
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Accessing the N5102A Module User Interface
All parameters for the N5102A module are set with softkeys on the PSG signal generator.
Press Aux Fctn > N5102A Interface.

This accesses the Ul (first-level softkey menu shown in Figure 11-15) that is used to configure the digital
signal interface module. Notice the graphic, in the PSG display, showing a setup where the N5102A module
isgenerating its own internal clock signal. This graphic changes to reflect the current clock source selection.

Figure 11-15 First-Level Softkey Menu
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Selecting the Input Direction

If both Option 003 (output mode) and Option 004 (input mode) are installed, you must select the input
direction.

Press Data Setup > Direction Input Output to Input and press Return.

NOTE If only Option 004 isinstalled, the direction softkey will be unavailable and the mode will
always be input.
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Choosing the Logic Type and Port Configuration

Figure 11-16 Logic and Port Configuration Softkey Menus
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1. Refer to Figure 11-16. Press the Logic Type softkey.
From this menu, choose alogic type.

CAUTION Changing the logic type can increase or decrease the signal voltage level. To avoid
damaging the device and/or the N5102A module, ensure that both are capable of handling
the voltage change.

2. Select thelogic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey selection
appears asking for confirmation.

3. Refer to Figure 11-16. Press the Port Configuration softkey.
In this menu, select either a seria, parallel, or parallel interleaved data transmission.

NOTE Within the data and clock setup softkey menus, only softkeysthat are relative to the current
configuration are active. Softkeysthat are grayed out are not available for the current setup.
Refer to the help text to determine which parameter is causing the softkey to be unavailable.
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To get help information, press the Help hardkey, then press the unavailable softkey.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Pressthe Clock Setup softkey, as shown in Figure 11-17.

Figure 11-17 Clock Setup Menu Location
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From this softkey menu, set all of the clock parameters that synchronize the data between the N5102A
module and the device. From this menu, the clock signal phase can be changed so the clock occurs
during the valid portion of the data. Figure 11-18 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the following error messages will

appear on th
803

804

e PSG:

Digital nodule input FIFO overflow error; There are nore
sanpl es bei ng produced than can be consuned at the current
clock rate. Verify that the digital nodule clock is set up

properly.
This error is reported when the digital module clock setup is not
synchronized with the rate the samples are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.

Digital nodule input FIFO underflow error; There are not
enough sanpl es being produced for the current clock rate.
Verify that the digital nodule clock is set up properly.
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This error is reported when the digital module clock setup is not
synchronized with the rate the sampl es are entering the digital
module. Verify that the input clock rate matches the specified
clock rate under the clock setup menu.

Figure 11-18 Clock Setup Softkey Menu for a Parallel Port Configuration
Inactive for Input mode
AN
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ock Ou / = Device
— Clock Skew
Clock/Data Timing 0.000 nsec Internal
Clock 1
Data X X:/ Clock Polarit
/ Heg lﬁ 0 dea
— 90 deg

Inactive for clock rates below 25 MHz
180 deg

Active for only the Internal clock source selection
270 deg
Inactive for clock rates below Z/V
10 MHz and above 200 MHz

Daone

The top graphic on the display shows the current clock source that provides the output clock signal at the
Clock Out and Device Interface connectors. The graphic changes to reflect the clock source selection
discussed later in this procedure. The bottom graphic shows the clock edges relative to the data. The
displayed clock signal will change to reflect the following:

= clock phase choice
= clock skew adjustment
= clock polarity selection
2. Pressthe Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display in the
signal generator clock setup menu will change to reflect the current clock source. Thiswill be indicated
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by a change in the graphic.

Select the clock source.

If External or Deviceis Selected

Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is

changed. Refer to “Clock Timing for Phase and Skew Adjustments’ on page 247.

For the External selection, the signal is supplied by an external clock source and applied to the Ext Clock
In connector. For the Device selection, the clock signal is supplied through the Device Interface
connector, generally by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock signal. The

reference frequency signal must be applied to the Fregq Ref connector on the digital module.

a. Pressthe Reference Frequency softkey and enter the frequency of the externally applied frequency
reference.

b. Pressthe Clock Rate softkey and enter the appropriate clock rate.

Table 11-9 provides aquick view of the settings and connections associated with each clock source
selection.

Table 11-9 Clock Source Settings and Connectors

Clock Source |Softkeys N5102A M odule Connection

Reference  |Clock Ratel Freg Ref |Ext Clock In | Device Interface
Frequency

External . .

Device . .

Internal?

1. For the Internal selection, this sets the internal clock rate. For the External and Device selections, this

tells the interface module the rate of the applied clock signal.

2. There should be no clock signal applied to the Ext Clock In connector when Internal is being used.

4.

Press the Clock Phase softkey.

From the menu that appears, the phase of the clock relative to the data can be changed in 90 degree
increments. The selections provide a coarse adjustment for positioning the clock on the valid portion of
the data. Selecting 180 degrees is the same as selecting a negative clock polarity.
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The 90 degree and 270 degree selections are not available when the clock rateis set below 10 MHz or
above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rateis set below 10 MHz or
above 200 MHz, the phase will change to 0 degrees or 180 degrees, respectively.

NOTE The clock phase and clock skew may need to be adjusted any time the clock rate setting is
changed. Refer to “Clock Timing for Phase and Skew Adjustments’ on page 247.

5. Enter the required phase adjustment.
6. Pressthe Return softkey to return to the clock setup menu.
7. Pressthe Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is a phase
adjustment using increments of time. This enables greater skew adjustment capability at higher clock
rates. For clock rates below 25 MHz, this softkey isinactive.

The skew has discrete values with arange that i s dependent on the clock rate. Refer to “ Clock Timing for
Phase and Skew Adjustments’ on page 247 for more information on skew settings.

8. Enter the skew adjustment that best positions the clock with the valid portion of the data.
9. Pressthe Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock transition. This
has the same affect as selecting the 180 degree phase adjustment.

10. Make the clock polarity selection that is required for the device being tested.
11. Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is aso reflected in the first-level softkey menu graphic. For example, if the
deviceisthe new clock source, you will see that the frequency reference is now connected to the DUT
and the DUT has an input clock line going to the N5102A module.

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory names (for
example, the Word Size softkey) are generally not mentioned. For more information on all of the softkeys,
refer to the PSG Key Reference.

1. Refer to Figure 11-19. Press the Data Setup softkey.
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Figure 11-19 Data Setup Menu Location
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Clock Rate: 100.0000 MHz
Sample Rate: 100.0000 MHz
Pass Through Mode

Clock Setupe

Dimonosticse

lg—— Accesses the data setup menu

This softkey menu accesses the various parameters that govern the data received by the PSG. The status
area of the display shows the number of datalines used for both | and Q along with the clock position
relative to the data. Figure 11-20 shows the data setup menu structure.
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Figure 11-20 Data Setup Softkey Menu with Parallel Port Configuration
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2. Pressthe Data Type softkey.
In this menu, select the data type to be either filtered (Samples) or unfiltered (Pre-FIR Samples). The
selection is dependent on the test needs and the device under test. However if the device being tested
aready incorporates FIR filters, the Pre-FIR Samples selection should be used to avoid double filtering.
Refer to “Data Types’ on page 250, for moreinformation.
3. Select the datatype that is appropriate for the test needs.

Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2's complement allows both
positive and negative data values. Use the Offset Binary selection when components cannot process
negative values.

5. Select the numeric format required for the test.

Press the More (1 of 2) softkey.
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From this softkey menu, select the bit order, swap | and Q, the polarity of the data, and access menus that
provides data negation, scaling, and filtering parameters.

. Pressthe Data Negation softkey.

Negation differs from changing the | and Q polarity. Applied to a sample, negation changes the affected
sample by expressing it in the two's complement form, multiplying it by negative one, and converting the
sample back to the selected numeric format. This can be done for | samples, Q samples, or both.

The choice to use negation is dependent on the device being tested.

. Toaccess |/Q scaling and filter parameters, press Return > N5102A Off On to On. Thiswill invoke the real
time Custom format in the PSG baseband generator. Thisis needed to set the filter parameters when
Pre-FIR Samplesis selected as the data type.

. Pressthe Baseband Setup softkey.

Use this softkey menu to adjust the 1/Q scaling and access filter parameters. If the selected datatypeis
Samples, the Filter softkey is grayed out (inactive).

Digital Data
If the N5102A digital moduleis not on, press Return > Return > N5102A Off On to On.

Digital datais now being transferred through the N5102A module to the PSG. The green status light should
be blinking. Thisindicates that the data lines are active. If the status light is solidly illuminated (not
blinking), all the data lines are inactive. The status light comes on and stays on (blinking or solid) after the
first time the N5102A module is turned on (N5102A Off On softkey to On). The status light will stay on until
the module is disconnected from its power supply.

NOTE If changes are made to the baseband data parameters, it is recommended that you first

disablethe digital output (N5102A Off On softkey to Off) to avoid exposing the device and the
N5102A module to the signal variations that may occur during the parameter changes.
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Millimeter-Wave Source Modules

You can extend the signal generator’s RF frequency using an Agilent 8355x series millimeter-wave source
modul e or any other external source module. The output frequency range depends on the frequency range of
the mm-wave source module. This section contains the following procedures:

= Using Agilent Millimeter-Wave Source Modules
= Using Other Source Modules

Using Agilent Millimeter-Wave Source Modules

The Agilent 8355x series millimeter-wave source modul e connects to the signal generator’s rear panel
SCOURCE MODULE | NTERFACE connector and allows for direct communication between the instruments
aswell as providing for automatic leveling control of the source module. If you want to use an 8355x series
source module without the automatic leveling or multiplier selection features, then refer to the section
“Using Other Source Modules’ on page 273.

Thefollowing isalist of equipment required for extending the frequency range of the signal generator:

= Agilent 8355x series millimeter-wave source module
= Agilent 8349B microwave amplifier (required only for the E8257D PSG without Option 1EA)
= RF output cables and adapters as required

NOTE Maximum insertion loss for cables and adapters connected to the E8267D PSG or ES257D
PSG with Option 1EA should be less than 1.5 dB. This will ensure maximum power from
the external source module.

Setting Up the External Source Module

CAUTION To prevent damage to the signal generator, turn off the line power to the signal generator
before connecting the source module interface cable to the rear panel SOURCE MODULE
I NTERFACE connector.

1. Turn off the signal generator’s line power.
2. Connect the equipment as shown.

= E8257D PSG without Option 1EA uses the setup in Figure 11-21.
= E8257D PSG with Option 1EA or E8267D PSG uses the setup in Figure 11-22.
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Figure 11-21 Setup for E8257D PSG without Option 1EA
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Configuring the Signal Generator

Figure 11-22
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1. Turnonthesignal generator’s line power.

Setup for E8267D PSG and E8257D PSG with Option 1EA

MM-WAVE SOURCE MODULE
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L

Leveled
Output

NOTE

amplitude ranges.

Refer to the mm-wave source modul e specifications for the specific frequency and

2. PressFrequency > (3 of 3) > Source Module, toggle the Agilent 8355x Source Module Off On softkey to On. The

signal generator will:

= recognize the Agilent mm-wave source module,

= switch the leveling mode to external/source module (power isleveled at the mm-wave source

module output),

= set the mm-wave source module frequency and amplitude to the source modul€'s preset values, and
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= display the RF output frequency and amplitude values available at the mm-wave source module
output when enabled

When the 8355x series mm-wave source is enable via the front panel Agilent 8355x Source Module Off On
softkey, the MMOD indicator in the FREQUENCY area and the MMindicator in the AMPLI TUDE area will
appear on the signal generator’s display.

3. If the RF OFF annunciator is displayed, press RF On/Off.
Leveled power should be available at the output of the millimeter-wave source module.

To aobtain flatness-corrected power, refer to “ Creating and Applying User Flatness Correction” on page 137.

Using Other Source Modules

Use the following procedure to extend the frequency range of the PSG with any external source module, or
to use the Agilent 8355x series millimeter-wave source modul€e’s without automatic leveling. The following
isalist of equipment required for extending the frequency range of the signal generator:

= externa millimeter-wave source module
= Agilent 8349B or other microwave amplifier (required only for the E8257D PSG without Option 1EA)
= RF output cables and adapters as required

Setting Up the External Source Module

1. Turn off the signal generator’sline power.
2. Connect the equipment as shown.

= E8257D PSG without Option 1EA uses the setup in Figure 11-23.
= E8257D PSG with Option 1EA or E8267D PSG uses the setup in Figure 11-24.
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Figure 11-23
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Configuring the Signal Generator

The following procedure configures a PSG for use with any external source module that hasa WR
(waveguide rectangular) frequency range of 90-140 GHz. You can modify the frequency range to match
your source module.

1. Turnon thesignal generator’s line power.

NOTE Automatic leveling at the source module output is not available with the OEM Source
Module selection.

2. PressFrequency > (3 of 3) > Source Module. Toggle the Agilent 8355x Source Module Off On softkey to Off.
3. Toggle the OEM Source Off On softkey to On.
4. Press OEM Source Module Config > Standard WR Freq Bands > WR8 90-140GHz.

The selections in the Standard WR Freq Bands menu are pre-defined frequency ranges and multipliers
for the most common external source module frequency ranges. They are provided for setup
convenience. If your source module has a frequency range not listed in the list of pre-defined setups, use
the Min Band Freq, Max Band Freq, and Freq Multiplier softkeysto manually set the range and PSG
frequency display multiplier. For more information on these manual settings, refer to the PSG Key
Reference.

5. If the RF OFF annunciator is displayed, press RF On/Off.

To obtain flatness-corrected power, refer to “ Creating and Applying User Flatness Correction” on page 137.
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12 Troubleshooting

This chapter provides basic troubleshooting information for Agilent PSG signal generators. If you do not
find a solution here, refer to the Service Guide.

NOTE If the signal generator displays an error, always read the error message text by pressing
Utility > Error Info.

“RF Output Power Problems” on page 278

“No Modulation at the RF Output” on page 282

* “Sweep Problems’ on page 283

» “Data Storage Problems’ on page 285

e “Cannot Turn Off Help Mode” on page 286

e “Signal Generator Locks Up” on page 287

e “Error Messages’ on page 289

e “Contacting Agilent Sales and Service Offices’ on page 292

e “Returning a Signal Generator to Agilent Technologies’ on page 293
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RF Output Power Problems

Check the RF QV GFF annunciator on the display. If it reads RF OFF, press RF On/0ff to toggle the RF
output on.

No RF Output Power when Playing a Waveform File

Preset the signal generator, then replay the waveform file.

If a header fileis not specified for awaveform, the signal generator uses a default header file with
unspecified settings. If you play awaveform file that has unspecified signal generator settings (settings not
saved to the file header, see page 82), the signal generator will use the header file settings from the
previously played file. If the previous header file had a marker routed to RF blanking, the RF output power
will be blanked. Preset the signal generator to return the RF blanking marker function to its default
state—off). Refer to the PSG Key Reference Marker section for more information.

NOTE If the default marker fileis used, ensure that the Pulse/RF Blank softkey is set to None.
Markers may have been set to Pulse/RF Blank by a previous file header.

RF Output Power too Low

1. Look for an OFFS or REF indicator in the AMPLI TUDE area of the display.

CFFStells you that an amplitude offset has been set. An amplitude offset changes the value shown in the
AVPLI TUDE area of the display but does not affect the output power. The amplitude displayed is equal to
the current power output by the signal generator hardware plus the value for the offset.

To eliminate the offset, press the following keys:
Amplitude > More (1 of 2) > Ampl Offset > 0 > dB.

REF tells you that the amplitude reference mode is activated. When this mode is on, the displayed
amplitude value is not the output power level. It isthe current power output by the signal generator
hardware minus the reference value set by the Ampl Ref Set softkey.

To exit the reference mode, follow these steps:

a. Press Amplitude > More (1 of 2).

b. Press Ampl Ref Off On until Off is highlighted.

You can then reset the output power to the desired level.

2. If you are using the signal generator with an external mixer, see “Signal Loss While Working with a
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Mixer” on page 279.
3. If you are using the signal generator with a spectrum analyzer, see “Signal Loss While Working with a
Spectrum Analyzer” on page 280.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no user-replaceable power
supply fuse. Refer to the Service Guide for instructions.

Signal Loss While Working with a Mixer

If you experience signal loss at the signal generator’s RF output during low-amplitude coupled operation
with amixer, you can solve the problem by adding attenuation and increasing the RF output amplitude of the
signal generator.

Figure 12-1 shows a hypothetical configuration in which the signal generator provides alow amplitude
signal to amixer.

Figure 12-1 Effects of Reverse Power on ALC
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=-8dBm =-8dBm
—_—
RF LEVEL
CONTROL > j j Lo
DETECTOR DETECTOR LO FEEDTHRU LO LEVEL
MEASURES MEASURES =-5dBm =+10 dBm
-8dBm -5dBm
ALC LEVEL REVERSE
POWER IF

Theinternally leveled signal generator RF output (and ALC level) is-8 dBm. The mixer isdriven with an
LO of +10 dBm and has an L O-to-RF isolation of 15 dB. The resulting L O feedthrough of -5 dBm entersthe
signal generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. Since
the detector responds to its tota input power regardless of frequency, this excess energy causesthe ALC to
reduce the RF output of the signal generator. In this example, the reverse power across the detector is
actually greater than the ALC level, which may result in loss of signal at the RF output.
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Figure 12-2 on page 280 shows a similar configuration with the addition of a 10 dB attenuator connected
between the RF output of the signal generator and the input of the mixer. The signal generator’'sALC level is
increased to +2 dBm and transmitted through a 10 dB attenuator to achieve the required -8 dBm amplitude at
the mixer input.

Figure 12-2 Reverse Power Solution
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Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces the LO
feedthrough (and the RF output of the signal generator) by 10 dB. Using the attenuated configuration, the
detector is exposed to a+2 dBm desired signal versus the -15 dBm undesired L O feedthrough. This 17 dB
difference between desired and undesired energy resultsin a maximum 0.1 dB shift in the signal generator’s
RF output level.

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the signal generator’s RF output when the signal
generator is used with a spectrum analyzer that does not have presel ection capability.

Some spectrum analyzers have as much as +5 dBm L O feedthrough at their RF input port at some
frequencies. If the frequency difference between the L O feedthrough and the RF carrier isless than the ALC
bandwidth, the LO’sreverse power can cause amplitude modulation of the signal generator’s RF output. The
rate of the undesired AM equals the difference in frequency between the spectrum analyzer’sLO
feedthrough and the RF carrier of the signal generator.

Reverse power problems can be solved by using one of two unleveled operating modes: AL C off or power
search.
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Setting ALC Off Mode

AL C off mode deactivates the automatic leveling circuitry prior to the signal generator’s RF output. In this
mode, a power meter is required to measure the output of the signal generator and assist in achieving the
required output power at the point of detection.

Use the following steps to set the signal generator to the ALC off mode:

Preset the signal generator: press Preset.

Set the desired frequency: press Frequency and enter the desired frequency.

Set the desired amplitude: press Amplitude and enter the desired amplitude.

Turn the RF off: set RF On/0ff to Off

Turn the signal generator’s automatic leveling control (AL C) off: press Amplitude > ALC Off On to Off.
Monitor the RF output amplitude as measured by the power meter.

Press Amplitude and adjust the signal generator’s RF output amplitude until the desired power is
measured by the power meter.

Nog~wWNE

Setting Power Search Mode

Power search mode executes a power search routine that temporarily activatesthe ALC, calibratesthe power
of the current RF output, and then disconnects the AL C circuitry. See the PSG Key Reference for more
information on the Power Search function.

Use the following steps to set the signal generator to manual fixed power search mode:

Preset the signal generator: press Preset.

Set the desired frequency: press Frequency and enter the desired freguency.

Set the desired amplitude: press Amplitude and enter the desired amplitude.

Turn the signal generator’s automatic leveling control (AL C) off: press Amplitude > ALC Off On to Off.
Turn the RF on: set RF On/0ff to On.

Press Do Power Search.

This executes the manual fixed power search routine, which is the default mode.

ok wbdrE

There are three power search modes: manual, automatic, and span.

When Power Search is set to Manual, pressing Do Power Search executes the power search calibration routine
for the current RF frequency and amplitude. In this mode, if thereis achange in RF frequency or amplitude,
you will need to press Do Power Search again.

When Power Search is set to Auto, the calibration routine is executed whenever the frequency or amplitude of
the RF output is changed.

When Power Search is set to Span, pressing Do Power Search executes the power search calibration routine
over aselected range of frequencies at one time. The power search corrections are then stored and used
whenever the signal generator istuned within the selected range of frequencies.
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No Modulation at the RF Output

Check the MOD QV CFF annunciator on the display. If it reads MCD OFF, press Mod On/0ff to toggle the
modulation on.

Although you can set up and enable various modulations, the RF carrier is modul ated only when you have
also set Mod On/0ff to On.

On the 8267D, for digital modulation, make sure that 1/Q Off On is set to On.
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Sweep Problems

Sweep Appears to be Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar. You can observe the
progress bar to determineif the sweep is progressing. If the sweep appears to have stalled, check the
following:

0 Haveyou turned on the sweep by pressing any of the following key sequences?
Sweep/List > Sweep > Freq
Sweep/List > Sweep > Ampl
Sweep/List > Sweep > Freq & Ampl

O Isthe sweep in continuous mode? If the sweep isin single mode, be sure that you have pressed the Single
Sweep softkey at |east once since completion of the prior sweep. Try setting the mode to continuous to
determine if the missing single sweep is blocking the sweep.

O Isthesignal generator receiving the appropriate sweep trigger? Try setting the
Sweep Trigger softkey to Free Run to determine if a missing sweep trigger is blocking the sweep.

O Isthesignal generator receiving the appropriate point trigger? Try setting the Point Trigger softey to Free
Run to determine if amissing point trigger is blocking the sweep.

O Isthedwell time appropriate? Try setting the dwell time to one second to determineif the dwell time was
set to avalue which was too slow or too fast for you to see.

0 Doyou have at least two pointsin your step sweep or list sweep?
Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.

In the sweep mode menu you can choose to set the sweep to various sweep types or to turn sweep off.
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Incorrect List Sweep Dwell Time

If the signal generator does not dwell for the correct period of time at each sweep list point, follow these
steps:

1. Press Sweep/List > Configure List Sweep.

This displays the sweep list values.
2. Check the sweep list dwell values for accuracy.
3. Edit the dwell values if they are incorrect.

NOTE The effective dwell time at the RF OUTPUT connector is the sum of the value set for the
dwell plus processing time, switching time, and settling time. This additional time added to
the dwell is generally afew milliseconds. The TTL/CMOS output available at the
TRIG OUT connector, however, is asserted high only during the actual dwell time.

If the list dwell values are correct, continue to the next step.
4. Observeif the Dwell Type List Step softkey is set to Step.

When Step is selected, the signal generator will sweep the list points using the dwell time set for step
sweep rather than the sweep list dwell values.

To view the step sweep dwell time, follow these steps:
a. Press Configure Step Sweep.

b. Observe the value set for the Step Dwell softkey.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. Only the
current list sweep isavailableto the signal generator. List sweep data can be stored in the instrument catal og.
For instructions, see “ Storing Files to the Memory Catalog” on page 60.
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Data Storage Problems

Registers With Previously Stored Instrument States are Empty

The savelrecall registers are backed-up by a battery when line power to the signal generator is not
connected. The battery may need to be replaced.

To verify that the battery has failed:

1. Turn off line power to the signal generator.
2. Unplug the signal generator from line power.
3. Plug inthe signal generator.

4. Turnonthesignal generator.

5. Observe the display for error messages.

If either error message —311 or =700 is stored in the error message queue, the signal generator’s battery
has failed.

6. Refer to the Service Guide for battery replacement instructions.

Saved Instrument State, but Register is Empty or Contains Wrong State

If you select aregister number greater than 99, the signal generator automatically selects register 99 to save
theinstrument state.

If the register number you intended to use is empty or contains the wrong instrument state, recall register 99:
Press Recall > 99 > Enter.

Thelost instrument state may be saved there.
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Cannot Turn Off Help Mode

1. Press Utility > Instrument Info/Help Mode
2. Press Help Mode Single Cont until Single is highlighted.
The signal generator has two help modes; single and continuous.

When you press Help in single mode (the factory preset condition), help text is provided for the next key you
press. Pressing another key will exit the help mode and activate the key’s function.

When you press Help in continuous mode, help text is provided for the next key you press and that key's
function isalso activated (except for Preset). You will stay in help mode until you press Help again or change
to single mode.
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Signal Generator Locks Up
If the signal generator islocked up, check the following:

» Makesurethat the signal generator is not in remote mode (in remote mode, the R annunciator appears on
the display). To exit remote mode and unlock the front panel keypad, press Local.

» Make sure that the signal generator is not in local lockout condition. Local lockout prevents front panel
operation. For more information on local lockout, refer to the Programming Guide.

» Check for aprogress bar on the signal generator display, which indicates that an operation isin progress.
*  PressPreset.

» Cycle power on the signal generator.

Fail-Safe Recovery Sequence

Use the fail-safe recovery sequence only if the previous suggestions do not resolve the problem.

CAUTION This process does reset the signal generator, but it also destroys the following types of data:

o all user files (instrument state and datafiles)
 DCFM/DC®M calibration data
e persistent states

NOTE Do not attempt to perform any other front panel or remote operations during the fail-safe
sequence.

To run the fail-safe sequence, follow these steps:

1. Hold down the Preset key while cycling power.
2. Continue to hold down the Preset key until the following message is displayed:

WARNING You areentering the diagnostics menu which can cause unpredictable instrument
behavior. Areyou sure you want to continue?

CAUTION Carefully read the entire message! It may list additional risks with this procedure.
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3. Releasethe Preset key.
4. To continue with the sequence, press Continue (to abort with no lost files, press Abort).

5. When the sequence concludes, do the following:

a. Cycle power.

Cycling power restores all previoudly installed options. Because calibration files are restored from
EEPROM, you should see several error messages.

b. Perform the DCFM/DC®M calibration.
Refer to the DCFM/DC®M Cal softkey description in the Key Reference.

c. Agilent Technologiesisinterested in the circumstances that made it necessary for you to initiate this
procedure. Please contact us at the telephone number listed at http://mww.agilent.com/find/assist. We
would like to help you eliminate any repeat occurrences.
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Error Messages

If an error condition occursin the signal generator, it isreported to both the front panel display error queue
and the SCPI (remote interface) error queue. These two queues are viewed and managed separately; for
information on the SCPI error queue, refer to the Programming Guide.

NOTE When there is an unviewed message in the front panel error queue, the ERR annunciator
appears on the signal generator’s display.

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Circular (rotating).

Overflow Handling Drops oldest error as new error comesin.

Viewing Entries Press: Utility > Error Info > View Next (Or Previous) Error Page

Clearing the Queue | Press: Utility > Error Info > Clear Error Queue(s)

Unresolved Errors® | Re-reported after queueis cleared.

When the queue is empty (every error in the queue has been read, or the queueiis cleared), the
No Errors following message appears in the queue:
0 No Error Message(s) in Queue

a. Errors that must be resolved. For example, unlock.

Error Message File

A complete list of error messages is provided in the file errormessages.pdf, on the CDROM supplied with
your instrument.

In the error message list, an explanation is generally included with each error to further clarify its meaning.
The error messages are listed numerically. In cases where there are multiple listings for the same error
number, the messages are in alphabetical order.
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Error Message Format

When accessing error messages through the front panel display error queue, the error numbers, messages
and descriptions are displayed on an enumerated (“1 of N”) basis.

Error messages appear in the lower-left corner of the display asthey occur.

Error Description

Error Number Error Message (May be truncated on the display)
A A

r NS A\

=222 Data out of range; wvalue clipped to lower limit.

Indicates that the user has entered a deviation, depth or internal
source frequency that is beyond the specified limits. y
\

'

Explanation provided in the Error Message List
(This is not displayed on the instrument)
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Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query error will
not generate a device-specific, execution, or command error.

Query Errors (—499 to —400) indicate that the instrument’s output queue control has detected a problem
with the message exchange protocol described in IEEE 488.2, Chapter 6. Errorsin this class set the query
error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors correspond to message
exchange protocol errors described in IEEE 488.2, 6.5. In this case:

» Either an attempt is being made to read data from the output queue when no output is either present or
pending, or

» datain the output queue has been lost.

Device Specific Errors (—399 to —300, 201 to 703, and 800 to 810) indicate that a device operation did not
properly complete, possibly due to an abnormal hardware or firmware condition. These codes are also used
for self-test response errors. Errorsin this class set the device-specific error bit (bit 3) in the event status
register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that the
instrument detected an error within the GPIB system, within the instrument’s firmware or hardware, during
the transfer of block data, or during calibration.

Execution Errors (—299 to —200) indicate that an error has been detected by the instrument’s execution
control block. Errorsin this class set the execution error bit (bit 4) in the event status register (IEEE 488.2,
section 11.5.1). In this case:

» Either a<PROGRAM DATA> element following a header was evaluated by the device as outside of its
legal input range or is otherwise inconsistent with the device's capabilities, or

» avalid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression eval uation operations are completed. Rounding
anumeric data element, for example, is not reported as an execution error.

Command Errors(—199 to —100) indicate that the instrument’s parser detected an |EEE 488.2 syntax error.
Errorsin this class set the command error bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1).
In this case:

» Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message was
received that isin violation of the | EEE 488.2 standard. Possible violations include a data element that
violates device listening formats or whose type is unacceptabl e to the device.), or

» an unrecognized header was received. These include incorrect device-specific headers and incorrect or
unimplemented |EEE 488.2 common commands.
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Contacting Agilent Sales and Service Offices

Assistance with test and measurement needs, and information on finding aloca Agilent office are available
on the Internet at:
http: //mww.agilent.com/find/assi st

You can also purchase E8257D/67D PSG accessories or documentation items on the Internet at:
http: //mww.agilent.com/find/psg

If you do not have access to the Internet, contact your field engineer.

NOTE In any correspondence or telephone conversation, refer to the signal generator by its model
number and full serial number. With this information, the Agilent representative can
determine whether your unit is still within its warranty period.
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Returning a Signal Generator to Agilent Technologies
To return your signal generator to Agilent Technologies for servicing, follow these steps:

1. Gather as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed on the Internet (http://www.agilent.com/find/assist) that is specific to your
geographic location. If you do not have access to the Internet, contact your field engineer.

After sharing information regarding the signal generator and its condition, you will receive information
regarding where to ship your signal generator for repair.

3. Ship the signa generator in the original factory packaging materials, if available, or use similar
packaging to properly protect the signal generator.
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Symbols
dM, 18, 155

Numerics
003, option, 4
004, option, 4
005, option, 4
007, option, 2, 7, 46
015, option, 4
10 MHz connectors, 29, 30
128QAM 1/Q modulation, creating, 179
1410, application note, 214, 224
1E1, option, 3
1EA, option, 3
1ED, option, 4
1EH, option, 4
1EM, option, 4
2's complement description, 255, 268
27 kHz pulse, 41
601/602, option
custom arb mode, 77, 161, 162
custom real-time mode, 189, 190
description, 4, 7
multitone mode, 213, 214
symbol rates, 175
two-tone mode, 223, 224
802.11b, 132
8757 network analyzers, 52
8757D scalar network analyzer, 41, 46-55

A

AC power receptacle, 28
ACP, 78, 168, 198
active entry area (display), 18
adding & editing (instrument state), 62
adjustments, display, 14
Adgilent PSG web page, 1
ALC

annunciator, 18

bandwidth selection, 132

input connector, 12

input connector (rear), 33

Index

ALC (continued)
limitations, amplitude, 134
off mode, setting, 281
with attenuator option, 136
ALC hold
description, 99
saving setting, 98
apha adjustment (filter), 168
aternate ramp sweep, 52
AM, 18, 153
amplifier, microwave, 270, 273
amplitude
display area, 20
hardkey, 10
LF output, 158
modulation. See AM
ramp sweep, 53
reference & offset, 40
analog modulation, 7, 151-159
analog PSG
optional features, 2
standard features, 2
annunciators, 18
application notes
1410, 214, 224
obtaining, 1
ARB
AWGN, 231
file catalogs, 59
reference, setting, 187
triggers, 113
waveform clipping, 119-126
waveform file headers, 80-90
waveform scaling, 127-129
See also custom arb waveform generator
See also dual arbitrary waveform generator
arb, 78
ARMED annunciator, 18
arrow hardkeys, 14
ATTEN HOLD annunciator, 18
attenuator, external leveling, 136
AUTOGEN_WAVEFORM file, 91
automatic leveling control. See ALC

Index
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Index

AUXILIARY /O connector, 26

AUXILIARY INTERFACE connector, 30

AWGN
ARB, 231
dua ARB player, 95
real-time, 231

B

bandwidth
ALC, selecting, 132
reference oscillator, adjusting, 149
baseband
clipping, 119-126
scaling, 127-129
baseband generator, 78
AWGN, 231
custom arb mode, 7, 161
custom real-time I/Q mode, 7, 189
dual arb mode, 8, 77
multitone mode, 8, 213
REF IN connector, 25
settings, 202, 203
two-tone mode, 8, 223
basic operation
digital, 77
standard, 35
BbT, adjusting, 168
binary files, 59
bit files, 59
bits per symbol, equation, 206
BURST GATE IN connector, 25
burst shapes, 197-201
bursted signals, 132

C
carrier bandwidth, 95

carrier feedthrough, minimizing, 219, 228

carrier signal, modulating, 58

carrier to noise ratio, 95

CCDF curve, 124-126, 221

CDMA, 132

ceiling function, bits per symbol, 206
certificate, license key, 71

circular clipping, 125

clipping
CCDF curve, 124-126
circular, 122, 125
concepts, 119-124
procedure, 125, 126
rectangular, 122, 126
clock adjustment
phase and skew, 247
clock rate limits, logic type output, 237
clock source
setting, 258, 265
clock timing
parallel data, 242
paralel interleaved data, 245
phase and skew, 247
serial data, 247
clocking, frequency reference, 240
clocking, frequency reference diagrams, 241
Clocks Per Sample
parallel data, 242
paralel interleaved data, 245
COH connector, 28
comments, adding & editing (instrument state), 62
common frequency reference diagrams, 241
component test, 78
concepts
differential data encoding, 205
FIR filters, 167
waveform clipping, 119-124
waveform markers, 98
waveform scaling, 127-129
confidential data, 64
connections
common frequency reference, 241
connectors
external triggering, 116
external triggering source, 117
front panel, 9
rear panel, 22
continuous
list sweep, 46
step sweep, 43
triggering, 114
continuous wave
configuring, 38
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continuous wave (continued)
description, 7
contrast adjustments (display), 14
correction array (user flatness)
configuration, 139
load from step array, 139
viewing, 140
See also user flatness correction
couplerg/splitters, using, 133
custom arb, 79
custom arb waveform generator, 7, 161-187
custom mode, 78
custom real-time |I/Q baseband, 7, 189-212
CW mode
configuring, 38
description, 7

D

DAC over-range errors, 127-129
DATA
input connector, 16
input connector (rear), 33
data
clock, 203
encoding, differential, 205-212
fields, editing, 37
files, 59
framed, 114
input methods, 64
patterns
triggering, 113
using, 191
removal, 68
sensitive, 64, 63
storage
problems, 285
security, 64
See also instrument state register
See also memory catalog
unframed, 114
DATA CLOCK
input connector, 15
input connector (rear), 33
datafiltering, pre or post fir, 255, 268
data sheets, 1

Index

data types, 250
DC detector, 41
DC offset, 154
declassification, 64
default FIR filter, restoring, 169
delay, external trigger signal, 115
Delete Item softkey, 37
Delete Row softkey, 37
description, adding & editing (instrument state), 62
detector
diode response, 135
using, 133
device clock source selection, 258, 265
DHCP, 73
diagram
data types, 250
diagrams
clock timing, parallel data, 242
clock timing, parallel interleaved data, 245
clock timing, phase and skew, 247
clock timing, serial data, 247
common frequency reference, 241
differential data encoding, 205212
DIG BUS annunciator, 18
Digital Bus connector, 25
digital modulation
annunciators, 20
custom, 161-187, 189-212
formats, 7
multicarrier, 162, 165, 186
multitone, 213-222
two tone, 223-230
digital signa interface, 236
digital signal interface module, 236
diode detector response, 135
discrete steps, skew range, 247
display
blanking, 70
contrast decrease, 14
contrast increase, 14
descriptions, 17
overview, 17
secure, 70
DMOD files, 59
documentation options, 5

Index
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downloading firmware, 5
dual arb, 78

dual ARB player, 8, 91-96
Dua ARB real-time noise, 95

dual arbitrary waveform generator, 8, 91-96

dwell time, 42

E

E8257D
optional features, 2
standard features, 2
E8267D
optional features, 4
standard festures, 4
Edit Item softkey, 37
Erase All, 68, 69, 70
erasing memory, 64, 68, 69, 70
ERR annunciator, 18, 289
error messages
DAC over-range, 127-129
display, 21
message format, 290
overview, 289
queue, 289
types, 291
EVENT connectors, 24
EVM, 168, 198
EXT
annunciators, 18, 19
INPUT connectors, 12
input connectors, 12
input connectors (rear), 32
extend frequency, 56
extend frequency range, 56
external
data clock, setting, 203
detector, diode response, 135

external clock source selection, 258, 265

external FM, 154
external 1/Q modulation, 185
external source module, 270
external trigger

connection, 116

gated, setting, 116

external trigger (continued)
single, setting, 186
source connector, 117

F

fail-safe recovery sequence, 287
failures. See troubleshooting
fall delay, burst shape, 198
fall time, burst shape, 198
FAQ, 1
features, signal generator, 2
feedthrough, carrier, minimizing, 228
file headers (ARB waveform), 80-90
file store
files, 61
catalogs, 59
using, 60
waveform segments, 92-96
waveform sequences, 93-95
See also instrument state register
See also memory catalog
filtered & unfiltered samples, 255, 268
filters
interpolation, 127-128
using, 167-174
FIR, 59, 167
firmware
options, 5
upgrades
obtaining, 5
using GPIB, 5
using LAN, 5
using RS-232, 5
flatness correction. See user flatness correction
FM, 19, 154
FM/®M hardkey, 11
formula, skew discrete steps, 247
framed data, 114
free run trigger response, 114
frequency
display area, 18
hardkey, 10
modulation. See FM
offset, 39
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frequency (continued)

ramp sweep, 47

ranges, 2

reference, 39

RF output, setting, 38
frequency extension, 56
frequency output limits, clock rates & logic levels,

237

frequency range, 56
frequency reference

common, 240

hookup diagrams, 241
front panel

description, 9-21

disabling keys, 70
FSK

files, 59

modulation, 178, 183, 184

G

GATE/PULSE/TRIGGER
input connector, 14
input connector (rear), 32
gated, 156
gated triggering, 114, 116
Gaussian filter, selecting, 168
Goto Row softkey, 37
GPIB, 29, 142

H

hardkeys, 9-14

hardware, configuring, 186, 202
Help hardkey, 11

help mode troubleshooting, 286
Hold hardkey, 14

| input connector, 16
| input connector (rear), 33
| OUT connector, 27
I/O connector, auxiliary, 26
1IQ
4QAM state map, 206
annunciator, 19

Index

1/Q (continued)
files, 59
input connectors, 16
modulation, 182, 210
scaling, adjusting, 203
1/Q waveform
clipping, 119-126
scaling, 127-129
I-bar OUT connector, 27
IMD. See intermodulation distortion
Incr Set hardkey, 13
information
additional PSG, 1
protecting sensitive, 64
Insert Item softkey, 37
Insert Row softkey, 37
installing firmware, 5
instrument state register
comments, adding and editing, 62
troubleshooting, 285
using, 61
See also memory catalog
instrument states, 52
int gated, 156
interface connectors
AUXILIARY INTERFACE, 30
GPIB, 29
LAN, 30
RS-232, 30
interface, remote, 142
intermodulation distortion
how to minimize, 121
testing non-linear devices, 214, 224
internal clock source selection, 258, 265
interpolation filter, 127-128
1Q
clock rates, 238
modulation, 185
1Q modulation, 185

K
key, license, 71
keypad, numeric, 13
keys

disabling, 70

Index
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keys (continued)
front panel, 9-14
knob, front panel, 10

L

L (listener mode) annunciator, 19
lan configuration, 73
LAN connector, 30
LEDs, 14, 15
leveling
ALC, 12, 281
external, 133-136
internal, 132
mm-wave source module, using, 270
LF OUT connector, 32
LF output, 12, 157-159
license key, 71
limits, clock & sample rates, logic outputs, 237
line power LED, 14
list
error messages, 289
files, 59
mode values table editor, 36
sweep, 43, 284
listener mode annunciator, 19
L oad/Store softkey, 37
Local hardkey, 14
logic type
output levels, 237
selecting, 252
low frequency output. See LF output

M

magnitude error simulation, 182
manual freq softkey, 52
manual sweep, 52
markers

output, 31

ramp sweep, 49

waveform, 97-112
master/slave setup, 54
MDMOD files, 59
media storage, 64

memory, 91
base instrument, 64
baseband generator, 64
catalog, 59, 285
See also instrument state register
erasing, 64, 68
hard disk, 64
overwriting, 68
persistence, 64
physical location, 64
sanitizing, 69
secure mode, 69
size, 64
types, 64
waveform, 64
writing to, 64
menus
marker, 102
marker polarity, 112
trigger, 115
MENUS hardkeys, 11
microwave amplifier, 270, 273
Millimeter, 270
millimeter-wave source module, 270
mixer, signal loss while using, 279
mm-source, 56
mm-wave source module
extending frequency range with, 270
leveling with, 136
user flatness correction array, creating, 142—148
mod on/off, 12, 19
models, signal generator, 2
modes of operation, 7
modes, triggering, 114
modulation
amplitude. See AM
analog, 7, 151-159
analog waveforms, 152
annunciators, 18-20
applying, 57
digital, 7
file catalogs, 59
frequency. See FM
multicarrier, 162, 165, 186
on/off hardkey, 12
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modul ation (continued)
phase. See ®M
predefined setups, 163, 190
pulse, 7, 156
types, 178
user-defined, 164, 210
See also digital modulation
module user interface location, 251, 261
MSK modulation, 178
MTONE files, 59
multicarrier waveform, 162, 165, 186
multitone, 78
multitone mode, 8
multitone waveform generator, 213-222

N

N5102A, 236
baseband data, 251
clock rates, 236
clock settings, 256, 263
clock source
description, 239
clock timing, 236, 242
common frequency reference, 240
connections to clock and device, 248
data parameters, setting, 253, 266
data types, 250
digital data, 269
frequency reference connector, 241
generating data, 260
input direction, 261
input mode, 250, 260
interleaving clock timing, 245
logic type, port configuration, 262
logic types, 252
output direction, 253
output mode, 250, 251
phase and skew clock timing, 247
seria clock timing, 247
user interface, 251
user interface module, 261
N5102A digital signal interface module, 236
negation description, 256, 269
noise, 95, 231
noise bandwidth factor, 95

non-linear devices, testing, 214, 224
non-volatile memory, 91

numeric format selection, 255, 268
numeric keypad, 13

NVMKR files, 59

nvwfm, 91

NVWFM files, 59

Nyquist filters, 168

0

OFDM, 132
offset, 39, 40, 154
offset binary use, 255, 268
on/off switch, 15
operation
basics, 35
digital basics, 77
modes of, 7
option 015, 185
options
003, 4
004, 4
005, 4
007, 2,7, 46
015, 4
1E1, 3
1EA, 3
1ED, 4
1EH, 4
1EM, 4
601/602
basic digital operation, 77
custom arb mode, 161, 162
custom real-time mode, 189, 190
description, 4, 7
multitone mode, 213, 214
two-tone mode, 223, 224
using symbol rates, 175
additional information, 5
enabling, 71
UNR, 3, 149
UNT, 3, 7, 151-155, 157
UNU, 3, 7, 151, 152, 156
UNW, 3,7, 151, 152, 156
oscillator, reference, adjusting BW, 149

Index
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output levels, logic types, 237
output power, troubleshooting, 278
output. See LF output and RF output
OVEN COLD annunciator, 19
over-range errors, 127-129
overwriting memory, 68

P

Page Down softkey, 37
Page Up softkey, 37
parallel
clock rates, 238
data clock timing, 242
interleaved data clock timing, 245
sample rates, 238
PATTERN TRIG IN connector, 24
peak to average power
CCDF curve, 124, 221
high ratios, 121
multitone characteristics, 221
reducing, 122
performance, optimizing, 131-149
peripheral devices, 236
digital signal interface module, 235

millimeter wave source module, 235

phase
error smulation, 182
modulation. See ®M
polarity, 204
phase clock timing, 247
player, dua ARB, 91-96
polarity
marker setting, saving, 80
markers, 112
trigger, external, 115
port configuration, selecting, 252
power
meter, 137, 281
output, troubleshooting, 278
peaks, 119-124
receptacle, AC, 28
search mode, 281
supply troubleshooting, 279
switch, 15
PRAM, 78

predefined filters, 167

predefined modulation setups, 163, 190

pre-fir samples selection, 255, 268
Preset hardkey, 14
private data, 64
problems. See troubleshooting
product information, 1
proprietary data, 64
protecting data, 64
PSG
additional information, 1
firmware, 5
modes of operation, 7
options, 5
web page, 1
PSK modulation, 178
pulse, 132
annunciator, 19
input, 14
input (rear), 32
modulation, 156
pulse modulation, 7, 41
pulse source, 41, 156
PULSE SYNC OUT, 32
PULSE VIDEO OUT, 32
pulse, marker, viewing, 110
PULSE/TRIG GATE INPUT, 32

Q

Q input connector, 16

Q input connector (rear), 33

Q OUT connector, 27

QAM modulation, 178, 206

Q-bar OUT connector, 28

QPSK 1/Q modulation, creating, 181
queue, error, 289

R

R (remote) annunciator, 19
ramp sweep, 46-55

rea time, 78

real-time AWGN, 231
real-timel/Q, 189-212
real-time mode, 7, 79
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real-time noise, 95
real-timetriggers, 113
rear panel description, 22
Recall hardkey, 10
recall state, 52
recall states, 61
receiver test, 78
recovery sequence, fail-safe, 287
rectangular clipping, 126
reference
amplitude, setting, 40
frequency, setting, 39
oscillator bandwidth, adjusting, 149
registers, 61, 62
remote operation, 11, 142
remote operation annunciator, 19
reset & run trigger response, 114
response, triggering mode, 114
restricted data, 64
Return hardkey, 14
returning asignal generator, 293
RF blanking, 278
marker function, 111
settings, saving, 98
RF output
annunciator, 19
configuring, 38
connector, 13
connector (rear), 32
leveling, external, 133-136
mm-wave source module, using, 270
On/Off hardkey, 13
sweeping, 41
troubleshooting, 278
user flatness correction, 137-148
rise delay, burst shape, 198
rise time, burst shape, 198
root Nyquist filters, 168
routing, marker
ALC hold, 99
RF blanking, 111
saving settings, 98
settings, saving, 80
RS-232 connector, 30
runtime scaling, 129

S
S (service request) annunciator, 19
sample

rates, 236

Index

rates, parallel/parallel intrlvd port configuration,

238
rates, serial port configuration, 237
type selection, 255, 268
samples
baseband, 127-128
interpolated, 127-128
sanitizing memory, 69
save and recall, 52
save and recall states, 61
savefiles
Save hardkey, 10
scalar network analyzer, 41, 46-55
scalar pulse, 41
scaling
concepts, 127-129
procedure, 129
runtime, 129
waveform data, 129
SCPI, 73
SCPI commands, 11
secure display, 70
secure mode, 69
security functions, 64, 69
security level, 69
segment advance triggering, 114, 118
sensitive data, 64
Seq files, 59
sequences
building and storing, 93
deleting, 62
editing, 94
instrument state register, 61
marker control, 108
playing, 94
triggering, 113
serial
clock and sample rates, 237
clock timing, 247
service reguest annunciator, 19

service, Agilent sales and service offices, 292
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shape files, 59
signal generator

features, 2

firmware, 5

models, 2

modes, 7

options, 5

overview, 1
signal loss, troubleshooting, 278
Signa Studio software, 214, 224
single step sweep, 42
single trigger mode, 114
single trigger, setting, 186
skew

clock timing, 247

range, 247
SMI connector, 28
softkeys, 10, 21, 37
software

available for PSG, 1

options, 5
source module, 270

SOURCE SETTLED OUTPUT connector, 32

source, external trigger, 115
spectral regrowth, 121

spectrum analyzer, troubleshooting signal loss, 280

square pulse, 41

standby LED, 15

statefiles, 59

State registers, 52

step array (user flatness), 137
See also user flatness correction

step attenuator, external leveling, 136

step sweep, 42-43
STOP SWEEP connector, 31
storage, troubleshooting, 285
Sweep

27 kHz pulse, 41

8757Dscalar network analyzer, 41

annunciator, 20
DC detector, 41
list, 43

mode, 7

output, 31
ramp, 46-55

sweep (continued)

RF output, 41

scalar network analyzer, 41

scalar pulse, 41

step, 42

trigger, 45

troubleshooting, 283
sweep progress bar, 41
Sweep/List hardkey, 11
switch, power, 15
symbol rates, 175
SYMBOL SYNC

input connector, 15

input connector (rear), 33
SYNC OUT connector, 13
SYNC OUT connector (rear), 32

T

T (talker mode) annunciator, 20
table editor, using, 36-37
talker mode annunciator, 20
TCP/IP, 73
technical support, 1
text display area, 21
trigger
hardkey, 11
inputs
GATE/PULSE/TRIGGER, 14

GATE/PULSE/TRIGGER (rear), 32

PATTERN TRIG IN, 24
TRIGGERIN, 31
output, 31
setting, 45
trigger & run, 114
trigger in, 156
trigger polarity, 156
triggers, 113-118, 186
troubleshooting, 277-293
two tone, 8, 78, 223-230

v

unfiltered & filtered samples, 255, 268

unframed data, 114
UNLEVEL annunciator, 20
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UNLOCK annunciator, 20
UNR, option, 3, 149
UNT, option, 3, 7, 151-155, 157
UNU, option, 3, 7, 151, 152, 156
UNW, option, 3, 7, 151, 152, 156
upgrading firmware, 5
user flatness, 59, 137148
user interface location, module, 251, 261
user-defined
burst shape curves, 199
data patterns, 193
files, 59
filters, 169, 171
modulation type
custom arb, 164
real-time 1/Q, 179, 210

\Y

vector PSG

optional features, 4

standard features, 4
VIDEO OUT connector, 13
VIDEO OUT connector (rear), 32
volatile memory, 91

W

warranted logic output clock rates, 237
waveform memory, 64
waveforms
analog modulation, 152
ARSB file headers, 8090
CCDF curve, 124-126
clipping, 119-126
custom, 161-187
custom real-time 1/Q baseband, 189-212
DAC over-range errors, 127-129
file catalogs, 59
interpolation, 127-128
markers, 97
multicarrier, 162, 165, 186
multitone, 213-222
player, dual ARB, 91-96
samples, 127-128
scaling, 127-129

waveforms (continued)
segments, 92-96
sequences, 93-95, 108
statistics, 125-126
triggering, 113
two-tone, 223-230
utilities, 125-126
web server, 73
website, 1
wfmi, 91
WFM1 files, 59
WIDEBAND | INPUT connector, 27
wideband IQ, 185
WIDEBAND Q INPUT connector, 27

Z
Z-AXIS BLANK/MKRS connector, 31

Index

Index
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